YouTube plugin doesn't work anymore (2.378)

Hi, after the last upgrade to 2.378 version, when I select YouTube the following 3 messages appear:

  1. ! Browse error - An error occurred while browsing the folder (in red, but what folder ?)
  2. Volumio has no permissions - Grant Volumio access to your TouTube account to access your playlist (in blue)
  3. YouTube - Fetching data from Youtube. This may take some time (in blue)

I put a string in the search box and the I received the last message again.
I waited, but nothing happened … I tried to update the plugin and to re-enable it, without results.
How can I authorize the access ? Before I didn’t do anything and all worked very well.
Or the problem is another?


I noticed that in the page Installed Pluging (Setting) there is an item:
Accounting Setting

  • Please grant Volumio read-only access to your YouTube account. Enter this code on
  • Code: NVJY-GJNV (auto-setted)

This code may cause the error?

None have this problem? Or none use the YouTube plugin?

Since I received too many answers and advice… so I tried to do it myself. :wink:

  1. I disabled the plugin
  2. I enabled it again and the displayed code in the Account Setting changed
  3. from the web interface I clicked on the link: (without steps 1 & 2 I got “Code error”)
  4. I entered the new displayed code and authorized the device on my Google account

Now it finds and plays music and does not return the initial " Browse error " anymore.
But I don’t remember doing this in the past when I upgraded the system to a new version.

Hi all,

It seems the code has to be really “fresh” to be accepted by Google / Youtube.
This is the reaseon why one has to disable/enable the plugin to get a new one.

Would be interesting for how long one can wait to register it until the “wrong code. please retry” message appears when trying to register the device.

I think this - and also the URL should be mentioned somewhere in the plugin.

  • Josef

I’m experiencing the following with Version 2.526 in the latest Chrome-Browser on Mac OS X

  • Installing plugin Youtube Playback
  • Activating Youtube Playback
  • Entering settings
  • Copying the code
  • Log in to google
  • Entering
  • Pasting the code
  • Following the steps granting permission to Volumio Youtube connection
  • Last step is telling me, the connection has been successfully established
  • When entering there is no Volumio Youtube visible
  • The plugin does not work and gives error messages “volumio hs no permissions”

Uninstalling and deactivating/reactivating the plugin, entering the newly generated code to my google account does not help.
How can I make it work?

Many thanks and best regards

Had the same issue. Reset and reinstalled the Volumio. Problem solved.
Good luck!

I used an older version of Volumio and as of April 2019, there has been a change in the way Youtube handles these requests regardless of version used, what you do to login and register your device

I am unable to activate the plugin either… who can actually fix this?

Ok, got it working…this is the sequence of events needed apparently

  • uninstall current version of plugin (not sure if needed)

  • reinstall youtube plugin

  • activate in ‘active plugins’

  • goto settings of the Youtube plugin add the code to google’s url as in description (browser)

  • goto Volumio home youtube search, find out not working

  • go back to plugins and select settings Youtube plugin

  • you will now get the message that access is granted…


(Btw Volumio, this plugin and Netsky rule! :wink: )

Thank you this just worked for me :slight_smile:

Hi, I can’t see the youtube plugin code. Can you help me?


Just be patient, wait a while, and retry.
It seems the servers at google sometimes do not respond

Best Regards

Unfortunately I also tried to install Volumio2 again. It works everything except the youtube plugin.
does not give me the google device authorization code.
Does it work for you?

Mine does not search Yuotube anymore and neither do I get a new pairing code

I have the same problem. And the code field is empty

Me too.
not wor.png

I have the same problem. This problem start six days ago.
I try to install past version of Volumio (2.513), bat i don’t risolve this problem.

Same problem, i get no code.

Same issue here. The code field is empty.

this worked for me also in the past, but however, now Volumio does not display a code anymore, so what to enter at ?