YouTube plugin doesn't work anymore (2.378)

Hi all,
I have the same problem.
No code displayed in the plugin so impossible to fill in the device google page, and to get an access granted for YouTube :cry:

The problem is known…
please be patient… :wink:

Thank you!

Oops, sorry, I hadn’t seen this :blush:
Thanks for your answer :slight_smile:

As far as I can tell this message was not yet posted in this thread. Does make me wonder how long they’ll make us wait :wink:

News?
youtube no news :unamused:

Any news about this great plugin ?

Some more work has been submitted, and we will test this week. Hopefully, good news soon

Thanks michelangelo :slight_smile:

looking forward to this too :stuck_out_tongue:

Hi
A big thank you to the developers for the plugin. It is one of the best features of Volumio. I shall look forward to seeing the plugin updated and working again.

hoping nobody from volumio team is ill with covid-19 :confused: :confused:
Please let us know if there are some news about YT plugin

Big thanks for all good work here :stuck_out_tongue:

Updated 25-2-2020 but still not working (Volumio 2.714)

YT-1.jpg
YT-2.jpg

YouTube plugin doesn’t work on my Volumio… No news?

Like Vlado64, the same problem…

Hi this same problem. btw during first 30-40 sec after reinstall yt plugin works (it is possible to add some playlist from subscribtions :laughing: )
pls let us know when we can be able to use yt on volumio or the beter way is change the app which has now problem with yt.

Yess its patectic that youtube pluggin is not working properly.Only some times we may able to get the subsction pae loaded.Else it shows the folder is empty.

This is the problem:
Youtube plugin requires an API key from Google (which we obtained). However, this API key is allowed to perform maximum 10k calls per day.
In this situation, the max quota is reached within minutes (Volumio has lots of users, and 10k requests is a very short limit for such large userbase).
We asked Google to raise that limit, but it was denied because their Terms of Service states that we MUST show also the video, not just play the audio.
So, to make Youtube working again we need to modify heavily how Volumio works to allow audio+video. This takes long time and in the meantime I’ve removed the youtube pluign.
We were looking for alternative solutions, but there does not seem to be one that fits our needs.

So, for the meantime, avoid installing the youtube plugin (I guess those who are using it do install it via SSH) since it will just be a frustrating experience…

Thanks for the update !

Hello, what is the ETA on solving the Youtube issue? are we looking at months vs weeks?

Actually we don’t know if it will be ever be solved… Since to have youtube playback going again we must probably add video playback to volumio…