[Volumio] with new rpi zero W

Hi there,

is there a way to install Volumio into the new rpi Zero W (Wifi & BT embeded) ?



Should work as-is I guess, as it has mostly same wifi as RPi3.
Have you tried to flash latest 2.114 image?

No yet, i just test to put my sd card from the pi zero 1.3 to the pi zero W… and there is no boot at all…

I will try to flash a new sd with the last version and keep u inform if it working good.


You’ll need the firmware from 3 March RPi update to get the wifi working, then it’s much the same as the standard Zero.

Hi again,

When i try to update the firmware oh the rpi zero W with sudo rpi-update command in ssh, i get the message :

This tool requires you have readelf installed, please install it first
In debian, try : sudo apt-get install binutils >> message : binutils is not available…
In Arch, try : pacman -S binutils >> command not found

Thanks for your help SO how to update the firmware of the pi zero W ?

apt-get update ?
apt-get upgrade ?

sudo apt-get update sudo apt-get dist-upgrade

I don’t think you really want to update the kernel to 4.9.x at this stage, but mostly other firmware files (in particular get bcm2708-rpi-0-w.dtb).
So better try: sudo SKIP_KERNEL=1 BRANCH=stable rpi-update If it doesn’t work after such update, then kernel update may be necessary, but this may break other things in Volumio (I do not think 4.9.x has been much tested yet).

Other (maybe safer) option maybe is to pull latest 4.4.x Raspian lite image, and get it’s /boot firmware files (except kernels) onto the /boot partition of Volumio SD (which the previous command somehow does).
You may want to look at /lib/firmware/brcm/ in running Rapbian image, and eventually copy over those wifi card firmware to same location inside Volumio: maybe it has updated firmware for PiZero W wireless chipset (very similar to the one of Pi3, but still different).

EDIT: final solution for 2.118 is here. Newer images do not need this.

Hello there,

at the moment, the embeded wifi of my pi zero w still don’t work…

  • i done the update of volumio of today in 2.118 > no change for the pi zero w support inside.

Volumio still working after that but Samba is dead and still no wifi embeded enabled

-sudo SKIP_KERNEL=1 BRANCH=stable rpi-update still return this :

This tool requires you have readelf installed, please install it first
In debian, try : sudo apt-get install binutils >> message : binutils is not available…
In Arch, try : pacman -S binutils >> command not found

  • finally, i find this file firmware : bcm2708-rpi-0-w.dtb in the /boot directory of the raspbian lite image, and i add it to the /boot directory of volumio micro sd, and it’s seems to work !!! i’am testing and keep u inform.

Thanks everybody.

Hi again,

i have a FX AUDIO D802 Full Digital working with my “rpi zero” in USB Output mode but with the rpi zero w same things, i ve got the Error message when i play a track :

Failed to open audio output…

Any idea ?

Did you do a dist-upgrade at all?
It should be avoided: you may want to restart from an original image and just add bcm2708-rpi-0-w.dtb in /boot.

OK undestood !! I’am restarting from an original volumio image, then i copy/past bcm2708-rpi-0-w.dtb in /boot, then i put the micro sd into the rpi zero w, then i cross my fingers…

So, all is working fine (wifi, webradio, NAS, Samba, playlist…) , except the USB output >>>my FXAUDIOD802 :frowning:

Error : Failed open audio output.

I tested all options below.

I don’t understand why.

i find the problem !!!

if i put an “USB Hub” between the pi zero W and the FXAUDIO AMP, it’s working !!!

but I want to plug the “one” micro usb of the pi zero w directly to the AMP please ???

Is there a solution please ?

You know, it’s a quite a hack-ish way.
You may want to copy over all the *.elf, *.bin, *.dat from March 3rd Raspbian image, and eventually also copy overlay files: *.dtb and overlay folder (replace)
No guaranties it would work though: be prepared to go back (maybe do it by stages).

To have full support, it would need to update kernel at March 3rd level at least, but other things from Volumio may probably break.
So you’ll have to live will current hack-ish method until a release with an updated kernel is fully tested.

@macmpi i know that it is a quite a hack-ish way.

by the way, all is working fine with my rpi zero W with Wifi embeded.

one last thing i like to resolve : remove the USB HUB between the rpi and my digital Amp…

Thanks you very much !

Actually i’am using :

pi zero w >> micro USB OTG >> 4XUSB HUB >> USB-A to USB-B >>USB INPUT Digital AMP.

if i plug like this :

pi zero w >> micro USB OTG >> USB-A to USB-B >> USB INPUT Digital AMP = Error : Failed to open audio output.

This problem may not be related to PiZero W software configuration.
Has your DAC a power supply?
Maybe your hub is powered and provides sufficient power to the DAC, something the PiZero might not be able to do…


The DAC seems to be embeded into the Amp, powered by it but

I think u allright, the USB from pi zero w don’t provides sufficient power to DAC…

is there a way to set more current on the USB of the rpi zero ?

Apart having a more powerful powersuply for the Pi (up to about 2A), I don’t know…

but my USB HUB is powered by the pi zero :exclamation:

also, i’m using a psu 5V/2A for the pi zero.

The DAC/AMP is powered by a PSU 32V/5A.