Volumio for Raspberry PI model B+

hi there -

just set up volumio 1.41 PI on B+ with hifiberry+

i followed the instructions in this thread (great help - thx!)
managed to mount my NAS via fstab entry - waited for the database update & was pretty amazed by what does work
can play mp3 and 16 bit flac without trouble - BUT:

as in other cases 24 bit 96 khz is not possible - in my case it actually freezes the system
i found the following entries which flooded my mpd.log:

: ffmpeg/flac: Could not find codec parameters (Audio: flac, 0 channels, s16)
: ffmpeg/flac: Estimating duration from bitrate, this may be inaccurate

so i searched a bit and disabled ffmpeg in mpd.conf - to no avail

24 bit is still not possible - as somebody above suggested it might be a raspi issue -
anyways i will keep following this thread to find out more since i would love to play some hires files :wink:

thanks again michelangelo - really great project!

i just found the following errors after dmesg:

pcm512x 1-004d: No SCLK, using BCLK: -2
pcm512x 1-004d: Completed initialisation - pcm512x_probe
pcm512x 1-004c: Failed to reset device: -5
pcm512x: probe of 1-004c failed with error -5

could there be a connection with the missing 24 bit playback?



Since I have less that 10k of music files —> how to “re-enable” the library tab on volume 1.41 (RPI-B+) ?


Go to the WebUI, click on the top right button “menu”, then go to system tab
under the upnp and airplay switches you will find the library tab switch.

Dont forget to press the apply button

under system tab (in services management section) I got airplay, upnp control and upnp/dlna indexing … but not the library tab switch ??? (or I’m blind ?)
I’m using volume 1.41 on a RPI-B+

so i can see it
Are you sure that you use Volumio 1.41? (from this link: http://sourceforge.net/projects/volumio/files/Raspberry%20PI/1.4/Volumio1.41PI.zip/download)

Hi Joda2,

I will wait mid october, for the new release :slight_smile:

Thanks a lot.

Kind regards

Just to add my thanks to all on here for the software and for the help.

Managed to get Volumio 1.4 working on Pi+ and iqaudio Pi-Dac+. Still in shock - wonderful. At the moment still playing around but looking forward to having more fun…:slight_smile:

Thank you.

I’ve re-dowloaded volumio 1.41 from your link, re flash and still no library panel ???

the volumio 1.41 image I’ve downloaded is 1.89 Gb in size and dated from 5 august 2014 (18h10)
ps: while login to shh i still have “volumio 1.4” under the volume logo (is that normal ?)

anybody would have a suggestion ?

:neutral_face: ok my mistake … 1.41 has no library tab … you need to update the system.

if you wanna do this you can follow this little guide: (which can also be found here: http://volumio.org/forum/enabling-disabling-the-library-t1712-20.html)

[spoiler]Guide (starting with a brand new installed volumio) for people like me (Noobs^^)

with help of these guides:

1. Installing git
sudo apt-get update
sudo apt-get install git
mv /var/www /var/www-orig
mkdir /var/www

2.1 Creating a SSH Key (if you have one move to 3.)
ls -al ~/.ssh
if you see something like id_rsa.pub or id_dsa.pub go to 2.3
ssh-keygen -t rsa -C “your_email@here.com
enter a passphrase
ssh-agent -s
ssh-add ~/.ssh/id_rsa (if this goes wrong: ssh-agent -s)
go to github.com/settings/admin
click SSH Keys on the left side
add a key
Name: Volumio
Key: all text in ~/.ssh/id_rsa.pub (open with: nano ~/.ssh/id_rsa.pub)

3. Getting the New UI
git clone git@github.com:jotak/Volumio-UI.git /var/www
cd /var/www
git checkout -b act_library

4. “Installing” it
cd /var/www/updates (if this goes wrong do: git reset --hard origin/act_library)

Restart Volumio, clear the browser cache and try the Library :wink:

At your own risk[/spoiler]

yes, i think michelangelo forgot to change that :wink:


while cloning your code (git clone git@github.com:jotak/Volumio-UI.git /var/www) I end up with errors :

“Cloning into ‘/var/www’…
ERROR: Repository not found.
fatal: The remote end hung up unexpectedly”

does your github still alive ?

ps: I did created a github account, make a ras key, check the connexion using ssh -T git@github.com and it was ok (i.e., I don t think that I did a “mistake” in the setup).


I’ve possibly found out a minor “bug” in the library tab for the “advanced options” :

  • I wanted to add a NAS mount (NFS) and I selected CIFS/SMB by mistake … (obviously it was not working). I looked at the advanced options and I see a long string for the “advanced options” (ro,dir_mode=0777,file_mode=0777)
  • I changed the NAS mount to NFS and the advanced options were still “ro,dir_mode=0777,file_mode=0777”
  • Updating this options to the default(?) NFS “advanced options” : ro,native, all was fine

does the advanced options are not updated with their default values while changing from NFS to CIFS/SMB ?

if you found a bug, please post it here: http://volumio.org/forum/enabling-disabling-the-library-t1712.html

Its not my code (i am not a programmer), if you have questions you should ask jotak.

The github account you’re referring is Jotak’s one… Official Volumio one is


However cloning it will probably break your system. We are reworking lots of stuff… A bit of patience and you’ll see everything in its place with the new 1.5 version…


All fixed :slight_smile:


As above


got my dac+ up and going with v1.41 and some code help from this forum last night.
(i am not a programer… so this took focus and no drinking on my part. lol)

all 16/44.1 seemed to be working and playing. however anything >16/44.1 was not. it would play at 2x,-3x, the normal speed.

this morning i started playing with the playback resampling and now i get nothing. disabled it, nothing. reset to defaults, still nothing.

the webui is working and green light on dac… what am i missing?

found my problem.
had to go back in and change the mixer_control from “DSP Program” back to “Playback Digital”.

not sure how changing the playback resampling in the webui changed the above…

back to working again (only 16/44.1.)

We got our Pi Dac+ HAT and followed the instructions from this forum and from Gordon. He sends a PDF with instructions. My daughter did the mechanical parts, putting the HAT on the raspberry pi B+ and putting in the SD card. It was easy with me offering as an extra hand when needed to holding things still.

I did the software side with volumio 1.41 beta. The only issue we had was when we tried to test it out before plugging it in the network, it will not drive the 1650x1050 monitor properly. The text appears, but it flashes constantly. Other versions work with video (raspberian, even volumio 1.40). This did not affect the remote interface though.

Plugged in the ethercable and the audio jacks and it worked beautifully both via airplay from the iphone and via bubble on android. I can get it to play mp3, ogg, and flac from CD as well as the high fidelity flacs sampled at 96kHz/24bit and 196kHz/24bit samples from 2L

They all sound great.

Many thanks to Michelangelo and all the contributors and to Gordon at IQaudIO