Volumio for Raspberry PI model B+

Thanks Plasma25!

My Rasberry Pi with HiFiBerry DAC+ is working too :slight_smile: I’ve tried to make it work for a few days, first with OpenELEC, then Raspbmc, Raspbian with no success. I’ve seen led DAC+ light on few times, but no sound yet, till today :slight_smile:

OpenELEC - thanks to develepers and chat on IRC i’ve loaded modules, but it hangs when you select DAC+ (ALSA) on the list in XBMC.
Raspbian - there was a problem with XBMC in full hd so i’ve let it go, the led was also on, but no way to test it (no ability to configure it)

If you have any other successes or just want to share (I can write exactly what i have tried) I would be glad to write to you. My goal is to make XBMC work, best on OpenELEC 'cause it’s easiest to run and configure. I’ve also some issues with wifi dongle, which i have ‘steal’ from my Xtreamer, it works on OpenELEC, Raspbian, on Volumio not yet :wink:

Hi Guys,

I’ve also have a model B+, and put the 1.41 version on the SD card. During the boot process it also stops at transientlog permission denied, and the GUI does not start. If I understand well, that this version contains the update that needs for the model B+? What else can I check?
I have a 2GB SD card. I think it shouldn’t be a problem.



What you mean with GUI does not start? You access the GUI via a browser not via monitor…

hello everybody,

using version 1.41 and following the instructions above i was able to get my raspi b+ and hifiberry digi+ to work.

but i’m having problems with playback of audio content with sampling rates above 48k. i have some 24/96 flac files that will not play back correctly.
playback seems to be faster than normal and with a lot of noise and clicks.

the same does happen with an usb dac i normally use on a dreamplug box (where it works flawlessly). everything below 96k works perfectly.


Thanks, it the meantime I’ve realized that there is no traditional GUI on the PI :frowning:
Now it has started to play music through my DacMagic, therefore it’s OK now.

Just a few things, I’m trying to check this once again, but:
On the web interface I was not able to play music on the USB drive. Library seems to be empty, after pressing update library it is the same.
When using Sound@home for Volumio on android, it shows the USB content, and plays correctly.

Thank you for your answer, and your work providing this distro!!!

Hey oskar,

I have the same issue with some flacs. Can you try if mplayer plays it any better? That works for me.
This is how Get Lucky sounds for me with Hifiberry DAC+: soundcloud.com/borostomi/dac-issue


hello tamas,

i can confirm that files play back perfectly with mplayer. so this seems to be a mpd issue?
files also do play back fine if i add format "48000:24:2" to the output section of mpd.conf (but that is not an option :wink: )

updated to new firmware (Linux volumio 3.12.28+ #709) today, but no change.

it seems as if files play back about 2x to 3x faster than normal, with a lot of clicks and noise, exactly like the one you posted.


Hi Everyone

I followed the instructions on page 2 to get the DAC+ working with pi b+. Absolutely awesome, Thanks so much for posting. I followed the instructions to the letter and upon reboot my RCA connections were sending audio to my amplifier. Sweet

I’m just wondering how you guys finding the sound quality though. I don’t have golden ears but have the pi/hifiberry dac+ connected to my Yamaha AS 500 & Tannoy monitors and the sound quality is almost unbearable. Sibilance is earsplitting and all high frequencies sound incredibly artificial with some female vocals almost sounding robotic. Based on the praise I have seen both Volumio & the hifiberry Dac receive I wonder if what I am hearing is caused somehow by a driver/setup issue.

Thanks for any feedback

I’ve got the same issues as mentioned above.
Playing hi-res flacs at double / triple speed and poor sound quality…

It must be a kerner / driver problem…

regards Mandretti

status update: i have tried to go back to the “stock” version of mpd (0.16.7-2+b1) on wheezy with no success. the issue is still there.

something else i could try?


so here i am again.

as i had suspected the issue is not related to volumio nor to the hifiberry addon boards.

the same problem exists on a stock raspberry pi b+ with raspbian installed. atm updating everything does not solve the problem.
it does not appear with onboard audio because selecting plug or hdmi output in mpd, audio is resampled from 96khz to 48k.

it happens with both a hifiberry digi+ and an external usb dac (capable of 192khz/24bit). the same usb dac works flawlessly on a raspberry pi b model and raspbian.

i think i’m going to post this on some official raspberry pi forum.


ok, posted here: http://www.raspberrypi.org/forums/viewtopic.php?f=28&t=86983



I have problem using Volumio 1.41 PI on B+.
There is a error when start up, the message is

[…] startpar: service(s) return failure: transisntlog …cat:/run/player_wrk.pid: No such file or directory

The screen will stop at

[ 136.957078] smsc95xx 1-1.1:1.0 eth0: hardware isn’t capable of remote wakeup
[ 136.972684] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 222.491079] bcm2835-cpufreq: switching to governor performance
[ 222.504503] bcm2835-cpufreq: switching to governor performance

Can anyone teach me how to solve this, please.

This is not a problem, don’t worry but please stay on topic

OK, thank you!!

Im all new to linux and I’ve followed the guide with my model b+ and digi+ but i simply cant make it work. The digi+ doesn’t show up in volumio.

I’ve tried a test img from hifiberry, so the devices are working.

Cant someone please upload a volumio .img where the digi+ is enabled?

hello sonder,

you will not be able to enable it from the web interface of volumio (because of the “worker thread busy” issue), but follow this guide, and it should work: http://www.hifiberry.com/guides/hifiberry-software-configuration/

follow this order:

  • edit blacklist and modules files
  • reboot
  • the “configure alsa” step should not be necessary
  • test with “aplay -l”
  • configure output in volumio.local


Hello, I posed this question in the help section but I will ask here also as it relates to a Pi+ and version 1.41.

Is the upnp renderer software included with this version please? If not is it planned to be added?

I have just got a pi+ which I would love to use with volumio, controlled by bubbleupnp, with flac files from minidlna on my nas.

Thanks in advance.

Hello guys,
When do you think the next release will be available “out of the box” to enjoy the sound of DAC+ with PI B+ ?

I have already try the workarounds describe before, but with no success.

Thanks in advance for your great work.

Kind regards.

yes its included

Should be included in the next version.
Can´t say it exactly … should be in mid october