Volumio for Raspberry PI model B+

Guys, I got the PI B+ (it had the same smell of my first model B, some time ago) . Arrived yesterday. It doesn’t work with Volumio 1.4 cause it needs a newer kernel, modules, elf and firmare files. So, got few time, but I managed to make an image compatible with both Raspberry PI B and B+
Since I were there, I upgraded the WebUI to latest version. This removes (is a temporary removal, we’re working on that) the Library Tab, adds Player name selection and fixes small bugs.

Since it features a new kernel, there could be some side-effects: some USB DACs may work better or worst, some may not be recognized and this will happen also for wireless sticks and so on.
Since the USB FIQ fix should be pretty mature and integrated into this kernel, you could also experience less crackles and better sound. This is what I experienced, but there is lot of variability with setups to be kept in mind.
So please share your feedbacks so I can improve for next version.

If however, some of you may want to retain its current configuration he just needs to connect via ssh to volumio and do:

[code]sudo apt-get update

sudo apt-get install binutils

sudo rpi-update[/code]

This implies you’ll have a working raspberry Pi model B where to perform what above. Also, it may happen that your USB DAC is muted when booted, just check with alsamixer and press m to unmute (this is fixed in the image).

Here is your download link @ sourceforge
sourceforge.net/projects/volumio … p/download


  • Removed Library Tab
  • Added Player Name configuration (Works also for Airplay)
  • Kernel Upgraded, compatible with B+ model
  • Fixed unmuting script
  • Improved NAS mounting

UPDATE: player name selection is not working, forgot to set appropriate permissions to rootfs before deploying the image. A temporary fix (unsafe, do at your own risk)
sudo chmod 777 /etc/hostname
sudo chmod 777 /etc/hosts

Great work Michelangelo.

Soon I’ll send you the IQaudIO.com Pi-DAC+ :slight_smile:

Then you can enjoy your music in “Full HD”.

BTW, what kernel version did you go with? 3.16?

  • We’ve changed the mixer name from “playback digital” to just “PCM” for the DAC - this should make your configuration easier. 3.16 also includes the correct B+ IO settings to have I2S delivered on the 40w header.

Best regards,


That is an amazing news Gordon! Really eager to listen to your DAC+!!!

Hironically: I was setting up a fix for the PCM mixer when IQaudIO DAC was selected… You’ve done it first…

FYI the FriendlyName in UI Option didn’t work for me :unamused:

I’ve tried a few times so a hope it isn’t a false alarm, My last attempt




Not a complaint, just feedback :wink:


Yep, didn’t included UPNP in the process… My bad.
However with a reboot you should see airplay and hostname changed.
Let me know

I don’t know what you did Michelangelo, but the scan of my NAS (which mounted seamlessly and easily for the first time yay!!!) seemed much faster than before with the latest image. Thank you! :smiley:

Thank you so much for the new image, Michelangelo. It works very well with my RPi B+. The sound quality through my USB-connected Beresford Caiman-II has taken a distinct upward turn and there are no tiny glitches in the sound compared with the RPi B, which I have for comparison. This shows that the USB subsystem is indeed improved. I also agree that reading the NAS contents seems faster now.

One bug I’ve found: after playing the first selection, any further selections no longer show a numeric time count in the Playback screen, although the circular progress bar continues to work.

Altogether, this is the best release yet. Will you be releasing a bug fix version for issues found?

This runs much better than 1.4 on my Model B. Thanks!

Just test 1.41 with RPi B

I work out of box with my HRT microstreamer. however, Wifi dongle (TL-WN725N V2) still need some update via SSH

I also suggest Stop/ Play/ Forward buttons shall be bigger (say double side) for tablets/phones friendly.

By the way, Volumio is really nice and resurrect my old Pi.

Thank you .


Bit of a n00b with a bit of a n00b question.

I have my RPi B+ up and running; it has cataloged the music on my NAS drive and I am able to play music via the HDMI cable.

I need to be able to play music via the 3.5mm jack plug.

I have checked the ALSA config using ‘amixer’ to check the settings - all things point to the 3.5mm jack being enabled however no sound is coming out.

Can anyone help?

Thanks in advance.

I can only say that changing between USB DAC output and the audio jack requires a reboot. Try removing any USB connection and reboot?

Dear Michelangelo,

I am very interested to test volumio on my new pi B+, where as I have no raspb Pi before, but having problems using volumio 1.41. Thanks a lot for your efforts to the audio community!

I downloaded 1.41 and is it running till transientlog, where I get a notice failed at … run player : no such file or directory.

I did also the update for drivers (usb/internet) and also the chmod 777 /ect/hostname and chmod 777 /ect/hosts,

but each time it fails at transientlog permission denied. The internet is working, while the updates where installed.

Any idea to fix this issue?

best Paul

Turns out I ‘may’ have screwed the config; re-flashed card and all now working as it should - just need to try and get WiFi working now :slight_smile:

Raspberry B +, how to get to DAC I2s?

Cannot get it to work too …

is this patch needed ? :


I get this error : Job Failed background worker is busy.

And no sound …

Please help :wink:


I have the exact same problem with the new HiFiBerry DAC+.

Does anyone knows how to fix this?

Thanks !


Same situation here.
I’ve a Raspi B+ with Hifiberry DAC+ hooked up on it.
As soon as I try to activate the I2S driver for the HifiBerry I get the Errormessage:
“Job Failed. Background worker is busy.”

Also strange: On every 2nd or 3rd reboot of the Raspi, the Audio Output device on Playback Page changes from “ALSA” to “sndrpihifiberry” without intervention. As soon as this happens, the DropDown Menu for the Output Device has only one device to choose from. So, one time I could only select “ALSA” and one time “sndrpihifiberry”

Any idea?
If you need some logs, or if you tell how to enable debugging, I’ll try to send as much info as possible to help sorting this out.

Best regards,


got some updates, but still no sound:

What I did until now:

sudo apt-get update
sudo apt-get upgrade
sudo reboot

After reboot:

sudo apt-get install binutils
sudo rpi-update
sudo reboot

Change config in “/etc/modules” to


Rebooted again but still no audio.

Can someone tell me where to find config files for Volumio or is there a page where I can find some documention to get on tinkering :wink:

Best regards,


I’ve got 1680x1050 screen. It says the resolution is not optimal and i can’t see nothing. When I’ve tried to boot with 1.4 version it doesn’t work, of course, but i could see all booting sequence and there were no problem with LCD screen. Shouldn’t it adjust to resolution of my screen?

Hi guys!

Finally I was able to bring my Hifiberry DAC+ on my Raspberry B+ to life!

What did I do:
1.) Setup Micro SD card with Volumio 1.41 according to the well known procedure :slight_smile:
2.) Hook up PI to your Network
3.) Power on PI, let it boot up, SSH to it and login (or just start over with the procedure below if you are directly on the console)

As I personally like VI, I’ll use itduring the procedures below it to edit files. Use the editor (nano,…) of your choice.:wink:

4.) System Preparation:

I do not need any X on my setup so I reduced Video Memory to 8MB. Thats at least enough to display on HDMI :wink:
This step is optional and can be ignored.

sudo vi /boot/config.txt

Change file content to:


Update installed binaries / Libraries to the latest versions.

sudo apt-get update
sudo apt-get upgarde

Update process will be interupted 2 times
1st: Only some information… Just press “q” to go on.
2nd: The upgrade process wants to change a Volumio Configuration file `/etc/php5/fpm/pool.d/www.conf’. As I didn’t look into the file and did not want to mess up my installation, I kept it as it was. Press N or O to keep the existing file!

sudo reboot

After reboot do:

sudo apt-get install binutils
sudo rpi-update
sudo reboot

The rpi-update installed kernel version 3.12.26+. With an older version it is maybe not working!

5.) Setup Config Files to recognize Hifiberry DAC+

sudo vi /etc/modules

Change file content to:

sudo vi /etc/asound.conf

Change file content to:

pcm.!default  {
 type hw card 0
ctl.!default {
 type hw card 0
sudo reboot

After the reboot you’ll notice that the little green LED on the DAC+ is on!
Hooray!! :laughing:

6.) Login to Web GUI of Volumio, go to the Playback Section and change the Audio Output to sndrpihifiberry. Save the changes.

7.) Setup Config Files to allow Hifiberry DAC+ Hardware volume Control

sudo vi /etc/mpd.conf

Look for code

audio_output {

                 type           "alsa"
                 name           "Output"
                 device         "hw:0,0"
                 mixer_control  "DSP Program"
                 mixer_device   "hw:0"
                 mixer_index    "0"
                 dsd_usb        "yes"


and change it to

audio_output {

                 type           "alsa"
                 name           "Output"
                 device         "hw:0,0"
                 mixer_control  "Playback Digital"
                 mixer_device   "hw:0"
                 mixer_index    "0"
                 dsd_usb        "yes"


Restart MPD Daemon

sudo /etc/init.d/mpd restart

That’s it!
Start a Webradio Stream and enjoy!

Finally Setup your Volumio as you like.

Please keep in mind that this is only a workaround to get Volumio on a Raspberry PI B+ with a Hifiberry DAC+ up and running!! :ugeek:
So changing settings in the Playback or System section of the GUI can mess up the workaround from above.
As a final solution Michelangelo has to integrate this in the GUI. Here is only a possible way to go! :smiley:

Have fun!

Also got this strange resolution on the HDMI Interface of the PI as zespre told. My small 17" display is not able to display it correctly. So no direct console access. If I hook it up to my large display, it is working, as it is able to view the resolution.