Volumio for Raspberry PI 3b+

Here is a Volumio image for Raspberry PI 3B+

updates.volumio.org/pi/volumio/2 … pi.img.zip

As always, before releasing to the public, it would be very helpful if you guys could test it (not only 3b+ owners, but all PI owners, so we understand if this release breaks something for previous iterations)

See my review of the Raspberry PI 3B+ here: volumio.org/raspberry-pi-3-b-plus-audio-review/

Really eager to know your feedbacks!

As a matter of fact, older Pi3/Pi0W owners having intermittent wifi problems with built-in HW may want to give that image a shot, as it may improve things too.
Thanks for feedback.

I’ve just installed 2.382 on an RPi3B (not a 3B+). I streamed webradio over wifi > disconnected router ADSL > reconnected ADSL > webradio not resumed/ reconnected. Hotspot:ON Hotspot fallback:OFF.

However, when I click Pause > click Play > webradio is resumed

Thanks for this new image.

Tried it on the 3b+ and couldnt get the volumio app on android (nexus 9 and 7 and samsung s8) to recognize it when voulumio was on wifi but tried finding on a browser and ok since then on the app. Weird.

The lan is noisy as described. The conection on wireless is very good and got DSD at 11.28 mhz with no skips or stuttering!
I can’t be sure but I think it sounds better than a standard pi3. Will have to try some listening next week as I have no time right now.
My pi is powered by battery btw, into a smsl sanskrit pro-b usb dac.

Mind that Pi3+ is known to have significantly higher power requirements than Pi3:

Thanks for this.

I initially ran into issues on my very first encounter with Raspberry Pi itself and Volumio v2.378 - would not boot on 3B+ …didn’t appear to detect SDCARD (4 long then 4 short flashes on LED). I overcame this by copying over the .elf files but this once booted lead to issues with disabled WiFi.

The release posted here has resolved these issues and boots fine. I am a total novice so haven’t really investigated many features yet, but streaming web radio and AirPlay seem to work fine and wanted to feedback what I can.

Thanks again for your efforts.

My battery power pack is an EasyAcc with 2.1amp on the output I use. I would have thought that was enough on battery. :question:

Is there some log file I can create & forward for someone to diagnose this problem?

Today test on 3b+ I2S on Soekris DAM1021
WEB radio plays OK
But when try to play ZZTop flac 44.1 16bit Soekris did not locked.
Resolved problem when turned on audio resampling.
BUT, here comes strange behavior.
I set 32Bit - Locked and playing!
I set 768Khz - Locked and playing!
Soekris supports only 24Bit 384khz only
So I don’t understand how actually resampling works.

Youtube plug in drops error: “Browse error An error occurred while browsing the folder.”

Just got my Pi 3 B+, flashed the above image, hooked up the new Pi to my Modi 2 Multi-bit - and the sound was incredible! Still need to test out some hi-res, but I never got the Pi 3 working well with the Modi 2, due to packet loss I believe, so this is very encouraging! Thanks for the quick turnaround on the Pi 3 B+ image Michelangelo!

I tried to get this image to boot, but the only thing I get is a black screen. Noobs does work… Anyone got a fix? Or shall I wait for an official release?

It’s normal, just connect to volumio via browser

Ok, but the little led lights should go blinky blink right?


All working just fine! sound is superb and spotify connect works as well I love it!

i have only 1 issue, after a couple of hours the Pi is unreachable for spotify, also if i browse to the ip adres or volumio.local it is unreachable and can’t get a connection to it, SSH is also impossible however i still can see on my router it is in the network.

the only way to restore connection is to unplug the power en reconnect it again. then connection is back again for a couple of hours and then it will be lost again.

tbh i have no idea where this comes from, maybe more people with the same issue?

thanks for all the hard work and effort to make this great program! :smiley:

kind regards

Are you on wifi or ethernet?
It seems there are still a few networking-related kernel/drivers/firmware issues being worked-out.
If anyone has usb-ethernet dongle available, one could make some tests to rule-out the ethernet part…

forget to mention, it is connected via Wifi. i made the ip static in the router so this couldnt be it.
tomorrow i can try to connect it via ethernet cable and see what this will do.

Testing the RPI3B+ with Volumio 2.382 and HiFiBerry DAC Plus for two days now, alternating between wifi and ethernet connection, and everything is stable. No problems whatsoever.
Nice Job!

If I were to switch to a 3B+ with my Kali / Piano, would the higher power requirements be of any concern since it’s powered through the Allo boards?

Pi 3b+, Volumio 2.382
NAS mount fails.

/var/log/volumio.log says
“An error occurred mounting the new share. Rolling back configuration”
This happens never before.

New version with kernel 4.14.29:
updates.volumio.org/pi/volumio/2 … pi.img.zip

Unfortunately the issue has only improved slightly but it’s not totally resolved, would love your feedbacks on that as well