Volumio 3 Buster Beta for X86

still testing! Don’t use it until it is OK.

1 Like

All fine with 3.075, but has other issues!!

PLEASE NOTE
Beta testers should start with at fresh version 3.077 or later when they want to use OTA for further image versions.
Versions before 3.077 cannot be updated!

1 Like

Version 3.077 can now be downloaded.

3 Likes

Hi everyone,
just to inform you that version 3.077 does NOT boot on my MSI GP60 2PE Leopard laptop, whereas it runs all right on other computers of mine. Tried both USB 3.0 and 2.0.

SecureBoot disabled?
UEFI and CSM mode set?
Does it show anything at all?

Yes, it starts booting up to the first two lines of text, and there it stays forever

in most cases this is caused by bios settings, like enabled SecureBoot or CSM mode incorrect for UEFI boot. There is not much we can do to help, sorry.

FYI, on the same machine Volumio-2.878 boots with no issues.

In case you are able to modify the grub configuration (/boot/efi/BOOT/grub.cfg) on one of your machines that does boot, try adding this to the kernel command line:

nouveau.nomodeset=1

or just

nomodeset

(if the first one made no difference)
Look for the line with the volumio settings, just add it to the end of the line. Perhaps it is a graphics issue, nomodeset stops video drivers to be loaded.

A log would help but in this situation this is impossible, unless you modify the grub configuration and also replace

loglevel=0

by

loglevel=8

(or add the latter to the end of the volumio settings in case loglevel was omitted)

This could give a log on the display. In case you get one, a screenshot would be helpfull.

Otherwise, there is not much we can do to help with this, I have no idea how your notebook is configured hardware-wise. I’ll search, best-effort, no guarantee.

There is no chance that we can support all of the ten thousands of different pc hardware configurations, even if they did work with Volumio 2 and it’s very, very old kernel. We don’t have a staff like Debian or Canonical.

Thank you so much for your help. I followed your instructions and made the following modifications:
nouveau.nomodeset

nomodeset

Unfortunately, there was not change at all, not even log info :pensive:

Ok, I tried “UEFI and CSM” BIOS mode and it boots now :+1:
I’m sorry, but I missed it before.
Thank you for your help.
Looking forward for the next issue :wave: :wave:

Lucky you😀
Glad it worked out in the end, very often these boot issues are bios issues.
Btw, I did not realise you were using legacy boot, the modifications should have been in /boot/syslinux.cfg in this case. But not relevant now…

the X86 beta forum has been quiet for a while now, so i assume this version is pretty stable? Any indication of when this will officially be released? or am i jumping the gun?

Some features such as plugins are still missing. Is this mandatory for a release?

good question @Robert.Hecht .

Hi,
My only problem is that when I listen to music in dsd (dop) format I get drop outs.
I have had this problem since the first test variants.
Asrock deskmini, i3 7100, 8gb ram, the rest of the system I suspect doesn’t matter
Respectfully for everything you do, Dan

Hi there,
I am testing Volumio-3.077 using a queue of FLAC files with different sampling rate and/or bit depth.
Sometimes, when the previous track finishes and the new one starts, Volumio keeps reporting the sample rate and bit depth of the previous track.
I’m testing using a Virtual Box, both with internal audio and external USB DAC. It could be related to the virtual environment, so I would like to know if you experience the same problem.

I still don’t see anything under the plugins.

if you would only take the effort to check before reporting a long known restriction, we have told from the beginning that plugins are not supported yet because of refactoring, they will be added later.

Hi, thanks for the new version of Volumio which finally support my “hardware” of mini PC ASUS PN40 a works very smoothly. The last stable 2.878 was a nightmare for me with initial setup. The plugins aren’t necessary right now, but I have two questions:

  1. Is it possible to make Tidal Connect working properly? With version 3.077 I can’t play anything. I click on something to play and nothing happens. I would use but 2.878, but that’s really not possible in my case.
  2. Is there a little hope for native ISO SACD/DVD-A support in a future? I know this was mentioned many times before, but since we have brand new awesome build, I thought it could be still “alive”… Of course I can rip my ISO files without no problems, but I think the native support is the right way.

Sorry for my bad English.

Michael