Volumio 2 on Odroid Boards

I’m going to order 12v connector and try that. The schematics show the 12v being stepped down to 5v so that the likely issue. Not enough power from my power supply.

I will say DSD through I2S is amazing. I was not able to do DSD with the C2. Only MQA and flac worked.

Please share with us which DAC device you used, how you connected it etc. Very useful for us, thanks.

Audio GD NFB-27h

http://www.audio-gd.com/Pro/Headphoneamp/NFB-27H/NFB27HEN_Custom.htm

I use breadboard jumpers to connect the 7 pin connector on C4 directly to 5 pin connector on the DAC and bypass the RJ45 connector on the DAC.

Updating the power supply has fixed the issue for me. No further freezes since I went to a 12v power supply.

Latest releases 2.857 available, see the updated opening post.

hello … I have an odroid C4 with hifishield 2 and tried to follow the link as mentioned in the first entry but

results in a unresolved link (error 404 Not Found)
can you check the link for the odroid C4?

Philip

Yes, something went wrong during the build process. Re-issued the request and will update the link within the next hour.

Odroid-C4 download link updated (now version 2.858).

Thanks!
downloading now and will test it next weekend … device is now in a small village in ISAAN in Thailand :slight_smile: — connected to a yarland tube amplifier (EL34) and 2 standing Klipsch speakers while I am currently in Bangkok :frowning:

I’m having issues with the odroid c2 using the hifi shield 2 i2s add-on. I’ve tried every mixer setting, but on all newer versions of volumio i get tons of noise and conversion artifacts in the audio. i have another odroid, i think it’s a c1+ running an older version of volumio with no problems. I also can’t seem to find anywhere i can download any of the older volumio images to roll back and get it working again. can anyone help with this?

C1/C1+ and C2 are different devices each with their own kernel, it is a bit like comparing apples and pears.
I’m not aware of issues, but will upgrade or flash mine tomorrow and check.
What particular version are you running at the moment and which version on the C1?
This will help locating a suitable older version when needed.

I was unable to to reproduce the problems you are having, testing with version 2.864.
This version works fine and we have no other reports.
Make sure you set you mixer hw setting to Hardware and mixer control to Digital.

Are you using wifi or wired?
In case of wifi, I suggest to try wired first to exclude you don’t have issues with the wifi dongle.