[SOLVED] Volumio 2.246 failed open Alsa

Hello

I just upgrade Volumio 2.245 to 2.246 and i have a slight problem.

I have a error message: Error. Failed to open “Alsa” [Alsa]; Failed to open ALSA device “hw:1,0”: No such file or directory.

I can’t play webradio or files of my network drives.

Best regards.

Configuration: Rapsberry 3 with a Justboom Digi; network drive Synology DS214; DAC ARCAM airdac, no wifi just cables.

Please disable i2s dac, reboot, enable i2s dac again

Ok, that’s works.

Thanks Michelangelo.

Didn’t work for me.

Justboom Digi.

Please advise as I’ve reset to factory settings once already! :frowning:

Thanks.

Hello,

I have the same problem today, i use the last version, 2.246. This is my first connection and i have not tried with the previous version.
I tried the solution proposed by michelangelo but it does not work with me.

My configuration is:

RPI3 - ALLO Isolator (Master position) - ALLO Boss - hard drive in usb, Ext4 - No wifi, only cable.

Regards.

We had various reports of JustBoom digi not working. Unfortunately I will be away from my studio and will not be able to fix that.
You can however help by listing the files you see in /boot/overlays

thanks

After upgrade to 2.246 ta same alsa issue, I2S off, reboot, I2S on, same issue :frowning:

Pi Zero W, Justboom Amp
Pi Zero W, Justboom Dac

volumio@volumioamp:/boot/overlays$ ls
README i2c-gpio.dtbo pwm.dtbo
adau1977-adc.dtbo i2c-mux-pca9548a.dtbo qca7000.dtbo
adau7002-simple.dtbo i2c-mux.dtbo raspidac3.dtbo
ads1015.dtbo i2c-pwm-pca9685a.dtbo rotary-encoder.dtbo
ads1115.dtbo i2c-rtc-gpio.dtbo rpi-backlight.dtbo
ads7846.dtbo i2c-rtc.dtbo rpi-cirrus-wm5102.dtbo
akkordion-iqdacplus.dtbo i2c-sensor.dtbo rpi-dac.dtbo
allo-boss-dac-pcm512x-audio.dtbo i2c0-bcm2708.dtbo rpi-display.dtbo
allo-digione.dtbo i2c1-bcm2708.dtbo rpi-ft5406.dtbo
allo-piano-dac-pcm512x-audio.dtbo i2s-gpio28-31.dtbo rpi-proto.dtbo
allo-piano-dac-plus-pcm512x-audio.dtbo i2s-mmap.dtbo rpi-sense.dtbo
at86rf233.dtbo iqaudio-dac.dtbo rpi-tv.dtbo
audioinjector-addons.dtbo iqaudio-dacplus.dtbo rra-digidac1-wm8741-audio.dtbo
audioinjector-wm8731-audio.dtbo iqaudio-digi-wm8804-audio.dtbo sc16is750-i2c.dtbo
audremap.dtbo justboom-dac.dtbo sc16is752-spi1.dtbo
bmp085_i2c-sensor.dtbo justboom-digi.dtbo sdhost.dtbo
boomberry-dac.dtbo lirc-rpi.dtbo sdio-1bit.dtbo
boomberry-digi.dtbo mcp23017.dtbo sdio.dtbo
dht11.dtbo mcp23s17.dtbo sdtweak.dtbo
dionaudio-loco-v2.dtbo mcp2515-can0.dtbo smi-dev.dtbo
dionaudio-loco.dtbo mcp2515-can1.dtbo smi-nand.dtbo
dpi18.dtbo mcp3008.dtbo smi.dtbo
dpi24.dtbo midi-uart0.dtbo spi-gpio35-39.dtbo
dwc-otg.dtbo midi-uart1.dtbo spi-rtc.dtbo
dwc2.dtbo mmc.dtbo spi0-cs.dtbo
enc28j60-spi2.dtbo mpu6050.dtbo spi0-hw-cs.dtbo
enc28j60.dtbo mz61581.dtbo spi1-1cs.dtbo
fe-pi-audio.dtbo pi3-act-led.dtbo spi1-2cs.dtbo
goodix.dtbo pi3-disable-bt.dtbo spi1-3cs.dtbo
googlevoicehat-soundcard.dtbo pi3-disable-wifi.dtbo spi2-1cs.dtbo
gpio-ir.dtbo pi3-miniuart-bt.dtbo spi2-2cs.dtbo
gpio-poweroff.dtbo piscreen.dtbo spi2-3cs.dtbo
hifiberry-amp.dtbo piscreen2r.dtbo tinylcd35.dtbo
hifiberry-dac.dtbo pisound.dtbo uart1.dtbo
hifiberry-dacplus.dtbo pitft22.dtbo vc4-fkms-v3d.dtbo
hifiberry-digi-pro.dtbo pitft28-capacitive.dtbo vc4-kms-v3d.dtbo
hifiberry-digi.dtbo pitft28-resistive.dtbo vga666.dtbo
hy28a.dtbo pitft35-resistive.dtbo w1-gpio-pullup.dtbo
hy28b.dtbo pps-gpio.dtbo w1-gpio.dtbo
i2c-bcm2708.dtbo pwm-2chan.dtbo wittypi.dtbo

Same Problem here. Restart i2c did not work.

/boot/overlays
adau1977-adc.dtbo
adau7002-simple.dtbo
ads1015.dtbo
ads1115.dtbo
ads7846.dtbo
akkordion-iqdacplus.dtbo
allo-boss-dac-pcm512x-audio.dtbo
allo-digione.dtbo
allo-piano-dac-pcm512x-audio.dtbo
allo-piano-dac-plus-pcm512x-audio.dtbo
at86rf233.dtbo
audioinjector-addons.dtbo
audioinjector-wm8731-audio.dtbo
audremap.dtbo
bmp085_i2c-sensor.dtbo
dht11.dtbo
dionaudio-loco.dtbo
dionaudio-loco-v2.dtbo
dpi18.dtbo
dpi24.dtbo
dwc2.dtbo
dwc-otg.dtbo
enc28j60.dtbo
enc28j60-spi2.dtbo
fe-pi-audio.dtbo
goodix.dtbo
googlevoicehat-soundcard.dtbo
gpio-ir.dtbo
gpio-poweroff.dtbo
hifiberry-amp.dtbo
hifiberry-dac.dtbo
hifiberry-dacplus.dtbo
hifiberry-digi.dtbo
hifiberry-digi-pro.dtbo
hy28a.dtbo
hy28b.dtbo
i2c0-bcm2708.dtbo
i2c1-bcm2708.dtbo
i2c-bcm2708.dtbo
i2c-gpio.dtbo
i2c-mux.dtbo
i2c-pwm-pca9685a.dtbo
i2c-rtc.dtbo
i2c-rtc-gpio.dtbo
i2c-sensor.dtbo
i2s-gpio28-31.dtbo
iqaudio-dac.dtbo
iqaudio-dacplus.dtbo
iqaudio-digi-wm8804-audio.dtbo
justboom-dac.dtbo
justboom-digi.dtbo
lirc-rpi.dtbo
mcp23s17.dtbo
mcp2515-can0.dtbo
mcp2515-can1.dtbo
mcp3008.dtbo
mcp23017.dtbo
midi-uart0.dtbo
midi-uart1.dtbo
mmc.dtbo
mpu6050.dtbo
mz61581.dtbo
pi3-act-led.dtbo
pi3-disable-bt.dtbo
pi3-disable-wifi.dtbo
pi3-miniuart-bt.dtbo
piscreen.dtbo
piscreen2r.dtbo
pisound.dtbo
pitft22.dtbo
pitft28-capacitive.dtbo
pitft28-resistive.dtbo
pitft35-resistive.dtbo
pps-gpio.dtbo
pwm.dtbo
pwm-2chan.dtbo
qca7000.dtbo
raspidac3.dtbo
README
rotary-encoder.dtbo
rpi-backlight.dtbo
rpi-cirrus-wm5102.dtbo
rpi-dac.dtbo
rpi-display.dtbo
rpi-ft5406.dtbo
rpi-proto.dtbo
rpi-sense.dtbo
rpi-tv.dtbo
rra-digidac1-wm8741-audio.dtbo
sc16is750-i2c.dtbo
sc16is752-spi1.dtbo
sdhost.dtbo
sdio.dtbo
sdio-1bit.dtbo
sdtweak.dtbo
smi.dtbo
smi-dev.dtbo
smi-nand.dtbo
spi0-cs.dtbo
spi0-hw-cs.dtbo
spi1-1cs.dtbo
spi1-2cs.dtbo
spi1-3cs.dtbo
spi2-1cs.dtbo
spi2-2cs.dtbo
spi2-3cs.dtbo
spi-gpio35-39.dtbo
spi-rtc.dtbo
tinylcd35.dtbo
uart1.dtbo
vc4-fkms-v3d.dtbo
vc4-kms-v3d.dtbo
vga666.dtbo
w1-gpio.dtbo
w1-gpio-pullup.dtbo
wittypi.dtbo

Thanks for reporting,
I’ve fixed the issue (the overlay name changed ):
github.com/volumio/Volumio2/com … 701b2b2b7b

I will release a new image with the fix very soon.

To solve it in the meanwhile you can change the content of

/boot/config.txt

removing dtoverlay=boomberry…
and placing
dtoverlay=justboom-dac
or
dtoverlay=justboom-digi

I have just re-tested, without the isolator card (slave mode), it works (RPI3-Allo DAC).
On the other hand, if I insert the Isolator card, the error message returns.
You have an idea?

Regards.

changing the config.txt worked fine for me on the justboom DAC, but for the justboom AMP I can’t fix it at the moment.

May be the the same overlay?

  • {“id”:“justboom-amp”,“name”:“JustBoom Amp Boards”,“overlay”:“justboom-dac”,“alsanum”:“1”,“mixer”:“Digital”,“modules”:"",“script”:"",“eeprom_name”:[“JustBoom DAC HAT”,"JustBoom DAC HAT v1.1"],“needsreboot”:“yes”},

Thanks Max

Do you have the isolator in slave mode ? I think that DAC is a slave.

Hi again,

is there any solution to get the JustBoom AMP Zero working again with Volumio2 without downgrading?

iqaudio-digi-wm8804-audio.dtbo
justboom-dac.dtbo
justboom-digi.dtbo
lirc-rpi.dtbo

  • {“id”:“justboom-amp”,“name”:“JustBoom Amp Boards”,“overlay”:“justboom-dac”,“alsanum”:“1”,“mixer”:“Digital”,“modules”:"",“script”:"",“eeprom_name”:[“JustBoom DAC HAT”,“JustBoom DAC HAT v1.1”],“needsreboot”:“yes”},

Hi Max,

updating to dev-version 2.253 worked for me with AmpZero. Dtoverlay in config.txt is “justboom-dac”.

Best Regards
Raendy

I have the same problem with ASLA error for HiFiBerry DAC+ pro (DAC PLUS)
Can this be solved ?

Adding to the end of a post marked [SOLVED] is not the best place to get your problem noticed :wink: Also, the other post was DAC specific. Help yourself by starting a new topic, and providing some details such as device, Volumio version & how to reproduce the problem…

Thanks Raendy for the info. How and from where do i get the Development Version 2.253?

Sorry for the late reply!

Go to http://volumio.local/dev/ and click on Test Mode “TRUE”. Then check for updates in Web-UI under “System/System Updates”. The latest dev-version should be available there.

Best regards
Raendy

Thanks! Works for me too with 2.279 and Justboom DAC Setting on a Justboom Amp Hat :-/

Hi there, rather than make a whole new thread I thought I’d reply here.
I have just purchased and installed a HiFiBerry Digi+ Pro and I’m getting the same problem.

Failed to open “alsa” [alsa]; Failed to open ALSA device "hw:2,0: No such file or directory

I have tried disabling and re-enabling (rebooted after each change) but still every time I enable I get this message.

If it help it’s connected via Co-Axial to a Denon PNE2500 and the amp shows no signal coming from the Co-Axial port.