Problems mounting CIFS shares


I have only two days of experience with Volumio but have a strong experience with Linux and Raspberry pi . I am using now beta 1.1 . My problem is that I cannot mount from webUI any CIFS share . I was trying from my file server Centos 6.4 using samba and my Linksys E 3200 router . From both I got the same error:

mount: cannot mount block device // read-only

I tried to change in the webUI in advanced options in mont flags the ro to rw but no success

a share definition in my Samba server is :

guest ok = yes
; guest account = root
; force user = root
writeable = no
guest only = yes
public = yes
path = /raid/3_Media/muzica/flac

To use volumio now I am using NFS sharing

I figured out that the webUi does not know how to mount guest accounts. Since my router Linksys e3200 is using a guest account I have tried first in ssh the line :

mount -t cifs // /mnt/test -o guest,sec=ntlm and worked

I tried than in WebUi, after unmount in ssh :

Ip :
remote directory : ambiental
username : guest

in advanced options I have removed all and replaced by : guest,sec=ntlm

Now the share is mounted . I suggest to adapt the WebUi also for guest account installation .

I had the same issue, but your solution didn’t work with me. I had to do it in a diferent way:
sudo apt-get update
sudo apt-get install cifs-utils
sudo mount.cifs //192.168.1.*/share /mnt/NAS -o user=guest,sec=ntlm
*your ip
share - your share name

But i’m with you, to adapt the WebUi also for guest account installation

I want to second that.

I am running an Apple Time Capsule with an additional drive attached. Airport utility has the setting of a device password, so there is no user. It is not possible to mount it via web interface.

Steps to fix:

Cifs-Utils are missing:

  • sudo apt-get update
  • sudo apt-get install cifs-utils


  • sudo mount.cifs // /mnt/NAS —verbose -o password=PASSWD,rw,iocharset=utf8,sec=ntlm
    (note the sec=ntml that is necessary now)

After these steps the drive is mounted and can be used by Volumio.

I hope someone can help me.
I need to put in a username somewhere where do I do that?
sudo mount.cifs // /mnt/NAS —verbose -o password=PASSWD,rw,iocharset=utf8,sec=ntlm

I think it would be like this
sudo mount.cifs // /mnt/NAS —verbose -o user=username,password=PASSWD,rw,iocharset=utf8,sec=ntlm

Thank you very much.
This worked I also updated cifs just in case and now i got it mounted,
Now I copy past this in an email for future issues If they are there :smiley:

It doesnt work how it is supposed to be.
After turning it of or reboot i forgets the librabry nas.
I can mount it with this boot options by guide also.
Any idea why it removesthe library?
Thnx in advance I really like this project

Joep, you can add the same string in /etc/fstab

That way your shar ewill be mounted every reboot…

Thanks guys for the feedbacks, gonna fix those cifs issue… Think I’ll drop samba in favour of cifs (thought they were same, turned out they aren’t)

Af ter mounting it with the ui i rebooted directly.
The other 2 times I grot it 2 crash. Works Luke a charme now.

I thought it was about time that I checked what cifs actually is and came across this… what’s that all about? What’s the difference between samba and cifs?

I still can’t get this to work?

I’ve ssh’d into my Pi with terminal in Mac OSX and done the following:
[b][i]- sudo apt-get update

  • sudo apt-get install cifs-utils[/i][/b]
    then i tried the following:
    - sudo mount.cifs // /mnt/NAS —verbose -o user=Ben,password=******,rw,iocharset=utf8,sec=ntlm

The response i get back is:

  • Retrying with upper case share name
    mount error(6): No such device or address
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I’m using a Sony Home Server (Model no. VGF-HS1) - its intended as a DLNA server for media files, it shows up fine from my Mac and PC as well as my Receiver. I checked the info page on my mac and it shows it as “smb://sonyserver/” i did try using the smb:// in the share name on the SSH script but still get the same result.

Any Idea’s or advice would be great.


Could it be because it is
case sensitive and also i think the server is sonyserver not Sony_Server.
sudo mount.cifs // /mnt/NAS —verbose -o user=Ben,password=******,rw,iocharset=utf8,sec=ntlm

Sorry should of said - i altered the share name from Sony_Server to sonyserver in case the name format was causing an issue. Still no joy though.

tried removing the share name altogether now and it does get me a little bit further - it now asks for a password, which i assume is the root password for volumio “volumio” - it then comes back with: mount error (22): invalid argument.

Sorry, try this
sudo mount.cifs // /mnt/NAS —verbose -o user=Ben,password=******,rw,iocharset=utf8,sec=ntlm

After this, use web UI to create your Music share.
Ip :
remote directory :Music
username : Ben
password:your password

in advanced options remove all and replace by : sec=ntlm

I’ll try this tomorrow and let you know how I get on.

Hi michaelangelo, Sorry to burden you with such a dumb question, but what is the syntax for calling Joel’s script in /etc/fstab? I tried adding the line:
mount.cifs // /mnt/NAS —verbose -o user=,password=,rw,iocharset=utf8,sec=ntlm
and it just spat it out as errors.
Keep up the excellent work!
Many thanks

I am also having problems mounting a CIFS share on my network. I can’t find any way to get it to work using the Volumio GUI. I can manually mount the share through the command line, but, of course, I lose it when I reboot. I saw the comment about /etc/fstab and made the appropriate changes at the end of the file. If I manually mount everything using mount -a, I get my network share. If I reboot I also get my network share, but my changes to /etc/fstab get removed. The time stamp on /etc/fstab corresponds to the reboot time. It appears that Volumio is modifying the /etc/fstab file during boot up. If I reboot a second time I lose my network share because fstab has been restored to its original state.

Any suggestions on how to make a CIFS network share permanent?

markl, the entries in /etc/fstab are similar to the mount command line, but not exactly the same. I think your entry in /etc/fstab should look like this:

// /mnt/NAS cifs user=,password=,rw,iocharset=utf8,sec=ntlm 0 0

The space character is the separator in /etc/fstab so be sure that you have no spaces in the options section (the part that starts “user=…”).

Use mount.cifs command thru ssh, and after that you should mount your share thru web UI too. After you reboot, you should be able to see and acess your mounted share.