Petrockblock powerblock install help

Volumio Information

Volumio Version:2.882
Hardware: pi4 4gb
DAC:hifi berry dac+ pro

My issue is I can’t install the driver for my petrockblock powerblock. I have been all over google and it won’t work. Has anyone successfully installed it yet? Please help. I am very new to the pi world. My first project.

Thank you in advance

I tried that but it’s not working. I just did a fresh install of volumio but it still doesn’t work. I get a wget error.

if wget doesn’t work just grab it you could always do it by hand …
green code button and download the zip and extract it and copy it to volumio…

Like put the sdcard back in my pc and install it there?

only extract it there and copy it with ssh to your pi with winscp … login with volumio volumio and you could drag and drop it in home/volumio

I tried to get ssh to work also. But putty won’t connect to my pi.

Like I said I am very new to this. Relying on the multitude of how-to’s online.

you have to enable it in volumio.local/dev enable ssh
after this you can ssh and use putty and winscp …

Ahh ok. None of the how-to’s said that. Well. Ill try again. I just wish there was a tutorial for every scenario. Every powerblock install is raspian or retropi.

Ok I extracted and dropped it on the pi files. How do I run the file

you can do that with putty and go to the folder and from there you run
cd home/volumio/name of the folder
and ls will show if your there already …
if it doesn’t start use :
chmod +x or chmod 755

Tried run
chmod +x or chmod 755
Neither work.

The directories is in is PowerBlock-master. I’m in that folder but it won’t run.

i think you have to wait for some one who has your Petroblock if this not work …
i’m still a beginner …

Ok thank you.

Ok so I got it working. But then as soon as I plugged in my hifiberry dac+ pro. I got a restart loop. And after some digging around. I found out that. Both hats share GPIO pin 18. So does that mean I can’t use the 2 hats together or can they be set to use a different pin? ESs help. @Florian

This is my real bugbear with HATs. GPIO sounds (and is) wonderful, but you are indeed limited to those pins. Sometimes you can change around the GPIO pins used, but i2s seems to be pretty much restricted (for whatever reason). GPIO18 is a common problem… I recently have cannibalised a fan shim to remove such a conflict (but lost all the nice leds and temperature based fan control).

i just put a fan on 5 v and ground or the 3.3v and ground for a bit less noise…
but it’s always on… even with powerdown

So do I not use the dac or the safe power down switch lol
Is there another way to do the power down without using 18?

i wrote that in your other post ssh with putty : sudo shutdown or with the UI shutdown >> power off
there is a other hat but don’t know if that will give the same problems…

Can I pull audio from the hdmi on a pi4?