Petrockblock powerblock install help

there is no input on hdmi …only output

Yea I know that’s what I mean. Can I pull audio from the hdmi output on the pi4? Or are they strictly video outputs.

only output on hdmi sound should go true your dac… best sound…
you could output sound on hdmi but you lose the quality sound of your dac…

Really bums me out. The enclosure I’m using has a power switch. And I wanted to keep it looking like it came that way. It’s a vintage pioneer enclosure.

you could try a shutdown command with a remote …
but power on is not possible that way or with that other board

Yea but the button is still not used. I really want to be able to use it. There has to be a way to get this working.

yes, that is essentially what I have with my chewed up fan shim. :confounded:

Well you could use it literally as a switch on your power supply (not a great solution ofc), but unless you can find an ‘off the shelf’ without GPIO18, then it would need to be homegrown. I suspect there would be quite a few people interested if you came up with such a solution. :smiley:

@chsims1 @Mayday maybe this is a option?
it seems that the pi remote uses gpio 14 and 15 and it could run a fan …
if you de-solder the button and put that in to test board with wires it should do the trick…
you could do that with the ir to i guess… ( they have this already included in a version incl a led )

  • New : The board has a 2 pin PH2.0 connector to power an optional 5V fan. The fan is only running, when the Raspberry Pi is on. We have a matching fan available here, and also offer an acrylic case with a built-in fan here

I just found that hifi berry is working on something. As this has been an ongoing issue. It seems like it uses a rotary encoder to power down the unit. But I wonder if there is a way to change it out for a button? Ie. Desolder the rotary encoder.

1 Like

i know that one to …if it work …it works…

1 Like

Wait I can still use my power button!
Just put it on the main power going to the pi.
Use the shutdown on the UI in volumio to safely shut it down. Then push button out to cut all power. Then when I push the power button back in, the pi will think that I plugged it in again and power back up.

If that makes any sense. Or am I losing it. Lol

it looks that you have it working but test it a few times …and don’t lose it :stuck_out_tongue:

1 Like

I just got confirmation of the devs of the powerblock. And he said that I can use different pins instead. The pin in question is pin 18. So what pin could I use in place of it?

The hifiberry uses gpio pins 2,3,18,19,20,21.

Could I use pin 12 or 13 in place of 18? Just looking at the gpio pinout. Looks like those are the only other 2 that have pwm that aren’t used. Or am I wrong.

1 Like

i guess you have to alter it in /etc/powerblockconfig.cfg can’t test it to see if it works…

1 Like

Yea I saw it in there before. You can change them. Just not sure what to change it to.

i can’t advice you on this can’t test it… just try it… or ask the dev for advice
i see that you already have contact with guys at petcockblock they can tell you with what you could
switch your switch…

1 Like

Well I figured out. I changed the powerblock config file from 18 to 12. Then did a shut down. I used a jumper on s1 on the powerblock pcb. And connected it to gpio12 (that’s a pin the hifiberry doesn’t use) then connected the hifiberry. Then pushed the power button let it fully boot up then pressed it again to shut it down and all worked perfect. Just posting this here incase anyone else has the same issue I found the fix.

1 Like

most of the time it’s just trail and error, nice that it worked … :slight_smile: