Open Beta Testing of new TIDAL and QOBUZ implementation, feedback wanted

Dear guys,

first, let me introduce myself: I am Davide, Customer Support Specialist @Volumio and I am also taking care of quality control.
I am really pleased to be part of this active and passionate community.

Many of you complained that current TIDAL and QOBUZ implementation require some love, and after months of hard work by the development team, we are finally ready to showcase the first beta to you.

This new implementation is completely redone from scratch, and we implemented it in a way we can solve any arising issue very quickly (and see what does not work in real time) without requiring you to update your Volumio instance.

You will notice that on the browsing side, not much has changed. But as this first step we want to make sure everything works and then go with some planned updates.

We’ve hidden this feature in a way that only motivated testers can enable it, in order not to distrupt the experience of whoever wants something that just work.

If you are interested in testing the new implementation, here’s how you do it:

  • Create an empty file for the test:

type: touch /data/cloudexperimental

  • Close the TERMINAL and RESTART Volumio

  • When Volumio is on, go to

SETTINGS→ SOURCES→ LOGIN Tidal and Qobuz→ Insert your LOGIN credentials

Now you are ready to try the new Volumio TIDAL and QOBUZ implementation.

Shall you find any inconsistency, error, issue of any sort, please report it here.
It is also useful to paste the log link after your error happens and describe what were your actions prior to the error.

If everything goes according to our plans, we shall be able to release this implementation for everyone in about 2 months.

Please enjoy

my best,

Davide
CUSTOMER SUPPORT SPECIALIST

1 Like

Hi Davide,

what is the version number of this beta ? For Odroid C2 ? 2.824 ? How Can I realize that this is the new test version ? What are the differences ? For what to look for ?

Hi,
I am on version 2.806, sgould I use the latest beta version in order to test this new qobuz implementation.
Thanks

Sorry, but things seem to actually getting worse from previous implementation!

First of all this issue is still present, which is making Volumio rather useless for me, as Qobuz is my main source: each and every track stops after about a minute! (see curl errors in the log)

Then, has become much more difficult to search for specific albums or tracks.
For example: before, to reach for this album I simply wrote in the search bar (which is always way too short, as I once wrote here, receiving no answer whatsoever) “scarlatti ross 20”.
Now… I tried this and many other search strings to no avail. I finally reached it at about twentieth trial not remembering exactly how!

About this issue and searching in general, a feature that lacks from official Qobuz app is the possibility to set a default genre (i.e. ‘classical’) to filter results.

Sorry for being crude, I wanted to go straight to the point, nevertheless I really really applaude your efforts to improve Qobuz intergration and looking forward to see it getting better. Please keep it up! :slight_smile:

Thank you Davide for improving us volumio!

here my first impression.
i went to 2.832.

going to tidal ‘My music’ is after tidal ‘Discover’s’
going to qobuz ‘My music’ is first, so before qobuz Discover area.

in playback options: After login to tidal Master Quality (MQA) is enabled an on.
But i don’t have “TIDAL HiFi”, just “TIDAL PREMIUM” - so no MQA is used.

choose a album to play in tidal it takes all CD’s to album and play’s CD1, Track1, than CD2, Track2, CD1, Track2, CD2, Track2, and so on.
should be playing at first compelete CD1, than CD2, and so on…
Try “Max Richter Voices”

there is a second of interruption between every tidal track.

single and continuous playing behaviour seem to work for me.(Thank you!)
that’s it for now. good day, jens

Hi volumio team, Hi Davide,

Here is my first report :
System Odroid C2, volumio 2.824, USB-DAC : SMSL M500 ( HW MQA capable, which works with not “beta” volumio)

A. No MQA playback

  1. After swiching to “cloudexperimental” mode
  2. Logging into TIDAL
  3. Keeping the preset values : Sound quality : Highest Possibile, MQA : On,
  4. Playing MQA files from TIDAL (files with “M” - like Muddy Waters : Folk Singer) does not “switch on” MQA indicator on M500 DAC display
  5. Volumio shows : 44.1 kHz, 16 bit
  6. And sometime playing hangs up, and blocks any upcoming playback try from TIDAL
  7. Switchin off the MQA option for TIDAL in Settings / Sources
  8. Playing the same album,
  9. Still no MQA indicator on M500, but
  10. Volumio shows 44.1 32 bit

B. Loading and playing very long playlists

Previous TIDAL implematation was unable to load the long play lists completelly - for example Rolling Stone: Best Songs of All Time. Now its look like this is ok, I did not count the number of songs, just check few songs from the beginning and the end of the list …

C. My Mixes

  1. Finally I can see and play my mixes, Yeah !
  2. But the play queue list has nothing to do with my mixes playlist :slight_smile: . I tried to find out some logic, but currently I have no glue what is going on …

Thanks guys for your fast reactions and feedbacks!
Some of the issues you mentioned were already taken care, while we add every suggestion\feeback in the pipeline.

We will keep you posted when an update is available after this first batch of issues are solved :wink:

Next,

clicking on Previous Button ( I< ), the artist - song - album from title disapear, and it is replaced with something like this : “0.flac? token=1600603620~ …”. Skipping to next track the display is OK again …

Next,

Differences in volumio’s Play Queue vs volumio’s TIDAL Playlist vs native TIDAL app Playlist

  1. I used as a comparison the TIDAL playlist Rolling Stone: Best Songs of All Time
  2. native TIDAL playlist is different than volumio’s TIDAL playlist
  3. Loaded volumio’s TIDAL playlist into volumio’s Play Queue is different to each other,
    there are songs listed in playlist but not listed in queue list, and what is funny, this is true for opposite way : there are songs listed in play queue, but not listed in playlist.
    Totally crazy.
  4. THere are songs which is not playable, this hangs up the playback of the queue. If you like to continue, you need to press next ( >I ) button…

Updated to 2.833 ( Odroid C2) : quick tests done. Results :

  1. volumio’s My Music TIDAL playlist == Play Queue list ( not checked the whole list …)
  2. MQA still not playable, just 44.1 kHz 16 bit ( I have feeling that my TIDAL credential is wrongly interpreted)
  3. Prev ( I< ) button still shows 0.flac?..
  4. Some songs still not playable ( but loadd into queue play list, maybe because of copy right for some countries ? )
  5. My Mix playlist is randomly loaded into Queue play list ( checked one-by-one, but not the whole list …)

Good example for uplayable tracks is the Chris Botti : Live in Boston album. It is really - really nice, but I can play only few songs from this album here in Hungary. It is no matter that I play from TIDAL app or volumio’s TIDAL ( or from Spotify )…

But if this is a situation, it will be a good to have option to hide unplayable tracks from playlists, and to diasable to have them in search results

now on 2833. found no difference to 2.832

add:
too few hits with qobuz.
search example: “Richter voices”
it’s an album from Max Richter “voices” - no album hit.
in tidal there are the right hits

Edit:
when i click on the progress indicator instead the title now this is showing:
file?uid=84136&eid=957244&fmt=6&profile=raw&app_id=53948&oid=3822&olid=2&etsp=16029597&hmac=4FwLJyNnDWZ… (qobuz)
with tidal tracks tis: e75ec628f8d73a8aa292fd9b0d_37.mp4?token=1…

previous track is not working

In Tidal my Artists are not showing

hi!
With Qobuz, I still have the same problem than with “old” version : some album, appears as hires in Volumio, but they are not (compare with Qobuz)

Hello
Thank you for your very valuable work!
I have installed the latest Volumio. So far it looks pretty good.

What I found:
If I add a track to any Volumio playlist in Qobuz, it works fine.
Unfortunately, if you want to remove a track from the Volumio playlist, it doesn’t work.

The same thing happens with a Qobuz playlist.
Adding and removing tracks works perfectly with tracks from your own FLAC collection.

Here is the log:
http://logs.volumio.org/volumio/hi4R3G5.html

Hello
Both with the stable version and with the latest beta version, it takes a long time if e.g. an album is added to the favorites on the original Qobuz web interface or in the Qobuz app until the album is displayed in Volumio’s Qobuz favorites.

Here it would be good if there is a possibility to update the selection manually.

regards
rust21A

I’m on 2.833 running Qobuz.

Everything is working fine so far.

I’ve just noticed that switching to Spotify, playing a track, then switching back to Qobuz shows codified track names rather than the proper names.

Seems to be once only, then reverts to correct display.

Installed. Tried to use both Audioquest Dragonfly Red and Cobalt and Audirvana as MQA decoder sending music to Volume installed on Raspberry Pi4. The light on the Dragonflies turns on and off from MQA color reproduction and ends to turn off MQA reproduction. Uninstalled the Dragonflies and reinstalled from the proper system path. No solution at the moment.

I think the new Volumio-system runs much faster - that’s very positive!
Many thanks!!!

rust21A

In Qobuz: search for The Knife. Doesn’t find the band. Search for Knife and finds The Knife as the first result.

Select the band, go to the album Silent Shout. Gives Error: no results.

I had written it before. I would appreciate it if the length of the track would be in the queue for each track. There is always room for it.

rust21A


Phone


Tablet