New Volumio Spotify Plugin Open Beta-Testing

I’ve installed the latest and I’m still seeing some issues:
Raspberri Pi 3
System version 3.301
Spotify plugin version 3.0.1
Wired connection
Free account (spotify is premium account)
Currently using onboard Spotify player, not Spotify connect.
Playlist stops playing and inaccurately shows very long track lengths. Also will not switch Spotify playlists without a restart first.
log: http://logs.volumio.org/volumio/2kHRxzF.html

New plugin not playing any spotify track, The login is O.K. and track browsing is also possible. When i want to play a song, nothing happens.

Same issue as described by @Wheaten. Constantly skipping songs.

Is it possible to have the old plugin in the plugin store again please?

Logs please!

Raspberry 1&2 doesn’t work at all. GUI doesn’t refresh, no music, no change track. Thats happens wit any spotify playlist, the rest of sources works fine. I sent log (http://volumio.ip/dev) from two devices.

http://logs.volumio.org/volumio/OCjX9hc.html

Volumio version 3.301
Volumio free version, Spotify Family account.
Spotify plugin 3.01
Device; Intel Core2 Duo Mac Mini dual booted with Volumio on seperate SSD.
Wired network connection.

Unfortunately I can’t get the log files easily as I’m currently running headless, but I believe I am seeing the same issues as @Wheaten and @Ema82 in that Spotify Connect is acting erratically.

I managed to get Spotify to see Volumio as a Spotify Connect device, but only after a uninstall/reinstall of the Spotify app, which seems odd.

I can now cast a playlist or track to Volumio, but when I click pause in Spotify on my phone, it is like the Volumio device overrides it and starts the track up again, so there is no way to stop the music without going in to the Volumio app and clicking pause.

The ‘now playing’ listing also seemed out of sync between Spotify and Volumio, or certainly for the first track.

In Denmark all songs are skipping.
I will try the hosts file workaround

Hi,
Same Problem here! I have a clean install and no luck. I already shared the problem before.
Raspberri Pi 3
System version 3.301
Spotify plugin version 3.0.1
Wired connection
Volumio Free
Spotify Family
http://logs.volumio.org/volumio/9ZBPNrG.html

Thanks for the hard work!

ahhhh!
So i see now, how this plugin works.
Volumio plays spotify tracks ONLY, if the output device select to Volumio in the spotify app settings!!!
Sorry guys.

If multiple VOLUMIOs work with the same user on the same network as the same SPOTIFY user, the volume buttons will “clutter”.
There is no multiroom group 3pcs VOLUMIO, but it connects SPOTIFY volume.
I don’t know if this is a mistake or a deliberate design …

VOLUMIO 1:

RPI 4 - 4GB
VOLUMIO 3.301
SPOTIFY 3.301
Volumio: Premium
Spotify: Premium

VOLUMIO 2:

Tinkerboard 2
VOLUMIO 3.301
SPOTIFY 3.301
Volumio: Premium
Spotify: Premium

VOLUMIO 3:

RPI zero 2
VOLUMIO 3.301
SPOTIFY 3.301
Volumio: Premium
Spotify: Premium

Same here! Use Family Account for Spotify and free version of Volumio. Connect works, search for album works also - playing song does´nt work. Greetings from germany
Sysinfo:

  • OS info

  • Version of Volumio: 3.251

  • Hostname: volumiowohnzimmer

  • Kernel: 5.10.92-v7l+

  • Governor: performance

  • Uptime: 1 days, 8 Hrs, 26 Minutes, 37 Seconds

  • Audio info

  • Hw audio configured: HiFiBerry DAC+ Pro

  • Mixer type: Hardware

  • Number of channels:

  • Supported sample rate:

  • Board info

  • Manufacturer: Raspberry Pi Foundation

  • Model: Raspberry Pi 4 Model B Rev 1.5

  • Version: b03115

  • Firmware Version: Jan 20 2022 13:56:48 - bd88f66f8952d34e4e0613a85c7a6d3da49e13e2

  • CPU info

  • Brand: BCM2711

  • Speed: 1.5Ghz

  • Number of cores: 4

  • Physical cores: 4

  • Average load: 4%

  • Temperature: 61°C

  • Memory info

  • Memory: 1962272 Ko

  • Free: 710488 Ko

  • Used: 1251784 Ko

  • Storage info

  • INTERNAL storage - Size: 4755Mo

  • Used: 1764Mo

  • Available for storage: 2742Mo (58%)

I face exactly the same issues at an identical setup with the same SW versions.

My logs are at http://logs.volumio.org/volumio/DLAtiAf.html.

After trying different things, this worked for me:
-restart your volumio
-ensure that you are logged in on the plugin
-play from the Spotify on a PC by selecting the volumio as an external player
-After that, make a change on the spotify plugin, like add a playlist to the queue.
-Disconnect the PC from the external player
-Now You will be able to control the volumio.

Hi,
same for me. I can’t play songs with casting via spotify connect from Spotify App(android). It’s playing 1sec and jumping to next title. I can’t stop it or pause.
My config:

  • Raspberry Pi 4 2GB
  • latest volumio version
  • plugin installed via Add-ons manager
  • DAC JustBoom DigiHat

So firstly, how can I revert to previous spotify connect plugin? It worked well but currently I can’t find in on the add-ons list.
Logs: http://logs.volumio.org/volumio/4P8IZjX.html

The old plugins no longer worked due to functionality discontinued by Spotify. Hence the rapid development of this plugin. Please be patient. The problems will be sorted out, it’s only just released and works pretty well for most already.

1 Like

I absolutely agree; there seem to be some occasional bugs (playlists stopping, songs not playing, tracks skipping, …), but overall it is amazing how fast the problem has been solved to a satisfactory result. I could imagine some of the remaining problems will be straightened out over time.

I had to make sure that I got the right settings saved successfully in Spotify (set Volumio as device) and for some reason had to do it more than once. I do not really remember, but I think setting Volumio as device and directly playing some music via Volumio before logging out from Spotify did the trick for me. Has worked now for the last couple of days and listening to several playlists via Spotify plugin without any issue all morning made my day.

Once again thanks that so many people were willing to tackle the problem that fast, especially since there are so many different combinations of boards, DACs, software, Spotify subscriptions, etc.; this must have been a real challenge! Rock on!

Cheers Gazza

1 Like

In my case the plugin did not work either, the spotify application did not see volumio as an external device and spotify in volumio did not play songs. in my case, I was logged in to two different spotify accounts under my spotify premium family account. it turned out that you only need to log into the same spotify account in the application and volumio once and it started working. just enough

The new plugin works fine for me. I only use it as spotify client, using the volumio webinterface. I didn’t test the “spotify connect” function.

I have only one device with volumio in my network.

Thanks for the fast development.

I’m totally having this too. Looks like they are still scanning this thread (I guess it worked for most?) but I can say for certain my install isn’t playing any tracks or playlists. Skips through most tracks after about a second although by what seems like random poking around I can get certain tracks to run clean.

Oddly, at times when it skips SINGLE tracks I click it seems to “load up” 50-100 tracks in the Volumio queue. Even when I get a successful track running the queue gets loaded with more tracks that I didn’t ask for.

FWIW if something doesn’t work it consistently doesn’t work. If I look for “Vienna” by Billy Joel and try to run it it will never run it will skip to “Uptown Girl” and load the queue up 100+.

I have no success using Spotify Connect from another device to Volumio

  • Raspberry Pi 2 Model B Rev 1.1
  • 3.301
  • HiFiBerry DAC Lite+ 1.3 Wireless
  • Volumio Free / Spotify Family Premium

http://logs.volumio.org/volumio/2rIR6Ey.html

1 Like