Issues with upgrading to Volumio 3

So, I saw the newsletter about Volumio 3, and I rushed to upgrade to see if it will help with all little issues with using Tidal, but it only made things worse.

I am using Volumio on Raspberry Pi 3B+ with Hifiberry Digi2 PRO, mainly for Tidal. I am a Virtuoso user.

With upgrade to Volumio 3:

  • I no longer see hifiberry as output device
  • When trying to connect to Tidal (through Tidal integration), I am redirected to Tidal error page.

I have no other choice but to go back to previous Volumio version.
Any ideas about the issues above?

Ok, so issue #2 is not a Volumio issue, but a Tidal issue, so scratch that.

I’m experiencing the same issue. Why do you say it’s a Tidal issue instead than a Volumio one? How did you find it out?

please eneable 12S DAC

Checked couple of forums, and I saw the announcement on Tidal Twitter page.

Because trying to start Tidal on a PC or ipad doesn’t work either.
There seem to be internet issues in several places, Volumio’s external pay service supplier was also affected earlier this evening.

No sound is coming out. For previous Volumio version I was able to select hifiberry as output device, didn’t use I2S.

Prob caused by all the V3 downloads :rofl:

Yes, there is a big outage with Amazon Web Services, which is causing outages to quite a big number of things (TIDAL, Netflix, our payment provider).

Situation is improving but nothing to do more than wait…

Mr. Volumio, any idea on the hifiberry missing from output devices in Volumio 3? :slight_smile:

You need to go to playback options, enable I2S and select your Hifiberry Model.
Even if you did not do it in the past, this is the correct way to do it.

Just while reflashing my 3 home systems at the same time :scream:
Should have done one after the other, could not have happened at a worse moment :see_no_evil:
But then, I can finish the Tidal config tomorrow, just bad luck…

Yeah… AWS outage in the day of launch of Volumio 3 … Really a bad luck!

And consider we avoid AWS for this reason… but since every tech company uses it, you cannot be unaffected anyway…

I did that, but there is no sound coming out. Hifiberry Digi 2 PRO is not able for selection, so I’ve selected Digi+ PRO (which is just the previous, discontinued model). It is then connected through S/PDIF to Schiit Modi 3 DAC…

Try jut hifiberry digi and reboot

Just tried it, still nothing :frowning:

Sorry for that.
We will investigate if this requires an overlay (parameter) which is still missing.

No problem. In this case, I would like to revert to previous Volumio version for the time being, but I can’t find a download link. Is there one?

EDIT: Found it -
EDIT2: Everything works now with previous version.

Thank you for the quick help and support, didn’t expect it at these hours :slight_smile:

You meant Tidal Connect works for you with previous version also? I may need to go back to previous version since Tidal Connect doesn’t work for me with Volumio 3. Don’t see much advantage in new VolumIO 3. I only need Tidal connect

Tidal connect doesn’t work at this time, but it seems those are just temporary issues with Tidal, not Volumio.