FusionDsp : the complete Dsp center for Volumio3!

Yes, the previous v1.0.21 corrupted the config file.
In your case, to fix

disable the plugin and remove the config

rm /data/configuration/audio_interface/fusiondsp/config.json

Then enable the plugin
Or remove it and re install

1 Like

Seems to be working now. Thanks for the quick fix!

you’re welcome

1 Like

Info : Autoeq updated theirs methods of optimization for Eq. Now it supports Highshelf and Lowshelf filters.
In FusionDsp, to use new calculated Eq with the new algorithm, just reselect your headphones and press ‘load and use’. That’s it :wink:
Warning : previous Eq are not available anymore.
More details Post in thread ‘AutoEQ Magic?’ AutoEQ Magic? | Page 4 | Audio Science Review (ASR) Forum

1 Like

If you tested the new Manifest UI and its HUB, you probably noticed a new button if FusionDsp is installed… A quick access to enable/disable effects and a scrolling list for quick preset selection!
You need last FusionDsp v1.0.22




FusionDsp v1.0.23 stable

Enjoy :wink:


can the two creators of fusion dsp and peppymeter get together to solve the problem so that both plugins run together, i have already asked in the peppymeter thread…

I already suggested the author in peppymeter thread to modify the plugin to be conform with volumio3 requirements…
But it seems to be not a priority…
FusionDsp is conform to requirements.
I’m ready to help to make plugins working together though :wink:


Hello balbuze, thank you for your answer :slight_smile:
One user had this fix here, but unfortunately it doesn’t work

Without any music playing…

nano /data/plugins/miscellanea/peppy_screensaver/peppymeter/run_peppymeter.sh


if ! pgrep -x “python3” > /dev/null


if ! pgrep -f volumio_peppymeter.py > /dev/null

ctrl+x , ctrl+y, enter , to save file and it should start working after the screensaver timeout value when you start plying music.

if you want to make the VU move more

nano /data/plugins/miscellanea/peppy_screensaver/peppymeter/config.txt

look for [data.source] and change volume.max = 100.0 to something higher like 200, experiment what works for you

Sorry I can’t answer for peppymeter.
This is a FusionDsp thread.

Hi Balbuze,

Not related to priority, but the author @2aCD, is running a big project that takes all of his time. Since that project pays his bills… we need to be patient.

Just reinstalled Volumio and FusionDSP but it still appears to be extremely buggy.

CamillaDSP just won’t work whatsoever. When I apply DSP settings it will just switch to ‘offline’ and music playback will stop.
It even crashed Volumio and I couldn’t browse my music or menus anymore.

Too bad, I really like the Volumio user interface but I’ll have to go back to MoOde where CamillaDSP works flawlessly

Sorry to read this… But you seem to be the only one with such problems.
So it’s very important for us to understand what happens.
Can you describe exactly how to proceed to reproduce the issue?
Did you install something else by ‘hand’ on your system?
And please send your log Sending logs for troubleshooting - Volumio Documentation

Occasionally unstable behaviour like this can be due to a corrupt SD card. Which type of card do you have and how old is it?

1 Like

I used different SD cards with Volumio and still get the same issues. Currently using a SanDisk Extreme.
I did a fresh install of Volumio and FusionDSP but still no luck.

CamillaDSP will work at first but as soon as I change filters or any setting while music is playing it will stop working after I apply those changes and music playback will stop.

How do you apply filters ? In FusionDsp or in CamillaDsp?
Have you read the help in the plugin to know how to change/save settings in CamillaDsp?
What kind of filter do you use?
Can you provide log please?

I only use CamillaDSP. I add a new filter to my any of my channels and after applying it the playback stops and CamillaDSP stays offline. I tried to load my old config but it still stays offline. I did everything as described in the fusion manual but it doesn’t work.

The log: http://logs.volumio.org/volumio/6938zCN.html

I’ll just use my SD card with moOde again. It just works flawlessly there and I get external inputs without a subscription

It seems you changed the output device in CamillaDsp.
If it is the case don’t. It must stay as set by FusionDsp
Edit: and please, give filters and values you use. Last point, why don’t you set it in FusionDsp?

CamillaDSP is just much more powerful than any other DSP out there imo.
I already have configs with parametric EQ and FIR filters to use with camillaDSP. I also prefer the GUI of CamillaDSP.
I‘ll check if a wrong output device caused this issue

Quick question about the Harman curve - if I have already used REW to create a set of WAV files for the Right and Left speaker (using they target curve options within REW) what would the Harman Curve in FusionDSP do to that target? Would this exaggerate the curve more again? If so what is the use case for using a target curve in FIR creation from WAV files?