FusionDsp : the complete Dsp center for Volumio3!

Hello,

yesterday i had a little workaround with Fusion and REW.
It’s fine.
The import option (make a txt File in REW and copied it to Fusion) makes the setup much easyer.
Will say thanks again.

Flo

1 Like

Hello!
FusionDsp v1.0.18 stable release

  • remove wrong filters in Peq
  • fix auto pre-amp calculated value.
    Enjoy :cowboy_hat_face:
2 Likes

Amazing @balbuze!

Hello together

Can I create a crossover with the zones in Multiroom and FusionDsp?

I want to run the satellites in one zone and the subwoofer in another zone. I want the satellites to be separated at 100 HZ and anything below 100 Hz to be reproduced by the subwoofer.

Thanks a lot.

Hello!
Multiroom send untouched signal. So on each device a different Dsp setting can be applied.
On the first device only <100Hz set a Lowpass 100,0.707


On the second device with satellites > 100Hz set a Highpass 100,0.707

And you’re done :wink:

1 Like

Hello balbuze,

thank you for the quick and positive response.

Have a good Sunday

Hello!
FusionDsp v1.0.19 beta

  • Small fix for preset for PEQ for a future use… :kissing_smiling_eyes:
  • Updated default headphones list (more than 4150 models!). Thanks AutoEQ
1 Like

Hej,
I’m having a problem when using fusiondsp together with a homecinema receiver using hdmi. I’m using 5 channels in advanced mode and it works fine. (I’m having an active speaker system playing stereo). But, camilladsp stops and restarts with a new config every time I switch album. I can reload my config with apply but that’s a bit cumbersome…
Br Thomas

Hi!
You have to set FusionDsp on Pure Camilla Gui mode and stay here.
In Camilla Gui, once you have set your values, save your config camilla.yml (or something like that) in the required tab. It should be fine :slightly_smiling_face:
Edit: see here. How-to FusionDsp - #39 by balbuze

Hello!
FusionDsp v1.0.20 stable

Enjoy :slight_smile:

1 Like

Hello!
FusionDsp v1.0.21 stable

  • New switches to mute channels
    image

  • Translation improvements

  • Added Harman as target curve for FIR creation

Enjoy :slight_smile:

2 Likes

I’m having issues with 1.0.21 running on the latest Volumio betas.

  • I entered some parametric settings and saved as a preset. The tracks would play but there was no sound.
  • if I used the EQ disable button (can’t remember the exact name right now), I got very distorted sound coming from the right channel only when the EQ was disabled.
  • I saved the same EQ settings as another preset and this time the same settings worked differently with audio only in one channel.

So it’s basically unusable for me at the moment but as I updated both Volumio and FusionDSP at the same time, it’s hard to be sure where the problem lies. If I find time, I might install FusionDSP 1.0.20 instead and see if that is working better.

I see. It is because I added new settings and the config file seems to be not updated correctly. 2 ways : remove and reinstall the plugin v1.0.21 or disable the plugin and remove the config

rm /data/configuration/audio_interface/fusiondsp/config.json

Then enable the plugin
In both cases, you lose your settings…
I’ll have a look to see how to fix it.

Sorry for that.

1 Like

WARNING! I found a bug in FusionDsp v1.0.21 as @Voluminous described.
I’m going to fix it.
The problem occurs after saving and loading a preset.
Please wait for next version…
Sorry for that :wink:

2 Likes

FusionDsp v1.0.22 stable

  • fix for distorted sound bug introduced in v1.0.21

Sorry for inconvenience :wink:

3 Likes

Thanks, i updated and still got sound from only the right channel using my preset. So then i decided to explore the “More settings” menu and saw that “left mute” option was selected, although I have never selected this feature. I unselected and applied the setting change (and got sound from both channels again), saved the setting, switched settings, then switched back to test it and the left mute was applied again. Seems that I can’t get rid of it.

Yes, the previous v1.0.21 corrupted the config file.
In your case, to fix

disable the plugin and remove the config

rm /data/configuration/audio_interface/fusiondsp/config.json

Then enable the plugin
Or remove it and re install
:upside_down_face:

1 Like

Seems to be working now. Thanks for the quick fix!

you’re welcome

1 Like

Info : Autoeq updated theirs methods of optimization for Eq. Now it supports Highshelf and Lowshelf filters.
In FusionDsp, to use new calculated Eq with the new algorithm, just reselect your headphones and press ‘load and use’. That’s it :wink:
Warning : previous Eq are not available anymore.
More details Post in thread ‘AutoEQ Magic?’ AutoEQ Magic? | Page 4 | Audio Science Review (ASR) Forum

1 Like