FusionDsp : the complete Dsp center for Volumio3!

Internal process is done using S32_LE format.
The final output is adapted to HW capability by ALSA via Volumio Volumio AAMPP Overview | Volumio Developers Documentation
Resampling in FusionDsp is applied whatever is the source.
Resampling does not (IMHO) improves SQ in a way I can hear…
So, hard to advice…
Without resampling, output samplerate is the same as input.
If you use convolution filter, you have to use one filter by samplerate.
BR

1 Like

hello @juliangst
no news from you.
Did you check the wrong output you set?
If it still not working we need to find why.
But if it was the problem (what I think), it would be honest and fair to write, here and elsewhere RPi4 + CamillaDSP Tutorial | Page 36 | Audio Science Review (ASR) Forum
that it was not a bug in Volumio or FusionDsp…
:wink:

Thanks BR! I’ve turned off resampling to keep everything native in that regard. I, too, do not notice any sound quality difference through comparisons in the past.

I’ve also found it interesting that my DAC shows support for S32_LE format but it says it’s in 24-bit. Would that suggest that FusionDSP’s S32_LE is also in the 24-bit domain, or is that one 32-bit? And, I imagine, that means there is conversion happening somewhere at some point (original source to S32_LE then back to whatever supported output of the DAC per AAMPP). I know it’s fairly common for this to happen with DSP, just curious of those details.

Otherwise, I had one hitch a couple days ago, two different times, where my music from my NAS wouldn’t play (in fact, one track played with static oddly enough). Rebooted the Pi with Volumio on it and it worked after that. Not sure this is related to the DSP or something else perhaps. The NAS is accessed through SMB which is hosted by another Pi running DietPi on the same network, wondering if a more direct NFS share might be better but also not sure this is the right thread if the DSP doesn’t have anything to do with it haha.

no comment…

That was me (hovation) trying to help out as well but I suppose they found their own way.

Ok, no worries… I just think not fair to simply say it’s buggy when the issue probably comes from a wrong setting done by the user…

I hear you, those misunderstandings can be frustrating sometimes.

FusionDsp v1.0.24 beta

  • 5 presets for convolution mode. Very easy to compare different filters! No shortcut in ManifestUI yet.

Warning : This is a beta, need to remove previous, reboot, install… Settings are lost
Enjoy :wink:

1 Like

I’m too busy enjoying 1.0.23. It just works and works well :smiley:

FusionDsp v1.0.25 stable

  • 5 presets for convolution mode. Very easy to compare different filters! No shortcut in ManifestUI yet.

Don’t forget to reboot after install.
Enjoy :wink:

2 Likes

Good evening, I encountered such a problem when I use the filter then the volume drops to 40 dB, in the interface it shows the same 3 db. If you switch the volume to the equalizer, the volume returns to normal.
How can this be fixed?

Hello.
Can you give more details please.
What is the FusionDsp version?
Volumio version?
How to reproduce the issue?
Do you use preset?
Thanks

Good evening. Sorry, I was quick to ask a question. I have two ancient macmini, one of them had such a problem, I thought it was a re-phase settings file. moved it to the second player there no problem.Tried to reset to factory settings the problem remained. Reinstalled the system again and everything works.

Good. I think you had v1.0.21 that was not working properly (fixed issue now).
But if ok, enjoy!

FusionDsp v1.0.27 beta

  • Bump to camilladsp v1.0.2!
  • Cosmetic Camilladsp GUI uses Volumio colors.
  • Online help is can now be download and translated
  • Headphones list updated.

Warning : This is a beta, need to remove previous, reboot, install… Settings are lost
DOES NOT work with arm6l (RPI ZERO…)
Enjoy :wink:

1 Like

I’ve been trying to use FusionDSP to play a sweep file and have REW analyse the results. I’m not having much luck figuring it out. I can’t even figure out how to get REW to record the sweep. I hit start in REW and then start the sweep file in Volumio. Nothing happens!! Is there a guide out there that will help? I need REW for Dummies!!

First Steps with REW

Turn your Loudspeaker from Pc down, after starting Measure, press Play in Volumio, to start the Measurefile from Volumio Storage.
I think here is not the right Thread.
There is a Thread named „Fusion How to“

1 Like

This is just to provide some good feedback and congrats to the development team. Great work !! Using Volumio on an Rpi for years, I just updated to 3.378 on my Rpi-2B, installed and configured FusionDSP (1.0.25) with a couple of EQ build with REW, and this little thing works like a charm ! Very impressive. I feel like I was waiting for this one for ages, it changes everything. The HW configuration is quite simple, at purpose : home made streamer with Rpi-2B with a 5" display and Audiophonics ON/OFF system, feeding an SMSL AD-18 amplifier in USB, and a pair of TRIANGLE ANTAL EX.
Fantastic job ! Long life to the Volumio project.

1 Like

Hello,
So pleased to read you :slightly_smiling_face:!
Did you used the import function in FusionDsp for Rew Eq?
Thanks for your feedback and enjoy music :musical_note:

1 Like

Hello there,
It’s my modest contribution :blush:
Actually, I just copied/paste the txt files generated by REW in /data/INTERNAL/FusionDsp/peq folder, as recommended. It’s a fairly easy process.
BTW yesterday I had system crashes when tweaking the FusionDSP settings while playing music (forgot to pause music before updating the settings).
I mainly stream music from a NAS and from Radio Paradise through the plugin.
Thank you for your participation in making quality music accessible to as many people as possible. :+1: