Cambridge DacMagic 200M not playing DSD

The topic title is pretty self-explanatory.
Just got a DacMagic 200M and my DSD files from the NAS don’t light up the DSD LED on the DAC. Somewhere along the chain, it’s converted to PCM.
I believe the settings are correct, and are the same that worked with various other DSD capable dacs.
Any idea or help is appreciated…
TIA

Hi,
Pls give more details platform, volumio versions, setings, etc.
Thbaks

Hi Lintbf, sorry for being short on details, it was late…

So:
Raspberry Pi4 with oficial power unit
Myvolumio v2.882
USB to Cambridge DacMagic 200M

The Rasp is connected trought ethernet and it’s only connected to the dac, nothing else. DSD, WMA, FLAC and MP3 files on a NAS.

Settings:
DSD Direct
Mixer type: None
Audio resampling off

Is there anything else relevant?

Hi,
Try to change dsd direct to dop and see then
Regards

Thanks, will do later.

Ok, DSD over PCM (DOP) works.
But my question remains: why does it not play DSD direct, if any other DSD capable dac that I’ve tested managed DSD files with a itch?..
Naturaly, if other dacs behave as they should, the problem is most certainly with the DacMagic… It is suposed to play DSD512, and it does so from the PC, including the same files in the same NAS that it can´t play trough Volumio/Rasp…

Hi,
For my topping e30 dac is the same. I have understoood from @gkkpch that some files are missing from kernel. Maybe it will be fixed in buster beta version.

1 Like

well, RPi 4 is using kernel 4.19, the DacMagic 200M is supposed to have an XMOS based usb interface. 4.19 does not need additional device registration for XMOS, so direct (native) DSD “should” be enabled.
It would be good to see the output of “cat /proc/asound/card5/stream0” to verify that.

Can you please point me to instructions on how to see that output?
The 200M manual does have the following note, do the Volumio/Rasp solution complies with that requirement?

4. USB Audio In
For connecting to PC/MAC computers.
Note: Class 2 USB Audio only. Windows-based PCs require a Cambridge Audio USB driver to be installed before connection.

Well, not very helpfull, but basically correct from their point of view.
I’ll post the instructions asap (can take a few hours, otherwise tomorrow).

Start with reading this how to use ssh to log in to Volumio with uid volumio and pwd volumio
Then just enter:
cat /proc/asound/card5/stream0
This should give you the device capabilities, copy the output here or take one or more smartphone pictures covering the whole output and upload it (don’t worry too much about how it looks as long as all the info is there, I can see which parts may be overlapped)

Thank you for the instructions. I’ve got this:

The output mentions format “SPECIAL” without the DSD identifier.
Looks like the 200M has not been recognized as a native dsd device.
Could you also show the output of “lsusb -t”?
This will show the <vendor id>:<product id>, which can be compared with the audio driver “quirks”.

Sure, here you go:

oops, lsusb, without ‘t’ :face_with_hand_over_mouth:

No worries:

does not look like XMOS or Thesycon, it appears to be 22e8:dac2.
Need to check this.

Bad news unfortunately, the RPi 4.19.y kernel (Volumio 2) does not support DSD native, neither does kernel 5.10.y (Volumio 3 beta).

You can only play DSD over PCM until Cambridge gets this device supported in the linux kernel, nothing we can do to help I’m afraid.

Thank you for your effort, at least I know it’s not a problem on my devices.

Two questions:

  1. Is there any detail I can relay to Cambridge to point them on the right direction?
  2. Is there a ETA for Volumio 3?

Thanks again!

I’m sure Cambridge knows which way
they have to go, they need to add a “vendor-id quirk” to the case list in the USB Audio driver’s quirks.c source module and talk the kernel.org audio driver maintainer to implement it for the LTS and upstream versions.

As for ETAs, we don’t give any unless for super urgent fixes.