Asus tinker board

Asus had recently launched a new tinker board which is similar to Raspberry pi. Not sure if volumio is able to be use on it.

It should, looks like a nice sbc with a 1.8Ghz A17 from Rockchip, though I do not see i2s anywhere.
Need to follow this for a while and see if and when enough documentation and kernel info becomes available.
-Gé-

Wonder if there is any update on this. I had a tinker board now. Will be really nice if it work

Yes there is :smiley:
We have been very busy getting this to work last week and we are getting really close to a pre-release.
There is a stable beta version since yesterday, but we are still working with Asus on a few open issues with the audio jack.
USB Audio is working flawless, ethernet and onboard wifi also.
Just hold on for a few more days and we will publish a downloadable test version.

– Gé –

see official anouncement and here

That is GREAT news. :smiley:

I had tried to use the new image for my tinkerboard. It will boot up and within few secs it will completely shutdown. I had tried to reinstall the image but face same problem. Not sure what else I can try

Please use a proper 2A 5V Power supply, better if 3A. Let us know

Also, use the heatsink as we set the cpu governor to performance and the SoC gets too hot otherwise and will throttle.
Asus (or the community) will have to come up with a better solution for a lower and larger heatsink when we want to support DACs with a future Volumio version.

Sure thing. I will try to use the heat sink to see if that helps. But funny thing is I just turn on less than 30secs is already shutdown. Also did try with other power supply but still it wont finish the POST. If I didn’t put in any SD card, just turn it on will stay on with red light. So I am thinking could be the SD card. Will try some more to see

Also check this link http://tinkerboarding.co.uk/forum/thread-318.html and http://tinkerboarding.co.uk/forum/thread-300.html and http://tinkerboarding.co.uk/forum/thread-16.html

The volumio is working well with the tinker board. Had been using for 1 week now. The only thing I realized is everytime I restart it take more than 5 mins. Also when trying to change the setting and restart the MPD service also take about 5mins.

5 minutes is a bit (actually very) long. Can you give me more details on your setup?

I’ve just bought an Asus Tinker Board in the hopes of using it to replace my Squeezebox and possibly also taking over as the music server too. At the moment I’m planning to use volumio but I might also look at piCorePlayer (although it hasn’t been ported to this SBC yet).

I’ve burned the image to a microSD card, connected my wired Ethernet network, added a wireless keyboard and mouse, a powered USB and a small hard disk and connected the HDMI output to my TV via a Denon AVR. It boots and I can see music files on the hard disk. I can access the volumio web interface over the network. My music is listed in the library and I can play it. But I’m struggling to get any sound from the HDMI output. If I select the headphone output then it seems to take a while to sort itself out but eventually I do get sound. If I select the HDMI output then I don’t get any sound and I also notice that I lose the option for a hardware mixer (only software or none is offered) which I suspect is a sign that the HDMI output is not working properly. If I do “aplay -l” then I see several USB audio devices (no idea what they are) but apparently nothing that is obviously a HDMI audio device - what should I see? On a few occasions I have managed to get sound by plugging and unplugging the HDMI and turning things on and off in different orders but I haven’t managed to identify a pattern. Also, if I run “aplay -l” when the sound is working then it seems to hang.

I’ve seen posts suggesting that I should add hdmi_force_hotplug=1 to the config.txt file but that doesn’t seem to exist on the Asus Tinker Board build so I’m not sure what the equivalent is.

Also, I tried the Android image provided by ASUS and I was able to play an audio file through the HDMI output. I think there is also a Debian build but I haven’t tried that yet.

I’m a software engineer but I haven’t used Linux in about 15 years. Any suggestions what to try next?

Incidentally, are there any pros/cons to volumio versus piCorePlayer?

tinkerboard -> Wadia 322 (USB) -> Audio Research LS25 -> Audio Research REF110.

I had downloaded the current release for tinkerboard and I can say it is working well. No issue with reboot. No issue with connection to network from first start up. Also discovery of the files in NAS is quite fast. 220GB of files done in 30mins. Most important restarting of the tinkerboard no longer is an issue. Selecting different output also work properly now. Looks like is all stable and good now

1 Like

Thanks for your feedback!

We do not claim PI or Tinker OS compatibility, we have out own debian jessie OS and we are happy to support a first, headless version. There is
more work to do, but there are no further plans at the moment.

Does ATB sounds better than RPi3 when connecting to an USB DAC? Thx.

Hi,
I have just tried a tinker board with the last Volumio and I have 2 issues:

  1. my USB external Steinberg UR22 MKII is not recognized
  2. I connected with the jack output and I find that the ouput is quite low, but anyway if I set a volume bigger than 40 the sound has distortion.
    So for the moment I’m using the jack output with the vol at 40 and I pass the signal from the UR22 to increase power before to go to the ampli.

Some possibility to use the usb output and external audio card ?

Thanks