Youtube Plugin (Failed to Decode Video)

I have been trying to use the youtube plugin on volumio but it has not been working cause this error. Please help if you know anything. Thanks
volumio error.PNG

I have the same probs :frowning:

I Have the same problem. And it’s the same thing for Spotify.

For me it’s only YouTube, not Spotify, and only some videos

But it seems the source of this problem is this:

A solution (requires modifying the YT plugin) is here: … -502083412

Same here. Same problem, on YouTube only


that worked for me:

-> SSH enable

Start Putty
Enter IP Adress - console opens, enter login data of volumio (default: volumio/volumio)

  1. step:
    cd data/plugins/music_service/youtube

  2. step
    npm i fent/node-ytdl-core

  3. step
    nano package.json

  4. step, change following line:
    “ytdl-core”: “github:fent/node-ytl-core”
    “ytdl-core”: “^0.29.2”
    Strg+X -> Exit, Save

  5. step
    npm install

Reboot Volumio

worked fine for me

Ok. But this is a nerd Fix. Please update a plugin for a neebie

Inviato dal mio SM-A600FN utilizzando Tapatalk

Still cant’ figure out this problem, followed the putty way, but when i encode command cd… the reply is no such directory exist.

any easy way to fix this?

Yes, same problem for me. Can anyone please help those of us that are simply using the app plugin feature? I’m just a simpleton here…no knowledge of Linux language or how to putty.

Yes !
cd /data/plugins/music_service/youtube
cd data/plugins/music_service/youtube

Thanks for solution, it worked!

For me this solution doesn’t work.

volumio@volumio:~$ cd /data/plugins/music_service/youtube volumio@volumio:/data/plugins/music_service/youtube$ npm i fent/node-ytdl-core [..................] / rollbackFailedOptional: verb npm-session b690052981c59ed volumio@volumio:/data/plugins/music_service/youtube$ nano package.json volumio@volumio:/data/plugins/music_service/youtube$ npm install npm ERR! code ETARGET npm ERR! notarget No matching version found for ytdl-core@^0.2.9 npm ERR! notarget In most cases you or one of your dependencies are requesting npm ERR! notarget a package version that doesn't exist. npm ERR! notarget npm ERR! notarget It was specified as a dependency of 'youtube' npm ERR! notarget

Why is getting the plugins to work so hard in the last time?

thanks @Ubiquinon, worked fine for me.

check the 4th step written by Ubiquinon.
it should be
“ytdl-core”: “^0.29.2”
you tried ^0.2.9

thanks @Ubiquinon, worked fine for me, too!

for the others, it should be enough these commands:
cd /data/plugins/music_service/youtube/
npm i ytdl-core
sudo reboot

the only issue I stil have is that youtube songs are cutting 10-15 seconds before the end.
Anyone found a solution?

thanks all!

I do not know why but my browser crashed any time when I use a youtube plugin. It could be due to poor optimization. I have a choice of the website which provides youtube to mp3 converter .The convenient and easy interface with many available formats and never with load your internet speed. Advice to everyone who also has some issues with a browser to use better the site and does not install a plugin.