You lost me Volumio, I'm cancelling ( terrible Tidal)

I resolved the loopback erro. It was a DAC set up issue in the Volumio playback folder.

1 Like

Holy Crap…the newly installed version 2.806 is performing very well for me on Tidal. Am i dreaming?

2 Likes

Maybe I’ve been very lucky but I’ve never had problems using Tidal with Volumio, currently the only operating system for Raspberry Pi that I can use for direct stream from Tidal. If I may help someway please drop me a line.

Tidal is working ok for me.
I’m on 2.799
“Check Updates” says I’m already on latest version.
How do I get version 2.806?

Tidal always was working OK for me.
I use Volumio on raspberry3 + Allo DigiOne Signature + MoJo, also on Celeron or Atom PC’s + MoJo or DragonFly black.
No plugins or Quobuz or Spotify, only Tidal.
Every few months I have to disconnect and connect again to Tidal, but it is acceptable.
Also, I get more results when searching in Tidal running on a Windows PC than when I do the same search under Volumio.

are you on the virtuoso plan?

Affirmative. Installed on laptop.

The x86 version is still 2.799. you have to enable dev mode if you want to test last version. But keep in mind, that it may not work…

1 Like

What problems do you have ? I have three pi’s with three different DAC’s and
all work perfectly. I also use a Samsung Galaxy S8 in my car playing via Bluetooth and it nevers fails me. Same for Qobuz and Radio Paradise. Tidal always works. I use my own playlists as most of what’s on their homepage I would never consider a listen. Have you upgraded Volumio to the newest version ?

Hey,

I’ve been frequently receiving errors Asset is not ready for playback when listening to music from Tidal (described here in this topic).

Is this something the new implementation should fix?

Guys, I am beginning to think most of my problems may have been related to poor internet speed for me. Just changed to a faster provider and Tidal is working without any issues. I used to get a lot of errors, just like the ‘asset is not ready for playback’ and now I do not really get any. I am also using version 2.806, perhaps that also helped, but not sure.

For me there are two major problems with the Tidal implementation.

  1. Queuing playlists for playback is excruciatingly slow. If I try to play a playlist with 100 songs it takes over two minutes before anything happens, on a Pi 4. This actually makes it seem like it is completely broken but if you are extremely patient it will eventually start playing.

No problems like this with Qobuz integration - even very large playlists queue and start immediately.

  1. Cannot play or even see EP albums of artists. This means most artists have “missing” albums in Volumio, and you might not even realise this until comparing the available albums in Volumio against those in the Tidal app. I didn’t realise this was happening until I noticed a couple of my artists had zero albums showing in Volumio - Tidal classifies all their albums as EP’s and therefore they don’t appear.

So a significant portion of my Tidal albums simply cannot be seen or played in Volumio. No problems like this with the Qobuz integration.

Both these problems were reported by me nearly a year ago on the forum and still remain. In response to the slow playback queuing there was a vague “we’re working on improving it”, but a year later it is just as bad and unusable. The thread about the EP album issue still doesn’t even have a reply to acknowledge the problem exists.

If these problems were in a free feature, fair enough, if you get something for free and it doesn’t work quite right it is what it is, but when you’re paying monthly for a feature that still doesn’t work properly a year later it’s a bit frustrating to say the least.

I’m an open source developer myself who never seems to get as much time as I’d like to work on projects so I have some sympathy but at some point I start to get impatient and frustrated and I’ve certainly considered cancelling MyVolumio until the issues are worked out.

HI,

I’m Massimiliano, one of the Volumio developers. I’m in charge of working on this issue.
Regarding issue #1 is the playlist one that you created or one created by Tidal? If the latter, would you mind giving me the name so that I can test locally?

Regarding issue #2 could you please give me a few artists names?
Thank you.

Hi,

Thanks for the reply.

I see the same slowness issue with all large playlists on Tidal. I don’t actually use the playlists curated by Tidal - just my own which I have added songs to gradually over time, and some of them were originally migrated from Spotify. (To be clear I’m referring to playlists stored in the Tidal account, not those local to Volumio)

Once they have more than (approx) 40 tracks it starts to slow down a lot. So it’s purely the number of tracks in the playlist which affects the speed, so you should be able to reproduce it simply by creating a large playlist of say 100 tracks in the native Tidal apps then attempting to play it in Volumio.

I just rechecked the timings of several playlists and got the following results:

14 track playlist - 3 seconds
30 track playlist - 5 seconds
35 track playlist - 12 seconds
52 track playlist - 35 seconds
103 track playlist 1 minute 8 seconds
277 track playlist - 2 minutes 10 seconds
354 track playlist - 2 minutes 11 seconds

These timings are on a Pi 4. For Qobuz a very similar 354 track playlist takes about 5 seconds, and smaller ones are even quicker.

The strange thing is that I can browse the playlist quickly - if I go to Browse->Tidal->My Music->Playlists then click on the playlist cover art (not the play button which would queue it for playback) the entire list of tracks appears immediately. However when I queue it for playback (to be added to the playback queue) this is when the long delay occurs before anything happens.

The playback queue remains empty and suddenly appears after the long delay. If you try to play something else during the delay, such as a single track it will play immediately, however after the delay the original playlist will finish queuing and suddenly take over playback.

The best example I have is ‘Ooyy’ - if you search for this artist in the Tidal integration in Volumio you’ll only find one album - at the time I first reported this problem last year it would give no matches, however this album has been released since then.

All other Albums from this artist are classified as “EP & Singles” in the Tidal native apps, and therefore don’t appear in Volumio.

If you check in the Tidal App for this artist you’ll see one Album under “Albums” (the one Volumio can see) and 17 other albums in the “EP & Singles” category which Volumio can’t see.

I’ve confirmed this is not a problem specific to any one artist - “EP & Singles” albums are not showing up for all artists I have checked.

Hope this helps.

Hi,
I’ve been able to perform some testing on the issues you reported. For issue #1 the current implementation in Volumio connects to TIDAL for each song in your playlist. That’s why the time needed to complete the task depends on the number of tracks. This behavior is not present the new implementation so the issue will be fixed soon.
Regarding issue #2 the TIDAL APIs are returning exactly what you see in the web page. I think there’s a new API in TIDAL but unfortunately it’s not reported in the official documentation. We will contact TIDAL for additional information and solve the issue asap.
Thank you for providing such a detailed description of the issue.
We’ll keep you posted.

Hi,

Thanks for the update. Fingers crossed that both of these problems can be fixed.

If someday Tidal integration is worth it , I might re consider

Hi,

I’ve just updated to V2.834 and enabled Beta support for Tidal and Qobuz (via SSH) and wanted to report what I’ve found regarding Tidal.

  1. The very long delay when loading large playlists seems to be fixed. The same playlist which was taking over 2 minutes now loads and starts playing in about 2 seconds - it’s now faster than Qobuz which takes about 5 seconds.

  2. Unfortunately the problem with not listing EP & Singles albums on Tidal remains. So a lot of the albums on Tidal are still not accessible.

I’ve just paid for a MyVolumio subscription just for Tidal support. I’m using the latest Volumio on a Raspberry Pi 4 with a Cambridge Audio DAC Magic 100 connected over USB 2.0. Everything is working as expected in all local and streaming modes except Tidal. I have no sound at all. Tried with standard def, 96KHz/24, 192KHz/24. The playback just does not start. What I am doing wrong?

Great to hear this is solving your issue!
Re EP and Singles we’re working on that :wink: