X900 Hifi Dac Es9023

Goodmorning everyone.
My Volumio configuration is RASPBERRY PI 4 Model B 4GB and X900 Hifi Dac Es9023 (maybe the DAC is not the best).
the system works, connected to the wl network, i can see the memory device connected to the usb ports (3.0), a 1 tb 2.5 inch ssd. I’ve been using it for about a week, mostly playing my iPhone or PC music through their respective music players.

Trouble A:
If I listen to music from the SSD, sometimes the volume loses audio and the RB gets stunned. This can take several seconds (10/15 seconds), then the audio returns. this repeats itself over time.

1 / has this already happened to some of you? If so, have you fixed it somehow?
2 / could it be due to an OS update? If so, can I hope for an update?

Trouble B:
A friend of mine tells me that my DAC is not configured correctly. I have the X900 Hifi Dac Es9023 dac which is currently set as "ST400 DAC (PCM5122) - AMP"

1 / is it correctly set? what possibility do I have to set it correctly?
2 / could it depend on the dac?


ps.: my english is translated automatically by google translator. sorry.

For trouble B, your friend is right. Sta400 is based on Pcm5122 from TI. Your Dac is From ESS. Using hifiberry sould be fine. This Dac 9023 does not provides HW mixer.

1 Like

thanks balbuze. i tried to change the sound card but with hifiberry there is no sound on my amplifier. configured on ST400 and the audio is back. I hope someone can help me in other problems too.


I need to correct my message, at least regarding the DAC board details.
Yesterday I took my Volumio apart and took a good look at the DAC. my DAC board is X920 SupTronics (http://www.suptronics.com/miniPCkits/x920.html), you can read its specifications in wiki pages -> http://raspberrypiwiki.com/X920. the correct setting for this card is ST400 DAC (PCM5122) - AMP.

Balbuze, sorry for my wrong.

For problem A, I am now using a 750GB 2.5 inch hdd. Things are better. I listened to the music on headphones (via 3.5 jack) and the sound didn’t stop.

maybe Raspberry has the limit on 1TB SSD?

I sent the 1TB SSD (Crucial --> https://tinyurl.com/yy5uejh2) back to Amazon in the meantime.


could it depend on this?