WiFi woes! Help please

Volumio Information 2.777

Volumio Version: 2.777
Hardware: Pi4
DAC: Allo Boss 1.2


I’ve being trying to set this up for a day now and it’s driving me nuts.

I get the hotspot running and enter my password for the ssid, then if I disable hotspot, nada I can’t access the Pi and it dissapears from my router. I have another Pi on my network which controls my fish tank, that was set up entirely via Putty and no problems for over a year.

Any tips?

Can I set it up using Putty (Headless)?

After entering your ssid, password, and rebooting (don’t disable hotspot), does your device connect to your home network?

No it doesn’t, I had a similar thing with Moode.

I’ve got Moode working by adding moodecfg.txt before first boot, it worked instantly. I’m sure Volumio generates a similar cfg.txt document.

What I’ve found is that Volumio isn’t saving the password either on Android or Windows 10.

The contents in moodecfg.txt are as follows;

browsertitle=moOde Player
airplayname=Moode Airplay
spotifyname=Moode Spotify
bluetoothname=Moode Bluetooth
upnpname=Moode UPNP
dlnaname=Moode DLNA
mpdzeroconf=Moode MPD




I just changed SSID, PW, Country and Timezone to my network/location.

Does Volumio have a similar config? If so it could help others with the same problem.

No, there is not a similar config file for Volumio. Let’s try and rule out hotspot problems. Can you plug your device into your router (wired connection), and see if it get assigned an IP address ok? You should be able to see on your router what address it has been given. If so, set up the wireless network from settings, save, and reboot.

Wired works, but as soon as it’s removed it reverts to the hotspot, it seems to be an issue with the pi 4 firmware, the reason I suspect this is because when I added the boss dac to moode and restarted it also reverted to hotspot.

I found an old WiFi dongle I hooked it up to the pi and it worked on volumio not moode, right now I’m using the dongle and volumio.

Maybe a full set up via console with WiFi configuration would be a solution, right now I’ve spent quite a fair a amount of frustrating time on this.

Do you ever see it connected to your LAN wirelessly? For example if I add a wifi dongle to a wired Pi (not RPi4), I can set ssid/password, networking resets itself (without rebooting), and the device shows both a wired and a wireless connection being present. If not, then I suggest that you file a bug report (it could be a Pi4 thing.

You could also try setting up your wireless manually, if you’re confident with what you are doing.

  1. Access the dev interface by changing your browser URL to ipaddress/dev

  2. Enable ssh by pressing the appropropriate button.

  3. ssh into your RPi4 with a wired connection

  4. Edit the wireless config file in ‘/etc/wpa_supplicant/wpa_supplicant.conf’ using ‘sudo nano’

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

*country codes can be found at https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2#Officially_assigned_code_elements

Thank you for the tips there, I’ll take a look again in a few days, for now I’ll let the DAC burn in then take another look, hopefully will get a resolution.

Ah, so you do have it working with a wifi dongle (sorry, it didn’t register in your earlier reply). Forget the manual setup then, it seems likely to be a problem with the onbard wifi on a RPi4, and you should submit a bug report.