where is airplay?

hi there …
i just installed the volumio 2. release
all is fine but i cannot find out how to activate airplay …
what am i missing?

is there a plugin?
or can i somehow activate it via ssh …
i really loved that in volumio 1.5 - seems odd that it is missing in the new release…

i tried to compile shairport - but i can’t seem to get it to run -
it says it is listening - but it does not appear on my apple devices
hmmm…

i just can’t get airplay to work & now it is also forgetting my scanned nas…
this is such a downer …

this will be my last attempt at volumio 2.0 - i have been trying again and again because
i believed the hype - but i can’t get it to do the stuff i need - and rune simply delivers…
good bye & enjoy fiddling with your fancy plugins - when the most basic things still don’t work in a release
:imp: :imp: :imp: :imp: :imp:

AirPlay is active by default.

youtube.com/watch?v=tzkG6Xu6lUE

(you’ve probably messed up with your previous attempts, and without detailed info it’s difficult to understand what went wrong)

Bye, we won’t miss you!

I second the OP.

Airplay doesn’t actually seem to be active by default in v.2.001

Identical setup, same hardware running Moode - & airplay works from my phone. However on Volumio airplay seems to not be running - I can’t select volumio under ‘more devices’ via Spotify… said differently, it doesn’t show up in the list of airplay devices.

Does airplay server bind to all interfaces? I am using Ethernet - I have a wifi dongle attached but haven’t connected it to the wifi network. However the wired Ethernet is on the same LAN as the wifi my phone connects to.

Have flashed about 3 times, no success. Devices is an RPI Zero / plainDAC. Web radio works, and I can browse the SMB share. Just no airplay.

Any tips?

Airplay is enabled by default. Probably there is something on the pi0 that prevents it from starting

could you please do

sudo journalctl -f

and find the relevant error when volumio start? and paste here?

Bless you @michelangelo and others

Just wonder what’s happening with mankind ?

Thanks for your interest Michangelo, I appreciate it. I have spent a few hours trying and failing, and that time isn’t coming back, so finding a way forward is of value to me. I did some detective work to make your life easier.

– Logs begin at Tue 2016-10-25 08:08:24 UTC. –
Oct 29 05:27:03 volumio systemd[24854]: Reached target Basic System.
Oct 29 05:27:03 volumio systemd[24854]: Starting Default.
Oct 29 05:27:03 volumio systemd[24854]: Reached target Default.
Oct 29 05:27:03 volumio systemd[24854]: Startup finished in 68ms.
Oct 29 05:27:03 volumio systemd[1]: Started User Manager for UID 1000.
Oct 29 05:27:03 volumio sshd[24849]: pam_env(sshd:session): Unable to open env file: /etc/default/locale: No such file or directory
Oct 29 05:27:03 volumio sshd[24849]: lastlog_openseek: Couldn’t stat /var/log/lastlog: No such file or directory
Oct 29 05:27:03 volumio sshd[24849]: lastlog_openseek: Couldn’t stat /var/log/lastlog: No such file or directory

and

volumio@volumio:/etc$ cat shairport-sync.conf
general =
{
name = “Volumio”;
log_verbosity = 0;
};

alsa =
{
output_device = “plughw:1,0”;
};

sessioncontrol =
{
run_this_before_play_begins = “/usr/bin/mpc stop”;

volumio@volumio:/$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

I used a few commands to try to find and configure shairport. However there are no shairport files in any of the locations mentioned eg. Here: drewlustro.com/hi-fi-audio-via-a … pberry-pi/

so I improvised

volumio@volumio:/lib/systemd/system$ cat airplay.service
[Unit]
Description=ShairportSync AirTunes receiver
After=sound.target
Requires=avahi-daemon.service
After=avahi-daemon.service

[Service]
ExecStart=/usr/local/bin/shairport-sync
User=volumio
Group=volumio

[Install]
WantedBy=multi-user.targetvolumio@volumio:/lib/systemd/system$

and…

volumio@volumio:/usr/local/bin$ shairport-sync
startup
could not bind any listen sockets!

so I found what we are running.
github.com/mikebrady/shairport-sync

and… I found some options

github.com/mikebrady/shairport- … /README.md

I bashed away…

volumio@volumio:/usr/local/bin$ shairport-sync -v
Looking for the configuration file “/etc/shairport-sync.conf”.
startup
Failed to bind to address 0.0.0.0.
Failed to bind to address ::.
could not bind any listen sockets!

volumio@volumio:/usr/local/bin$ shairport-sync -V
2.4-openssl-Avahi-ALSA-soxr-metadata

I found other ways to bash away…

htmlpreview.github.io/?https://g … -sync.html

I checked the lan…

volumio@volumio:/usr/local/bin$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:e0:4c:53:44:58
inet addr:192.168.7.47 Bcast:192.168.7.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:367515 errors:74 dropped:760 overruns:37 frame:118
TX packets:69367 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:131906456 (125.7 MiB) TX bytes:12076778 (11.5 MiB)

and…

volumio@volumio:/usr/local/bin$ shairport-sync -vvv
Looking for the configuration file “/etc/shairport-sync.conf”.
Looking for configuration file at full path “/etc/shairport-sync.conf”
startup
statistics_requester status is 0.
daemon status is 0.
rtsp listening port is 5000.
udp base port is 6001.
udp port range is 100.
Shairport Sync player name is “Volumio”.
Audio Output name is “(null)”.
on-start action is “/usr/bin/mpc stop”.
on-stop action is “(null)”.
wait-cmd status is 0.
mdns backend “(null)”.
userSuppliedLatency is 0.
AirPlayLatency is 88200.
iTunesLatency is 99400.
forkedDaapdLatency is 99400.
stuffing option is “0”.
resync time is 2205.
allow a session to be interrupted: 0.
busy timeout time is 120.
tolerance is 88 frames.
password is “(null)”.
ignore_volume_control is 0.
audio backend desired buffer length is 6615.
audio backend latency offset is 0.
configuration file name “/etc/shairport-sync.conf” resolves to “/etc/shairport-sync.conf”.
metdata enabled is 0.
metadata pipename is “(null)”.
get-coverart is 0.
Failed to bind to address 0.0.0.0.
Failed to bind to address ::.
could not bind any listen sockets!
volumio@volumio:/usr/local/bin$

In conclusion, the website states that volumio has airplay and raspberry pi support. In practice it doesn’t work with my configuration - a raspberry pi zero. A newcomer would give up and simply not try volumio again. I can understand why the original poster was upset.

I figured I should google the issue…

github.com/mikebrady/shairport-sync/issues/276

extracts:

marcushartwig commented on May 11
I don’t know if this helps, but I had this issue when my Pi was using only the wifi0 connection. It seemed like shairport-sync was trying to bind to eth0 by default. The solution was to bring eth0 down. After that shairport started normally.

retrostrobe commented on May 21
@marcushartwig’s comment about bringing eth0 down worked for me. Editing the interfaces file didn’t do the trick, so I edited /etc/rc.local and added: (sleep 30;sudo ifconfig eth0 down)& just before exit 0.

stevensflight commented on May 21
@retrostrobe - that worked for me too. I can stream from my phone, switch to my iPad, and back and it is still working! Thanks!

Owner
mikebrady commented on May 21
Thanks for this. I’ve been trying to fix it so that this workaround isn’t necessary, but it’s good that it works!

Owner
mikebrady commented on May 30
I believe this is fixed by 2.8.4. Feel free to reopen if not. Thanks.

I am happy to research further but don’t code, so can’t really do much - unless something here stands out as a red flag worthy of investigation?

If I am not mistaken, Volumio is running an older version of shairport-sync ?

At the time of building it it was the latest. If there is a newer one, let me know and I’ll update it

Awesome,

well, with regards to the version of shairport-sync

volumio@volumio:/usr/local/bin$ shairport-sync -V
2.4-openssl-Avahi-ALSA-soxr-metadata

Yet the latest is v 2.8.6

It could be that shairport-sync -V is mis-reporting the version or reporting the version of a dependency, is there an easy way for me to see the version used? A command I can type?

Had the same issue, Volumio 2.041 on a Pi zero with an I2S dac (chinese hifiberry compatible dac), shairport-sync refusing to bind. Upgraded to latest shairport-sync in the volumio Github (currently 2.8.5) manually et Voila!

Fully working.

Now, on to solving my Wifi issues (lots and lots of resend requests, stuttering and Volumio disappearing from the network)…

Interesting, we’ll update to latest shairport as well!

I didn’t have exactly the same issue as described above though, not using wifi but an ethernet to usb converter that shows up as eth0, so disabling that really wasn’t an option.

Long time reader, fist time contributor…Thanks for the amazing work!

This said, I too have had some issues with airplay since RC2 (0.978).

I confirm that i couldnt stream with airplay from my Nas which is a Synology DS215J. Streaming through dlna has always been working. The issue still persist on Version 2.3 of Volumio, which is the latest version I run on any of my machines. The sound was doing a short bleep of music, than silence for a few sec, then a bleep than silence again.

The fix that worked for me is to update shairport sync per instruction given at https://github.com/mikebrady/shairport-sync
The bug only occured with my synology nas as a source, as airplay was working with my iphone or from itunes on the pc.

If this can help someone:

  • volumio is a SystemD type of installation
    -If you run into an error while following instruction, most of the time adding a “sudo” in front of the command will get rid of the problem. Don’t crap at me if you use “sudo” in a wrong manner.

Good luck

My setup:
Pi2+hifiberry amp+
Pi3+ hifiberry dac+light
pi-zero+phat Dac

Nice work Michelangelo!
I have done a fresh install and airplay was not visible when accessing volumio from my mac.
Looks like the shairport service is not starting automatically so I ssh’d into the rpi and turned on shairport service by typing:-

shairport-sync start

To ensure the service starts automatically at boot:-

sudo systemctl enable shairport-sync

Done!

Just faced the same issue with AirPlay and Synology.
I see that shairport-sync is at version 3 already while on my system I have

$ shairport-sync -V 2.4-openssl-Avahi-ALSA-soxr-metadata

I’m wondering if we can expect the updated version integrated into Volumio.