WebUI doesn't respond anymore


I have reboot my Volumio and the webUI doesn’t get back alive… I have try the following:

  1. WebUI working fine
  2. rebooting (power remove)
  3. Ping my RPi and it works
  4. Enter the IP address in my browser. This give me the and I works! response…
  5. Try volumio.local in my browser… no response
  6. Try to connect ssh with putty… U: root P: volumio, unable to connect… bad password. This is bizarre the password seem to be volumio?

Thanks for your help

I installed the version 1.1 and now it boot and I can access the WebUI again.

However, I’m still not able to log in a SSH session.

With version 1.1 it stopped working again. Same problems than previously.

I can ping the IP of my Raspberry, but a ping on volumio.local does respond.

Also, in the browser, if I write the IP address I get the message []It Works![] but not the WebUI.

I certainly tryed to reboot multiple time. I had the same problems with version 1.

Does anyone has a suggestions? (I’m missing new ideas…)


I’m having the same problems right now. I hope it will be fixed, in the next update.

Try to SSH in and use this command

sudo /etc/init.d/mpd restart

It worked for me, but it keeps happening.

Best regards,

I have some issues with the WEBUI as well (Beta1.1 on raspberry).

  1. When configuring the NAS quite often it hangs with the message Connecting (and the two rotating arrows).
    Some times the following helps, not always
sudo service mpd restart
  1. I cannot power off/reboot from the WEBUI.
    The only solution is connecting via ssh and poweroff, however I cannot propose this to my wife and my kids :unamused:
    The rest is quite good, I really like the graphic.
    Thanks very much for the effort, donation as soon as I can install something usable by the whole family :wink:


Thank you for your feedbacks, if we can get this solved is also thanks to this!!!

I think this could be a bad SD cards, SSH relies on hard drive informations sometimes, and your SD may be at the end of the life… I cannot have other explanations to this behaviour…

If you cannot get into the WebUi with volumio.local, you need to install bonjour,

Then, as for the not able to connect. It is suggested to pause before rebooting or turning device off…

If you turn off just with shutdown now, somehow mpd doesn’t like that… If you see, the Webui as shutdown gives the following

mpc stop && shutdown now 

So, or you manually pause or you give the above command to shutdown/restart

Hope that helps

Thanks for prompt the answer!

The card should be ok (SanDisk Ultra 30MB/s SD HC I) and it is fearly new.

No problem with the first access to the webui. The problem is that sometimes it hangs! Same issue with different browsers and different platforms: thus it is likely a problem with the raspberry. Up to now the problem apperas when confuguring the NAS.

Same for me… the SD card is a new and the I’m using the NAS. First configuration are ok (after re-writing the SD Card), but once the NAS is configure, then the WebUI hang and stop responding.

I believe I am experiencing the same issue.

Yep, same problem. Initial install works, attaching NAS works too but after a day or so webserver stops responding. I can still SSH into the Pi, but web is down. After I re-image SD card it works again for a day or two and then web goes down again. Last time it stopped playing in mid-song. SSH still worked, but not WebUI. Seems that nothing is listening on port 80.


Same issue here, on a RPi with the 1.1beta. I can make the web server stop responding following this steps:

  • Boot Volumio
  • Go to web ui (ip-address)
  • Go to Menu/Playback
  • Don’t change anything, just click “Save changes”
  • A pop-up appears with the “Restarting mpd…” notification
  • The CPU is now at 100% for some time, with three php-fpm processes working
  • Click the Volumio logo: the server doesn’t respond and after 10 or 20 seconds the browser shows a blank page

If you try to reload the blank page or go to volumio.local/index.php there’s no response and the process “php-fpm: pool display” takes all the cpu for 20 or 30 seconds.

Restart mpd and everything works again:

sudo service mpd restart

Hope this helps to solve the bug.

Same issue here. But a little more strange…

No access to web UI, then connect to SSH, enter sudo service mpd stop (yes, stop), bam ! web UI is here (it’s immediate looking at the two windows). Then start mpd again, then no UI (and no mpd either, can’t connect thru MPDoid too)

And sudo service mpd restart doesn’t help…

I’ve found that after clicking “Save changes” mpd disappears. The webui is stopping mpd instead of restarting it. With mpd in verbose mode the last lines after saving changes are:

Jan 17 17:27 : client: [9] opened from Jan 17 17:27 : state_file: Saving state file /var/lib/mpd/state Jan 17 17:27 : client: [9] closed Jan 17 17:27 : client: [8] closed Jan 17 17:27 : client: [4] closed Jan 17 17:27 : listen: listen_global_finish called Jan 17 17:27 : db_finish took 0.180000 seconds

probably there’s no need to jump on the bandwagon but here I am with my +1
same issue here: ssh can connect but webui can’t
as mentioned previously, /etc/init.d/mpd restart makes the webui come back

it looks mpd is the weak link on volumio