Web app does not respond, though in wifi

Dear all,

I am stuck on the loading screen of the volumio web application with any PC in my local wifi. But I am able to ping the raspberry pi, see it being connected in the router settings, and am able to ping out and ping some websites.

This is what I did:
Yesterday I tried to configure my raspberry PI 2 B+ with volumio. I downloaded the image volumio-2.201-2017-06-13-pi.img and flashed to SD card with Win32DiskImager. Then I put the SD card to the pi, connected HDMI, a wireless keyboard and a wifi dongle.

I do need to configure for wifi, as there is no ethernet available, so I performed the following steps:

  1. login with User “volumio” and pw “volumio”
  2. setup automatic wifi login on star-up
  • I set my router to WPA2-PSK security only
  • checked installation of wpasupplicant with
$sudo apt-get install wpasupplicant
  • opened wpa_supplicant.conf file with
$sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

and wrote

  • opened interfaces file
$sudo nano /etc/network/interfaces

and wrote:

out-commenting all other lines, which were already in the file, later I also tried commenting in the first lines again, which did not help either:

  • then rebooted with

I checked with $sudo ifconfig and ping www.google.com as well as ping for valid connection and was (and still am) also able to ping from a PC in my wifi to the raspberry pi.

  1. setup automatic login with volumio
  • went to root mode, added directory and opened autologin file with
$sudo -i
$mkdir -pv /etc/systemd/system/getty@tty1.service.d
$nano /etc/systemd/system/getty@tty1.service.d/autologin.conf
  • wrote into file
  • enabled service with
$sudo systemctl enable getty@tty1.service
  • and rebooted again

The end result is and was, that the user volumio is logged in and wifi connection is established. I checked this from outside with ping and see a valid connection in the router settings as well. My problem is: If I open up a browser on any other PC in the network - be it a wifi connected or cable connected PC - and try to go to volumio.local or, I get stuck on the loading screen. I see the faded dark volumio interface and the circle loading sign, but I cannot proceed to the player. I am also not able to connect with my spotify android application.

Additionally I had a very funny inital problem. When I finished the above process the first time, I was not able to connect with any PC, but 1. This one PC was in sleep mode all time. I brought it up and there was an established connection the volumio page in the browser already loaded. I found out that this PC was able to ping the web, but not any other PC in my wifi. I was able to set the spotify account and update volumio. After switching volumio off and on again, this PC was not able to connect to volumio like all others.

I googled that the web interface is not loading and found posts claiming to restart mpd, so I tried without success:

$sudo /etc/init.d/mpd restart

I also tried to stop and start. and deleting the state folder

cd /var/lib/mpd
ls /var/lib/mpd
rm -i state

But nothing helped up to now.

Do any of you have an idea how to solve this?

turn off the ads blocker :slight_smile:

Thank you for your suggestion, but this does not work either. I tried with Firefox, where I have ad-blocker and NoScript and also with Chrome and even internet explorer. But no success.

I also tried changing the /etc/network/interfaces file to:

replacing the stars with the plane ssid and psk, but without quotes. The login on

$sudo ifdown wlan0
$sudo ifup wlan0

seemed very promissing and I am again able to ping in and out, but do not get the web interface to respond, just see the perfmanent circle of circles, even if I reload the page.

… same on my android phone browser chrome.

First thing, if you WiFi dongle is supported by volumio, you don’t have to change files via ssh! Just write volumio image, boot wait at least 7min and you should see a hotspot “volumio” on which you can connect to to configure volumio ( network, music lib, etc). Please read the doc!

Thanks for the advice. I just found the documentation when I came to this forum. I am using volumio already several months ago, which worked fine first, and then the connectivy got worse and worse. That time I think there was no doc and I came up with the approach of googeling for setting up information with wifi dongles.

So would you now recommend me to flash a fresh volumio image to the sd card?

By the way, I put the dongle to a different USB port and now I can access the web interface. I am able to play some radio stations, and I am also able to see my spotify playlists, but I am not able to play one of them or connect with my spotify app or desktop app to the volumio. May it take some minutes / hours for the first sync to my spotify account?

If you have altered some files “by hand” you may have some issue with OTA update.
For Spotify, the plugin allows you to use Spotify directly from Volumio. If you want to connect with the official Spotify app, you need to install a other plugin called volspotconnect or volspotconnect2 ( have a look at the plugin collection on the forum)

edit : link to go volumio-plugins-collection-t6251.html

As restarting again just brought up the originial problem, I simply reflashed the image to the SD and went the way through the documention. Works very well now.

But: I am not able to connect from the spotify app to the Volumio. Thank you for your suggestion of the volumioconnect plugin. As I am using the newest volumio version, I downloaded volumioconnect2 plugin and installed it. But on my phone it just says: connecting… and then stops connection. I am still not able to play from the phone. I even tried a restart of volumio, but this did not work as well.

I used the simple volspotconnect, not the volspotconnect, now it works. Though I first had installed both and it showed me both as “volumino spotify connect 2” and I was not able to set each of the inactive independently. I had to uninstall both again and reinstalled the later (volspotconnect, without the 2) again. Now it works like a charm

:laughing: <- This is me being so happy, that I have volumio working again, and much better than in the old days with the connection problems on startup

:unamused: <- this is me being sorry for not searching for documentation in the first place.

Thank you very much for all your help.

what is the output selected for volumio ? do you use a dac ? Before using the plugin, you must have a working config. Once it is done, disable and re-enable the plugin in order to reconfgure it.
Note : Tonight I have some problem to connect to Spotify with the plugin… I hope Spotify didn’t change something in their protocol or something else that would prevent the plugin to connect… Even if now it works for me…

Please see the edit of my last post, it works now. I use an HDMI cable to my blueray player.

:bulb: only draw back: I have my tv connected to my blueray player, which brings up the screen of the volumio login as well. Would be cool to have a nice volumio screen (at least the startup screen with the logo, instead of the command line).