Volumio2 x86 using spdif out ?

I have Volumio2 x86 running on a low spec Dell Inspiron 93000 laptop.
Everything works wonderfully with one exception that I,m sure is simply a configuration file that needs modifying…but how to go about it…??

problem… the laptop has a spdif coax out. I have wired this and it works fine and is a selectable option in Ubuntu and Xubuntu so the hardware is good.
Unfortunately, when I try to select an output device from the Volumio2 x86 menu it does not show any spdif options (well no options other than the IHA6 it uses for onboard audio)

What is the name and password to ssh into Volumio2 x86 ? and what file would I need to modify to get spdif output ?

Thanks for any and all help …

uid volumio
pwd volumio

Could do aplay -l and aplay -L and post the result?

uid volumio
pwd volumio

Could you do aplay -l and aplay -L and post the result?

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH6 [Intel ICH6], device 4: Intel ICH - IEC958 [Intel ICH6 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0

aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=ICH6
Intel ICH6, Intel ICH6
Default Audio Device
sysdefault:CARD=ICH6
Intel ICH6, Intel ICH6
Default Audio Device
front:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
Front speakers
surround21:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
4.0 Surround output to Front and Rear speakers
surround41:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
iec958:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6 - IEC958
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
Direct sample mixing device
dmix:CARD=ICH6,DEV=4
Intel ICH6, Intel ICH6 - IEC958
Direct sample mixing device
dsnoop:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
Direct sample snooping device
dsnoop:CARD=ICH6,DEV=4
Intel ICH6, Intel ICH6 - IEC958
Direct sample snooping device
hw:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
Direct hardware device without any conversions
hw:CARD=ICH6,DEV=4
Intel ICH6, Intel ICH6 - IEC958
Direct hardware device without any conversions
plughw:CARD=ICH6,DEV=0
Intel ICH6, Intel ICH6
Hardware device with all software conversions
plughw:CARD=ICH6,DEV=4
Intel ICH6, Intel ICH6 - IEC958
Hardware device with all software conversions

Anyone…??

I have tried several modifications to the config files but nothing works.
No matter what is selected in Mixer out sound is always redirected to the inbuilt speakers. If I plug in a USB dac that is registered and offered as an output. Spdif is never found as an output option.
All the 'buntus, Daphile, Geexbox et al all pick up the Spdif out and have it as an output option and it works.

Is this an mpd failing or Volumio code ?

Hello,

now in 2020 I have exact the same Problem with actual Volumio Version from January 2020. Board: Intel Atom N2800.

Whereas an Ubuntu Desktop 18 LTS installation shows up all audio out including SPDIF, and let play music on SPDIF, Volumio does not detect it.

Using aplay with -l and -L shows up all alsa information including SPDIF.

Is there a way to configure it within volumio config files?

Best regards,

Martin

Sorry, I must have missed this post.
Please add a new Intel ICH6 card line to the end of /volumio/app/plugins/audio_interface/alsa_controller/cards.json, so that the last part looks like this (note the “,” added after the closing bracket on the AML-M8AUDIO card line)

{"name": "AML-MESONAUDIO", "multidevice": true, "devices":[{"number":1, "prettyname": "I2S + SPDIF + HDMI", "defaultmixer": ""}, {"number":1, "prettyname": "SPDIF + HDMI", "defaultmixer": ""}],"type":"integrated"}, {"name": "AML-M8AUDIO", "multidevice": true, "devices":[{"number":0, "prettyname": "I2S", "defaultmixer": "", "ignore": true}, {"number":1, "prettyname": "SPDIF", "defaultmixer": ""}, {"number":2, "prettyname": "PCM", "defaultmixer": "", "ignore": true}],"type":"integrated"}, {"name": "Intel ICH6", "multidevice": true, "devices":[{"number":0, "prettyname": "HDMI Audio", "defaultmixer": ""}, {"number":4, "prettyname": "SPDIF", "defaultmixer": ""}],"type":"integrated"} ] }

Please test this and report back so we can add it to the next release.