Volumio on the Raspberry Pi Zero 2

what do you mean ?

1 Like

I think some of the early raspberry pi models are 32 bit.

Nope, the main difference b/w v2.xx and v3.xx is the underlying Debian operating system. The older one was based off Jessie, and the newer one is based on Buster. For the Pi, it is all 32bit :slight_smile:

Have a look at the opening post in Volumio 3 RC1 - Open Beta Testing for more details!

My mistake. I think I read “From now on, Volumio for PC will be built on 64 bit architecture only.” too quickly and took it as applying to the RPi.

out of interest, which dac did you use for the Zero 2 ?
and did you use a micro USB OTG ?
I’ve got one hanging around and was thinking about trying it out

I did a search as well and didn’t find this thread. Apologies.

I’ll download v3 and give it a shot.

I used a pimoroni pirate audio DAC Pirate Audio: Line-out for Raspberry Pi – Pimoroni
It connects to the Pi’s GPIO and is equivalent to a HiFiBerry DAC, with a nice little 240x240 colour display. I’ve never tried a USB DAC, but I think they tend to be pretty generic, and most should work out of the box

I’ve managed to get pirateaudio to work with beta 3 now, I’ll post in the pirateaudio plugin page what I did to make it work (downgrade the SRT7789 module from 0.0.4 to 0.0.3, and all is well)

this looks cool. I’ll head over to the plugin page , thx

Hi if your going to use any raspberry pi boot it up wired over Internet an adapter is available online once booted change in setting to wire pass word of home net work this should work. I have my volumio worked fine raspi zero w this way .
I used raspiaudio hat and small 5v amplifier so are both 5v and then use one solor rechargeable power bank so could pluge both into it it works fine.
Hope this helps you out

1 Like

Thanks @jimbo, this isn’t a problem relating to getting access to the network, it’s at the very first level of the Pi actually running at all. I don’t know what’s changed, but the Pi Zero 2 W has a similar processor to the Pi Zero W, but it’s different enough that the system doesn’t get to start up to any significant level. Volumio 3 is based upon a more recent version of the operating system that allows it to boot, and there are no problems getting wired or wireless access once it’s booted.

1 Like

The Pi Zero 2/W need different hardware descriptors to boot…if these aren’t in /boot the kernel doesn’t know how configure the devices.

I think you’re right, but after adding these files to the boot folder, the board still doesn’t boot.
I suspect one of the other boot files needs to be modded so these extra dtb files are looked at.
Do you (or anyone else) know what needs to be changed?

Yeah, those files aren’t the only files that need to change…I mentioned them mostly for the purpose of identifying an install that “should” boot on the device. The raspberry pi firmware decides which dtb to pass to the kernel. So I you have the means, you should be able to update the pi firmware and kernel to get it to boot. It’s probably easier to backup anything important on the device and install the supported version.

1 Like

Thanks for your lead.
I’ve now got it booting.
I copied files from

*.dtb
*.dat
.elf
bootcode.bin
overlays folder
over the files in the boot folder.
I left all the other files untouched (
.img)

It now boots and I can have Volumio 2 on my zero 2.

Got Volumio 2 booting and running now, but my latest problem is the on-board wifi.
I don’t think the hardware is recognised by the OS.
It does work with a USB Wifi dongle!

I am using the latest Buster Beta on RPi0-2 without problems, everything works just out-of-the-box, including the onboard WiFi

The performance increase compared to the original RPi0 is impressive, as expected.

1 Like

What about snapcast?

I did’t try snapcast

are you using Volumio 2 with this ?