Volumio on RasPi 3B+ not responding via network after awhile

I am enjoying volumio quite a bit.

I have one problem.
After some hours of not using volumio it is not reachable via app/browser.

It happens every day. So I have to unplug the power and reboot…which probably is not a nice thing to do.

There seems to be some live in my RasPi when this happens…it is quite warm and the LED on the ethernetport are flashing.

My setup (still a test rigg - I plan to pimp it up with touchscreen and buttons…):
RasPi 3 3B+
via USB to my DAC (Dynaudio Connect - not a DAC but acts like a DAC - it streams to my speakers (XEO 2).
network via ethernet
WLan turned off
Everything powered by the RasPi Power brick
All in the original RasPi-case
No heat sink

Any Idea how to solve this?

I read that some people are running volumio on a RasPi 24/7 - no chance for me… :frowning:


That is strange… Can you still ping the device and/or SSH into it?

Also, can you post a log just after when you had to reboot it? Maybe some interesting stuff pops up there. (Not sure how Volumio deals with logs after a reboot, we’ll see…)

Hi, thanks for the response and sorry for my late answer…I have quite a lot to do at the moment…

I can not ping it and no chance via putty/SSH.
I have to figure out how to get the logs…I will post later about this.
Only a hard reboot is possible now. So you want the logs after this hard reboot?

Any idea?

I had the same kind of issue here. What happened for me was the outstanding need for RAM => the system needs more RAM than available, and comes into a very long swapping process. Sometimes it ends (after a long time), sometimes it doesn’t.

While swapping, the system is still running, leds are flashing, but the web UI won’t connect, neither ssh.

To check this: open a SSH connection before the problem happens, run “top” and leave it running. You will see the memory figures in the header, also also which processes use RAM and CPU.

You are in the same trouble as me if:

  • almost all RAM is used
  • you see kswap0 on top very often
  • you notice that “top” figures are not refreshed every 3 seconds, as it should.

Here, this problem appeared just after booting. Once the webUI and music library was available, and system is running, everything was fine. So maybe, you are not in the same situation.

1 Like

Same issue here, but it happens only if a RaspberryPi 3Plus is connected to ethernet. Wireless works fine and older RaspberrryPi Models don’t have this issue.

My workaround was to switch to wireless until it get fixed.

It might be related to this bug: https://github.com/raspberrypi/linux/issues/2608

Yep, same thing here. Yesterday my system was running good all day long, and pretty much all week. However, don’t shut it off otherwise good luck getting it back running again. All I did before going to bed was turn everything off, and when I got up this morning, nothing!!! Volumio will not start even after entering my IP address which worked fine before. My router is showing that everything is connected but I still get " This site can’t be reached".

I’m running 2 RasPi 3B+ units, and the player has a HiFiberry DAC + Pro on it, the unit in question is the one running the dashboard or whatever its called. Like I said before, everything has been fine up until this morning. If it wont connect, then what?

Ok so not only is this not responding via the network after awhile but now it “will not” even connect to my router anymore. This morning I had it running playing music and all was well, and then it just stopped for no obvious reason…“as usual”. So then I checked the PI with another SD card that had a copy of Raspbien, and it connected as it would normally, so its not the RPI. I even switched Pi’s and its still not showing up in my router. I even flashed 2 SD cards and that didn’t help. I’ve only had this for 2 weeks and when it was working, I was still having connection issues like the signal dropping for no apparent reason, and then it would take forever to get it back running again.

It would appear that I’m fighting a losing battle over here, but I’m not ready to give up either.

Any help and/or suggestions would be highly appreciated.

Good Afternoon All,

I hate to be a “me too” but …

I’m using Volumio, the latest version, 2.657, Hot Spot disabled and I’ve been having a couple of network related problems with this, and an older version.

On a few occasions, if I leave the app paused while I go for lunch or similar, when I come back, it no longer responds in the browser. I see the following “problems”:

  • I cannot get a response in the browser window;
  • I cannot ping the (hard coded) IP address or hostname;
  • I cannot ssh back onto the Pi;
  • I cannot use the Android app to connect either;
  • I have to crash the system out to regain control. This has corrupted a SD card and a full reinstall was required.

That’s a mildly irritating problem, especially when corruption occurs.

My other problem is caused when my router went down all by itself. That left the music playing - nice - but lost me my connection to the Pi again. Again, none of the above worked, and I had to crash t he Pi to regain control. No corruptions this time, thankfully.

I’m on Virgin and the main router is where the Pi connects to over WiFi. When the router crashed/hung or whatever happened, I lost all networking. My laptop did reconnect after the router reboot, but not the Pi. (Could be Pi related of course, not Volumio.)

And now, something useful. I remember writing a blog post on the Raspberry Pi 3, with built in WiFi, losing WiFi after a while, it’s here - qdosmsq.dunbar-it.co.uk/blog/201 … r-a-while/ and explains how to avoid that particular problem. Hope it helps someone.

My Hardware is:

HiFiBerry DAC+ with ADC.
Raspberry Pi 2B+ (Quad core) with official Raspberry Pi WiFi dongle and power supply.

I am too far away from my router to use a network lead and the Pi is running headless well away from monitors and free mains plugs.


Same problem here, cannot connect via network… when playing Flac tracks higher as 44/16 Volumio crashes, freezes… what ever :smiley: but music plays normally… my work around is to down sample to 44/16… and it looks like it stops crashing :-/ anybody have a clue whats happening ? ( RPI 3b+ / Hifiberry digi +)

Thx Marko

Edit.: down sampling to 44/24 works also :smiley:

Similar problem for me with RPi 3B running on Wi-Fi.
I install a fresh copy of Volumio, everything works fine for a while then it just gives up the ghost and stops responding. Doesn’t ping. Shows up on the network okay some of the time then is gone completely. This has been happening with Volumio for a long time now. I used it before with ethernet and same problem. I’d leave it running, come back maybe a day or two later to listen to music and be left trying to sort out technical problems - really annoying.
I’d love to upgrade to a paid Volumio account and / or Primo but it’s just so seriously unreliable.
Just to be clear, I’m using a fully functioning RPi, good wi-fi signal, good quality fast SD card, decent power supply and I have most services turned off…


same problem here.
I am using a Raspi 3B+ with volumio and connection via Wifi.

There has been no problem at all for years. Then I had to set the system up compeletely new because of a problem with a plugin.

After the setting up the system everything seemed to work fine until I left it alone for a while (for the night). After that, I could not reconnect to Volumio anymore. This now happens all the time when the system is not used for some time.

I even setup everything again without any improvement.

Ping is not successful, neither is SSH.

P.S. A hard shut down (pulling the plug) and restart lets me connect to the system until the problem appears again.

Is there really no fix to this?

Thank you

OK, I think I figured out, what the problem was. At least in my case.

As I said, I had to set up the system anew because of an issue with a plugin. Because I am lazy and did not want to change the settings with my other clients, I “recycled” the old IP-address and used it again for the newly set up system together with the same name.

I have no clue why, but I think that was the problem. I assigned a new IP and since then, everything works just fine.

Maybe this has to do with some artifact settings or IDs for this IP in my router not matching the new system?!

Please let me know, If this works for you guys as well.
Also, if anyone can explain this behaviour, I would be glad to know in order to avoid such issues in the future.


So, my problem is gone… iam not sure if its related with yours but it seems my problem was in wrongly formatted usb flash drive… when i started playing flac etc, system become frozen-like (music was still playing), and it was impossible to connect… only hard reset helps, i used to have ex-fat (which is not writable under Linux) now i have fat-32, no more lag… butter smooth response and fast ass hell :slight_smile: no need for work around using lower audio sampling rates… maybe its going to help you guys.

And bonus, all music and folders on samba share server is now editable under IOS, Widows, Mac, without permission problem at all :slight_smile: