Volumio on a sailing boat without a Wifi


Hope all of you are being well.

I would like to acces my Raspi (with Volumio) on my sailing boat.

  • Boat has no wifi
  • Raspi has been configured at home via my Wifi at home
  • Raspi and HD will then be put in a watertight box
  • Once o board I want to connect to the local wifi of the raspi
  • And then connect with my iPad to this network and acces volumio via volumio/local

but … do not know how to do this.

Can anybody help me or point in a direction?

Much appreciated


Sounds cool, careful you don’t drop your iPad overboard!

When there is no connection to your pi with Volumio it will automatically make it’s own wifi network. To check this is on go to settings (settings>network>hotspot settings). Make sure “Enable hotspot” and “Hotspot fallback” are on.

When there is no wifi it’ll create it’s own hotspot and you should see “Volumio” network on your iPad. I believe the default password is volumio.

Then you could use the Volumio app from the App Store or connect via safari to volumio.local

Sounds a cool project. I wanna build one for camping.

Hey, thanks for the elaborate answer. It will be a blast (and a floating disco in Holland!)
Be safe,

Hey, am checking now, but I do not see Hotspot settings under network … What am I missing?

You have to set wireless network to on. And then you’ll see the hotspot ip on the top of the screen.

And the hotspot settings appear below that.

This is what I see under Network Settings …

What do I do wrong?

I’ve only seen the hotspot availability on a fresh install of the Volumio S/W. It’s use is to get you up and running if you don’t have Ethernet. Once you’ve logged into your own home network then the hotspot becomes redundant. It may be possible to alter the config files on existing installation to re-establish a hotspot but the quickest way is to take a new SD card flashed with the latest rev of the S/W and not log in to your home network. You’ll see a new WiFi source on your phone or tablet for the raspberry pi hotspot and just connect to it

Ok, will do thanks!

In settings > system under “Show Advanced Settings” do you have “Full Settings Mode” selected?

I noticed that when that is set to “Simplified Settings Mode” then hotspot settings under network are not available to me.