Volumio failed to open alsa device

Hi all, I have installed Volumio-3.251-2022-03-31 on raspberry 4 with 8Gb of RAM with Sound Card: HiFiBerry Digi2 Pro (connected to the amplifier with Toslink optical cable)
I choose as I2S dac HiFiBerry Digi : Now when starting any audio file I get the error message
“failed to open alsa decvie”
(It worked with Raspberry 3 with the same sound card and same cable)
I searched in the community but couldn’t find a solution
(I tried as someone suggests to do some on / off and various changes but when I go back to HiFiBerry Digi it never works)
Anyone have a suggestion?
Thank you

this is config.txt in the boot dir of raspberry 4

initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1
force_eeprom_read=0 ####this line is not in the rasp3 config (I tried to remove it but nothing changes)

include userconfig.txt

Volumio i2s setting below: do not alter

dtoverlay=hifiberry-digi

I have the same problem but using a Hifiberry DAC+ ADC pro and the Hifiberry Aamp60. Hope to get a suggestion as well

Instead of the HiFiBerry Digi2 Pro I installed an analog HiFiBerry Dac on the rasp4 and it works…BUT
I also installed the touch display plugin 3.3.5 and PeppyMeter ScreenSaver 1.3.0; activating the first all good, activating peppy the music does not go well you hear a second yes and a second no, intermittently sound-silence.
I will also post this notice in the peppy project section
If anyone has any suggestions they are welcome, thanks bye

in other my post " Raspberry 4: best i2s dac?" michel8166 gave an answer that perhaps, but I didn’t understand much, can be used to configure and resolve the “alsa device” error. perhaps
HI