Volumio disappears from wifi network

I’m a new user. I installed Volumio on a raspberry pi 3 b+, I set a static IP on the GUI and create a favourite page on my and my wife’s phone browser, so that even her could easily access the GUI. Everything worked right away. USB HDD recognised, DACs (yes, I’m using two) recognised.
When I start listening, if I check my home network through the router, I see Volumio, whith its IP address and everithing is ok. After a while (the time varies, or at least I think so), the GUI gets stuck on my phone and, if I check the network again, Volumio has turned into a generic “computer” with the same static IP. Later on, even the “computer” disappears from the network. While all this is happening the tracks I queued, keep playing regularly. To have again control, I need to reboot the pi by turning the power off and on.
Any suggestions?
Thank you in advance.

I have 2 rpi 3 model B that do the same when running Volumio.

Never thought to check the router. I will next time.

I have switched to a new rpi 4 , so maybe it will stop happening.

Yesterday I reflashed, updating to the latest version. I pretty much left everything to the factory setting, apart from inserting the wifi network key. Then I gave Volumio a static IP in my router.
Last night it worked flawlessly.
Fingers crossed! :smiley: