Volumio - access to usb drive in network

Hi, with Volumio 1.55 on my RPI 2 I was able to see Volumio and the attached usb hard drive in Windows explorer under network. This was good as it allowed me to move downloaded music to the hard drive by using wlan. Also I could connect Jriver to the hard dive by setting up volumio as a network drive.
Now with V 0.979 the folder usb nas, usb etc don t show up any more. Only “internal Storage”. Any idea how to show USB folder?
Is this a bug or am I doing soemthing wrong? I am not an expert so I appreciate help.

Me too.

Found a solution! Just put in my good old V1.55 sd card
Works like a charm!
I think I better wait another year or so to see if V2 improves :frowning: :laughing:

Don’t be rude only because feature is missing… Volumio is a open source project, and you can contribute to add - improve…
This function will be add as a plugin, but later.
By waiting :
To do that you have to edit the file (using ssh)

/etc/samba/smb.conf

and add

    [usb]
            comment = usb
            path = /media
            read only = no
            guest ok = yes

then update the system :

    sudo smbcontrol reload-config

now from your file browser you should see your usb hd.
This is a example, you may have to adapt the path to what you want if needed.

I have the same problem with the USB drive. The network cannot find the drive, although Volumio plays all the files on it.
I can’t get ssh access to my B+ with volumio/volumio nor with root/volumio
What am I doing wrong?
I’m on 0.979

Help please
HenRyPi

Hi Balbuze,
thanks you are certainly right and I didnt intend to be rude…I thought maybe it is my mistake in settings etc…I didnt know this feature is missing.
Unfortunately I can not contribute as I have zero programing skills. :frowning:

Just tried your proposal by ssh and I get
-bash: /etc/samba/smb.conf: Permission denied
What should I do differently?

No problem…
I forgot to add that To édit you have to type sudo nano /etc/smb.conf

Hi Balbuze,
did run the procedure you described. No error message or any other issue but…no change… cant see the Volumio USB in my Exploerer network. Hmmm. :wink:

Ooops. I think it’s because you have to type sudo /etc/samba/smb.conf (samba was missing.let me know.

Hej Balbuze,
who is the Linux specialist here?? :sunglasses: I tried your update and it did not work. Dont ask me about details.
Then I compared what you wrote but I thought hmm something is different and maybe I should I try…

sudo nano /etc/samba/smb.conf

added to the end of the file_

usb]
comment = usb
path = /media
read only = no
guest ok = yes

plus update

sudo smbcontrol reload-config

and BOOOOM it works!!!
:astonished: :astonished: :astonished:
thanks and I am proud… this could be the start of a new star in Linux ? haha!

Good!
As I said, it will probably add as a plugin, later fora very easy use… :wink:

and I am starting to see the advantages of V2.
Response time when I access the USB drive and also when I run Jriver is much much faster.
Thanks for your good work! :sunglasses: :slight_smile:

Thanks Balbuze,

I needed your info a lot. I finally managed tot get it right by trying (first time) in Putty.

Henry

Hello
i’m really not an expert but all the procedure explained worked fine ONLY if i had the term “smbd” to the original update command

the update command that did NOT work for me (got a “help” message) :

sudo smbcontrol reload-config

the update command that did work for me (and i could the usb hdd from my windows 7 PC)

sudo smbcontrol smbd reload-config

may be i’m the only one with the problem
anyway, i solved it for me, that’s not too bad…

Hi I had the same problem.
the proposal worked so far, that I can see the USB drive now over the network. I can read stuff from there but if I want to copy something there I don’t have permissions to write.
Am I missing something? I connected as “guest” and " volumio" and “root” always no permission to write.
Please help.
Best regards
Peer

I also have the same problem as Peer. Noob at Linux…so idk what to do :laughing: :laughing:

I am having the same problem on OSX. I can get the drive to show up, but I have insufficient access. I have tried CHMOD to change permissions, but to no avail.

Hello,

I have the same problem with the network and with the newest version of Volumio (2.041): I can’t see the mp3 files on the SD card in my PC network folder. :cry: I can’t understand why wasn’t this fixed yet.

Also there is a problem together with mpdroid what I use on my smartphone. With the older version of Volumio 1.55 all songs were synchron - at smartphone (mpdroid) and on pc (browser). Now it’s not so more - nothing is displayed in browser in Volumio/playback.

So I don’t see any advantages and think to return to V 1.55.

Regards,

Martin

Hi.

Same issue here on OS X: I can see the USB drive in the finder but have insufficient rights. I tried several things in the smb.conf file (like “writeable=yes”) and so on.

Then I’ve just also put the concrete name of the USB stick in the path and now it seems to work…

Is there an option to automatically have access to whatever USB drive I attach?

The smb.conf lines that now seem to work btw look as follows:

[usb]
comment = usb share
path = /media/256GB_MUSIC
public=yes
guest ok = yes
browseable = yes
writeable = yes

where “256GB_MUSIC” is the name of the stick.

happy for your feedback.

Cheers

Good evening,

I have a similar problem.

I have installed Volumio (Version 2.673) on a Raspberry Pi 3B and I use a SSD connected via USB.
Fileformat off SSD is exFAT and I copied some music to that drive, before I connected it to the Raspberry Pi. I can play this music via Volumio and I can browse the folder on the SSD, if I am connected via SSH.
Now I want that SSD be accessible via network and if I connect as guest to the Raspberry Pi I can see a folder with the name of the SSD, but I have no right to open that folder. The same behavior if I am connected as volumio user.

smb.conf is not changed.

Does anyone have any idea why? Or what else I could control?

Thanks a lot.

Raymond