Volumio 3 RC1 - Open Beta Testing

It would be great if they update the Autostart plugin for Volumio 3. I install it manually and it works fine.

Hi Exnovo, thanks for the precious feedback. I read your message before, and I did write you an email. Maybe it’s in your spam box?

It is to be noted that Multiroom can be disabled, and we were already aware of the issue with Direct DSD and worked on a fix.
This did not make it into release but will do very shortly.

Thanks again and hope this solves your doubts

The Manifest Ui won’t show metadata if there’s not enough room in the view, this is due to a recent optimization.
We could further refine it for 7’’ if you could let us know your display resolution

What plugins did you have installed? This is very important for us to know

We are checking as we speak, probably the manifest UI will not show the required controls

1 Like

@volumio and @mervinio Using the offical Pi display ( 7" 800x480) and yes, I really liked the metadata on the local display.


1 Like

Thanks Michelangelo for the info.

  • Touch Display V3.3.1
  • Now Playing V0.1.3
  • System Information V3.0.0
  • Spotify V2.0.3
  • PeppyMeter Screensaver V1.3.0
  • Contemporary advanced V1.0.5 (was not enabled)
1 Like

Contemporary advanced V1.0.5
radio paradise
youtube caster
touch display

Contemporary advanced modify /Volumio…
It is the cause of integrity failure.
When disabled, it restores files in /Volumio…

Last favourite track still cant be removed if its from Spotify plugin.
It just keeps staying in the favourite listing, no matter what.

info: Removing uri spotify:track:69uKRb41ioeUpYtHIAKqkN from favourites
info: CoreCommandRouter::executeOnPlugin: spop , removeFromFavourites
info: Error : CoreCommandRouter::executeOnPlugin: No method [removeFromFavourites] in plugin spop
info: Saving Cloud item favourites
info: CoreCommandRouter::executeOnPlugin: my_volumio , saveCloudItem
info: Pushing Favourites {"service":"spop","uri":"spotify:track:69uKRb41ioeUpYtHIAKqkN","favourite":false}

i have tried to look at the public sources, but this seems to also involve proprietary code?

if its stuck somewhere in the cloud, you have my permission to remove it from the database if thats possible.

Yep but it was already disabled. I think it was related to PeppyMeter as it uses an ALSA Pipe.

If it restores files, it’s even worse! This will make volumio stop working if you update.

@dvo can you please remove this plugin and don’t ask people to use it?
This until we find a way to have UIs loaded as plugins

Please, this is still creating lot of troubles to us


I’ve noticed the same thing - I have one song from Spotify that is like a permanent fixture in my Volumio favourites list.

that is one of the plugin’s i want to use.
@volumio i will switch it off with a update ( this fix the problem )
but removing it… i don’t like that… then i’m stuck on the old design what i don’t like at all.

1 Like

flip side of this coin is that, when people report issues and have plugins that causes those issues, volumio team is put to chase ghost’s when trying to replicated and fix the issues.

1 Like

i understand it but we have a problem… and a fix for it… so why removing it ?
we can learn people if you want to update switch your plugin’s off … it’s so easy…
or add in update that when you update auto switch off plugin’s in config of update.

15 minutes left…


Where is it ?