Volumio 3 on Macbook air

I am new the forum, I tried installing Volumio 3.396-2022-12-05 on Macbook Air (2011 version). Installation medium booted fine, but ended up with a white screen.

I logged in using (Ctrl+Shift+F1) terminal, to see the logs, I don’t know where to look for the error. I see

I am copying these by manual typing as I didn’t get network working.

$ cat /var/log/volumiokiosk.log

Starting Kisok
Waited 0 sec for Volumio UI
Openbox-Message: Unable to find valid menu file "/var/lib/openbox/debian-menu.xml"
ERROR: openbox-xdg-autostart required PyXDG to be installed

.... gnu_init.cc(426) Passthrough is not supported, GL is desktop
.... sandbox_linux(374) InitilizeSandbox() called with multiple threads in process gpu-process
... bus.cc(393) Failed to connect to the bus: Coudl not parse server address: Unknown address type (...tcp, unix)

... object_proxy.cc(62) Failed to call method: org.freedesktop.DBus.Properties.Get .... UPower was not provided by any .service files
... object_proxy.cc(62) Failed to call method: org.freedesktop.DBus.Upower.GetDisplayDevices
... object_proxy.cc(62) Failed to call method: org.freedesktop.DBus.Upower.EnumerateDevices

Where do I go from here? Is there some other log file that I should be looking at? Or a install a different version of volumio?

boot.log has no issues, I can setup wifi and see if that helps, but looks like a display/graphics driver issue. What can be the next step. Thanks for reading my message!

Mac’s aren’t officially supported, though I have seen a number of reports from people running Volumio on Mac Mini’s and Macbook’s successfully.
I would need a complete bootlog to be able to check anything.
Would it be possible for you to dump the output of

sudo journalctl -b



to a .txt file on your boot partition (/boot) or a 2nd usb stick and somehow get from there?

It is working now, not sure if rebooting worked or waiting a really long time on the white screen helped.

An issue with a white screen has been reported before, which was solved by rebooting. It only happens on first boot.
The problem is due to a too short timeout in some rare cases, causing the UI to start before the display manager is up.
This timeout will be increased for one of the next image versions.

1 Like

I am sorry this is turning into a more support section, I am facing more issues.

It was working reasonably on USB, except for second monitor ( connected through display port) was not displaying UI. But it was routing music correctly though display port.

But after installing on disk it booted again white screen. Second boot mouse was only moving vertically - no horizontal movement. Also second monitor (display port) was showing blank screen which had a menu (on right click I guess?) that looked like:

Terminal Emulator
Web Browser
Applications    >

And this point I kinda gave up, i wanted both screen (to mirror) and mouse to be working. Will try it again another day. If you respond I shall try those next time I continue from where I left off.

A reboot at this point would be necessary (first boot from a device).

With a second monitor I’m afraid you’re on your own.
As mentioned at the beginning, Macbooks are not supported and for a single user there is not much point for me to try getting it to run with additional requirements.