Volumio 3 does not index NAS based music library

Updated to Volumio-3.175-2021-12-13-pi. Indexing my NAS based music library is not working.

/var/log/mpd.log is flooded with lines like:
[src/libmpg123/readers.c:1184] error: Cannot open file /var/lib/mpd/music/NAS/HullyGully-NAS/Amy MacDonald/This Is The Life/04 - Youth Of Today.mp3: Stale file handle
Dec 20 08:48 : mpg123: libmpg123 failed to open /var/lib/mpd/music/NAS/HullyGully-NAS/Amy MacDonald/This Is The Life/04 - Youth Of Today.mp3: A generic mpg123 error.

The NAS is mounted via cifs and accessible, permissions are looking ok:
ls -l /var/lib/mpd/music/NAS/HullyGully-NAS/Amy\ MacDonald/This\ Is\ The\ Life/04\ -\ Youth\ Of\ Today.mp3
-rw-rw-rw- 1 root root 7395200 Apr 26 2016 ‘/var/lib/mpd/music/NAS/HullyGully-NAS/Amy MacDonald/This Is The Life/04 - Youth Of Today.mp3’

Same library worked with volumio-2.917-2021-10-06-pi.img.
HW: Raspi 4, HiFiBerry Digi, DSD Direct, Network via wired LAN (WLAN is configured as well)

Just to mention that I’m experiencing the same issue. I’m also seeing these errors in the Live Log on the dev page:

cifs_all_info_to_fattr: 59 callbacks suppressed
CIFS VFS: bogus file nlink value 0
CIFS VFS: bogus file nlink value 0
CIFS VFS: bogus file nlink value 0
CIFS VFS: bogus file nlink value 0
CIFS VFS: bogus file nlink value 0

Raspberry Pi 3B
Clean install of Volumio 3.175 from the img file.
No DAC connected yet.

I’ve tried both cifs v2.0 and v3.0 but with the same result.

Same issue at my site. But I think, this is not related to the Volumio 3 issue (Volumio 2 worked in the same environment).
The “bogus file nlink value” issue is existing since years with the FritzBox. It is independent from Fritz OS (6.x, 7.x), Samba Version (1, 2, 3) and clients (Raspbi OS, Volumio, OpenSuse Leap, OpenSuse Tumbleweed, …). Even with that, all file operations on the NAS are working.

1 Like

I reported the same “Stale file handle” issue here yesterday, but after trying moOde and getting exactly the same result and error message I added the ‘noserverino’ option to the mount settings in moOde and this seems to have resolved the issue. Presumably adding the option to the source under ‘Advanced Options’ in Volumio 3 will have the same effect.

Also without the noserverino mount option I could browse to the NAS folder (when SSHing to the Pi) and see the audio files, but if I tried to copy them locally then I got the Stale file handle error. With the mount option included then I can successfully copy the files.

I am using a FritzBox router with a USB drive as a NAS (FRITZ!OS v7.30).

Hope this helps.
Chris

Thanks for the hint. noserverio solved my problem - Volumio 3 is now indexing.
noserverio is not solving the old “bogus file nlink value” issue, but for me this is not a problem.
Thanks, Jens

3 Likes