Volumio 3 cannot find NAS

Volumio Information

Volumio Version: 3.173
Hardware: Ras Pi3
DAC: Chord Hugo

Hi,

I upgraded, with the original setting erased, i need to re-mount my NAS, However i cannot seems to mount it even though Volumio could find the NAS on network. It used to be connected when I input "vers=1.0’ in the option box. But this is not working now.

Am I missing anything?

Thanks,

A log would be a big help here.
Howto: Send a log

1 Like

This sounds similar to the issue that I’m experiencing, where I can mount the path to the NAS successfully but no music files are populated into the database and I get an error. I added to this thread here. For now I’m downgrading back to V2 until sorted.

Just for info: yes, Volumio 2 still works but goes EOL soon.
Means won’t get updates anymore and no more support.

I faced this problem too. In the line of the IP address, you need to accurately indicate the IP address of the NAS

1 Like

Just sent over the log. :pray:t2:

http://logs.volumio.org/volumio/iUY2PFW.html

When you add a network drive, do you use the browse function and select your share?
Or do you enter the details manually?

Your log shows this connect string:

COMMAND=/bin/mount -t cifs -o username=,password=,ro,dir_mode=0777,file_mode=0666,iocharset=utf8,noauto,soft,vers=2.0 //PCH-A400/share\Music /mnt/NAS/share

When I look at my cifs connect string, I have:

COMMAND=/bin/mount -t cifs -o guest,ro,dir_mode=0777,file_mode=0666,iocharset=utf8,noauto,soft //MEDIANAS-1/music /mnt/NAS/music

That is why I think you have entered the Alias or Path incorrectly, what are your vaules?

I selected from browse function but added “Music” to the path.


In the second line of the NAS IP, you must enter the correct address in the form 192.168 …

1 Like

you should use “share/Music” not “share\Music”
Or change your shared folder to include Music., then use only need to browse and not add anything

Your suggestion works! Thanks :pray:t2: