Volumio 3 Buster for Asus Tinkerboard

Please use this topic to discuss errors, missing components or improvement suggestions during the Volumio 3 Buster beta test phase for Asus Tinkerboard.

In this opening and first following post we will keep a list of beta versions, fixes, known problems and important updates.
Please also refer to the general issues for Volumio 3 Buster issues, which are not platform-specific.

This thread will be moderated actively. With issues, which do not appear to be Tinkerboard or Debian Buster related, you will be referred to the help section.

To help us locating and fixing issues, the following information is mandatory:

  • a recap of the boards configuration, incl. list of peripherals (DACs, disks etc.)
  • the exact image version you are testing with
  • whenever possible, the URL of the logfile you created with the log function from the dev page

Current download link
Volumiobuster-3.083-2021-08-16-tinkerboard

Previous
Volumiobuster-3.082-2021-08-16-tinkerboard
Volumiobuster-3.081-2021-08-14-tinkerboard
Volumiobuster-3.080-2021-07-27-tinkerboard
Volumiobuster-3.079-2021-07-06-tinkerboard
Volumiobuster-3.078-2021-07-01-tinkerboard
Volumiobuster-3.074-2021-05-17-tinkerboard
Volumiobuster-3.073-2021-05-07-tinkerboard
Volumiobuster-3.067-2021-04-16-tinkerboard
Volumiobuster-3.066-2021-04-15-tinkerboard
Volumiobuster-3.051-2021-03-06-tinkerboard
Volumiobuster-3.046-2021-02-26-tinkerboard

Reserved for the 2nd post

Just installed Volumio 3.046 on my tinkerboard.
Here is the log of the first session:
http://logs.volumio.org/volumiobuster/ocI1Zab.html

1 Network configuration via hotspot √
2 open dev mode, enabeld ssh √
3 monitoring with journalctl -f
4 connect usb drive
-> device is detected and mounted √
5 start scan library √
6 activate Virtuoso √
7 add Qobuz √
8 play local Titel √
9 play qobuz titel √
10 pause and play qobuz √
11 play radio √
12 test upnp √
13 test shairport √
14 connect to 2 volumio on rasperry 4 √

so this is more of a success report than a bug report.
Thought you might enjoy one for a change :wink:

one thing i found is nmbd still trying the old hotspot ip
> Feb 28 17:29:44 volumio-tinker volumio[724]: info: CoreCommandRouter::executeOnPlugin: mpd , getMyCollectionStats
> Feb 28 17:29:47 volumio-tinker nmbd[2102]: [2021/02/28 17:29:47.375038, 0] …/source3/libsmb/nmblib.c:917(send_udp)
> Feb 28 17:29:47 volumio-tinker nmbd[2102]: Packet send failed to 192.168.211.255(138) ERRNO=Invalid argument
> Feb 28 17:29:48 volumio-tinker volumio[724]: info: CoreCommandRouter::executeOnPlugin: mpd , getMyCollectionStats
> Feb 28 17:29:51 volumio-tinker nmbd[2102]: [2021/02/28 17:29:51.385245, 0] …/source3/libsmb/nmblib.c:917(send_udp)
> Feb 28 17:29:51 volumio-tinker nmbd[2102]: Packet send failed to 192.168.211.255(138) ERRNO=Invalid argument

i will continue testing connecting a usb dac and see what reboot does to the system.
So far this release looks really good.
Congratulations.

I entered a wrong password in the wireless network settings.
As to be expected the network did not connect, yet wpa_supplicant tried accessing a file that is missing:
Mar 01 15:58:10 volumio-tinker wpa_supplicant[14155]: nl80211: Failed to open /proc/sys/net/ipv4/conf/wlan0/drop_unicast_in_l2_multicast: No such file or directory
Mar 01 15:58:10 volumio-tinker wpa_supplicant[14155]: nl80211: Failed to set IPv4 unicast in multicast filter

I report this just in case this might be helpfull. Overall the system function seem not to be affected.

On another note; when changing the audio interface in settings the sytem takes a long time (several minutes) before any audio can be played again. Also a new title has to be chosen before playback starts.
Is this expected behaviour?

I would like to compare SQ of different audio devices like the build in Audio Jack vs a connected USB Dac.

changing audio device: please submit a Volumio log!!

Here is the logfile:
http://logs.volumio.org/volumiobuster/ssPh2eN.html

Also i just found i can not add a qobbuz title to favourites.
And here is the logfile for that:
http://logs.volumio.org/volumiobuster/LZEq4Oz.html

Please ignore the farorite part.
I expected to find favorite title under Favorites, yet qobuz title are listed under QOBUZ -> my titles.
My bad.

Mpd became unresponsive over night and had to be restarted.
Here is the log:
http://logs.volumio.org/volumiobuster/Y29rxpu.html

new version out, see OP

Tested Volumiobuster 3.051

Configuration:

  • ASUS Tinkerboard (no “S”)
  • HiFiBerry DAC plus with linear power supply
  • ASUS SPDIF plate cable bracket with optical and RCA out (Spdif soldered board connection, +5V and GND connected to pin 4 and 6
  • LAN connected, WLAN disabled
  • Nothing was disconnected during test

Image: Volumiobuster-3.051-2021-03-06-tinkerboard

A.)
First try with HiFiBerry DAC plus because of my special interest to make the HAT working. The positiv was: Interface was asking for reboot after selecting the DAC. But: there was no clear indication that reboot was carried out. Finally the good news for me: HiFiBerry DAC plus is working attached to TB with this Beta.

B.)
Quick try to connect HDMI. After reboot TB shows the following on the screen:


Also the Web interface was not accessible - just a waiting cycle. So I gave up.

C.)
Reconfiguring to SPDIF. I must say without have the possibility to do a A/B comparison my favoured testing tracks have more punch, more transparent and clearer bass - wow!

The only drawback is 88,2 kHz and muliplier 176,4 kHz gives a noisy, crapy sound over the music. Connect to older equipment also 88,2 capable gave silence only. All other sampling rates up to 192 kHz are working fine. BTW: volumio 2 has no such problem.

Further investigation showed: this is true for Hires sources (Qobuz) as well as for selecting the appropriate upsampling rate in the setup.

Runnig a log while starting a 88,2 hHz tracks gave only this significant difference (left volumio 2 - right volumio 3):

Let me know if I can perform further testing on the OS side.

EDIT: Volumio 2 has implemented an automatic upsamling from 88,2 kHz to 96 kHz in the background. I.e. obviously the ASUS SPDIF plate cable bracket does not support 88,2 / 176,4 kHz.

I found the folling issues running version: 3.066

Equipment:

  • ASUS Tinkerboard (no “S”)
  • HiFiBerry DAC plus with linear power supply
  • ASUS SPDIF plate cable bracket with optical and RCA out (Spdif soldered board connection, +5V and GND connected to pin 4 and 6
  • Topping D10 DAC
  • LAN connected, WLAN disabled, Hotspot disabled

Image: Volumiobuster-3.066-2021-04-15-tinkerboard

Sources:

  • Library
  • Internet Radio
  • Qobuz
  • BubbleUPnP
  • J.River

Configuring the HiFiBerry DAC plus gave the folling error message after a first reboot :

grafik

Hitting the reboot after selecting the DAC model does not show the cycle:

grafik

There is no clear indication reboot is performing.

Finally I made the HAT working was like I2S Device + “HiFiBerry DAC plus” → “reboot” → HiFiBerry DAC" → “reboot” → HiFiBerry DAC plus" → “reboot” sucess!

Support for support 88,2 / 176,4 kHz via Spdif output still not working. In Volumio 2 there was an automatic upsamling from 88,2 kHz to 96 kHz implemented.

Find log while switching from a 44,1 kHz/24 bit track (music playing) to a 88,2 kHz/24 bit track (noisy or no music): http://logs.volumio.org/volumiobuster/vyPZkll.html

Player State looks like this while playing the 88,2 kHz/24 bit track:

{“status”:“stop”,“position”:0,“title”:“Looking At Sounds”,“artist”:“Michel Benita”,“album”:“Looking At Sounds”,“albumart”:"/albumart?cacheid=558&web=Michel%20Benita/Looking%20At%20Sounds/extralarge",“uri”:“http://192.168.1.169:57645/proxy/qobuz/815BBB5A7F05220AEC12CD1E6DFBF78B.flac",“trackType”:“flac”,“seek”:273059,“duration”:520,“samplerate”:"88.2 kHz”,“bitdepth”:“24 bit”,“channels”:2,“bitrate”:null,“random”:null,“repeat”:null,“repeatSingle”:false,“consume”:true,“volume”:100,“mute”:false,“disableVolumeControl”:false,“stream”:false,“updatedb”:false,“volatile”:false,“service”:“mpd”}

DSD via UPnP to the D10 is working fine. I sort of remember this was not working with Volumio 2.

At initial setup the German translation for “Setting” is missing on the left hand menu. After a few reboots “Einstellungen” was showing up.

Media Servers are not showing up at all. With Volumio 2 on the TB there is no issue and usually I can see all of them, except the WD NAS Twonky server. But there is a BubbleUPnP Server runnig in my network, which helps to find it through it’s proxy. EDIT: Took a while, now Media Servers are there except Twonky.

Testing version 3.067 using same equiment as above, but a Douk Audio USB to Spdif converter.

Image: Volumiobuster-3.067-2021-04-16-tinkerboard

I found the folling issue: After powering on the unit and start playing via DLNA there was no sound to hear. The playback options output device was still set to “HIFI DSD”. After pressing “Save” in the output device tab, the sound starts playing immediately. Find this procedure logged here: http://logs.volumio.org/volumiobuster/8cnSKa2.html

From this junction in time the unit does work w/out any problem.

This did already happen multiple times. The unit was always shutdown cleanly.

Update version 3.078 …

Updated version 3.079 …

Updated version 3.080 …

Updated version 3.081 …

Updated version 3.082 …

3.083
“Failed open alsa” after restart

Tidal Connect on 3.0.83 for Asus is broken the same way as on 3.083 for x86

IMPORTANT for Volumio 3 beta testing

Since Volumio 3 Beta 3.079 a number of unstable test images have been pushed into OTA (and the download area). The development has reached the stage, where the team is forced to use the official Release Build to test final issues, this appears not quite trivial. Most testers have set their installation in “Test” mode (which was suggested and not corrected by the team afterwards). OTA “Test” mode has always shown all images, including untested or even worse, non-functional test ones.
Some versions were also published in the forum threads which should not have happened, the team apologizes for all that. There was a warning for non-working images from the start (read the announcements), so hopefully you understand and bear with us.

Change of Volumio 3 Beta Policy
Volumio will continue to release images for Volumio 3, but will now make a firm difference between “beta” and “alpha”. Therefore the team would like you to do the following:

  • Unset “Test” (OTA) mode and do not set unless instructed in certain circumstances. This will prevent you from getting unstable alpa builds.
  • Please do not forget to unset afterwards when such an exception was the case.

OTA “Test” mode “disabled” (beta) will get you a Volumio 3 beta build which is at least tested by the alpha testers.

OTA “Test” mode “enabled” (alpha) can still be used (we advice against), but please be aware and understand: do NOT start forum discussions or ask for support.
Unless: in pre-communicated, pre-selected circumstances (e.g. where we would like you to re-test a reported issue before releasing it as stable beta).

Final Beta Testing notice
The Volumio team has had many, many reports where people do not send any information at all, let stand the version of the beta software they are testing with. Please give the team a chance to help with our problem. “Latest version” has no value, two days later “latest” may be moot, remember, you agreed to help the team. It is not the developer job to chase the version you may have meant, he needs facts.

Also, whenever possible, add a log for the team to work on, the more logs they have, the higher the chance to get the issue resolved. Preferable from a fresh reboot, with minimal steps to reproduce the problem :slight_smile: Learn about it here

Fututure development
The Volumio team is aware of the fact, that the current separation of test and production system is not ideal and does not match the complexity of Volumio as it became. The team has a plan and is working on improving it, but does not want to introduce any change at this moment which would further delay an initial Volumio 3 release.

When Volumio 3 is released, the stable channel will only contain official Volumio 3 releases, and an additional alpha and beta channel will be added.

There is a new beta version available, download it from this location:

Volumiobuster-3.101-2021-09-08-tinkerboard.zip

There is a new update available: Volumio 3 Release Candidate 1:

Volumiobuster-3.111-2021-10-08-tinkerboard-RC1

The next stage of testing will involve a Volumio 3 Announcement with reported feedback in a new single thread for RPi, Tinkerboard, and x86 .

Thread closed … see you in the new thread. :smiley: