Volumio 2 takes 10 secs (minimum) to play a song.


I have been using a Raspberry 1 with raspify and the initial versions of volumio flawlessly during the last 2 years. I have recently upgraded my audio system to a raspberry pi 3 with Piano DAC and Reclocker. The digital audio source has been always the same: Synology NAS with FLAC files connected to a Gigabit LAN with CAT 6 wires.

The point is that ever since i swapped to Volumio 2, playing times are so slow. I mean, navigating through the music collection is OK (the NAS is mounted with NFS file system) but the time spent since I click on “Play this song” or “Play this album” until it sounds something, is almost 10 seconds!

Is it normal? Did I did something wrong at the configuration? Has anything changed?


Am I the only one having this issue?

I had the same issue as well. Not sure how to solve it.

I’m thinking on what can be the case… Because on mine it starts immediately. The only time it takes a long time to start is when I don’t use it for hours and then I restart…

So this could be my explanation:
We added a utility to not keep alive the connection beetween volumio and NAS, this way if you don’t play music, the NAS can enable power save mode (it was asked by some community members).
To see if that’s the case with you guys as well, please try this:

  • Play a song from NAS (by adding from browse menu) (here it should take 10 seconds as you explain)
  • After 20 seconds, add another one as you did before

How much does it take to start?

If it takes 2 seconds, then my assumption is right. If that’s the case we’ll probbly add an option to disable the power saving feature of volumio.

Let me know

How big did you set the buffer? I believe this can help a bit? Mine is set to 2Mb and start play at 10%. This works well on my PI3 with cabled LAN.