Volumio-2 Spotify Plugin not working - solved

The Spotify Plugin does not work for me at all.

My System: volumio-2.001-2016-10-15-pi on 8G SD-card, Raspi 1 Bplus, HiFiBerry DAC+

Volumio2 runs fine on IP-Radio as well as files on an USB stick - sound is excellent.

I started the installation (as user volumio; PW: volumio) of the spotify plugin included in the release which it ran w/o problems and ended with the message: “successfully installed”.

I filled in User and PW but the plugin would not signal activation. I ran update w/o success and after that I clicked “uninstall” which showed absolutely no reaction. Reboot etc. did not change things.

Please give me either some advice for troubleshooting or manual removal of this plugin.


You have a Spotify Premium account, correct? Can you post the contents of /var/log/volumio.log.

I already noticed and reported that : something is wrong with dependencies. If you enter spopd -c /etc/spopd.conf you get spopd -c /etc/spopd.conf spopd: error while loading shared libraries: libspotify.so.12: cannot open shared object file: No such file or directory
issue : https://github.com/volumio/volumio-plugins/issues/25
This on rpi B. Seems to work on RPI 2 and >

you have to do LD_LIBRARY_PATH=/usr/local/lib spopd to make it work.

It seems the service does not start properly

Thanks to both of you for coming back to help.

I tried to collect some more infos and yes its a premium spotify account.

Confirmed, same here. But


And here is an excerpt from volumio.log

I hope you can read something useful out of this…

Sorry it’s export LD_LIBRARY_PATH=/usr/local/lib/ spopd

This code ran w/o any confirmation or error message.

The plugin is still inactive and does not behave different in any way.

Save config in plugin

Success, the activation is green now.

You were right, just clicking the save button does not do the job.

I opened the spopd.conf with nano to verify my entries and saved it back.

After that the activation turned green.

b.t.w. The uninstall button did not work - is the script behind it still missing?

Thanks again for your help

I got it activated, but when I play music from Spotify, there is no sound on the output. Radio for example works. Any ideas?

My config: RPI3+i2s iqaudio digiamp+, fresh installation of volumio 2.001 with spotify enabled, configured and activated + fix for config save. Tried twice, got the same issue.

Good news, now it is working. There are two issues:
1.) you have to add the correct LD_LIBRARY_PATH, you can also make by adding into /etc/environment the following, which will make it to set the variable on boot:


2.) After investigating what is going on, i noticed, that servis spopd is reporting wrong username. I change the userneme not to use the “@” symbol. Now it is working.

It looks like I’m having the same problem as yourself that you have resolved. So from what I gather is I basically copy and paste.