Volumio 2, Beta3: USB DAC volume control not working


great work on Version 2!

One bug I noticed (and its possible its already mentioned - apologies) , is that the volume control for a USB DAC isn’t working, but for the onboard PWM it does work. I’ve tried controlling the rotary dial, as well as the volume up and down buttons (mute also doesn’t work).

I have a Behringer uca202 USB device . From DMESG:
usb 1-1.3.3: new full-speed USB device number 6 using dwc_otg
usb 1-1.3.3: New USB device found, idVendor=08bb, idProduct=2902
usb 1-1.3.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-1.3.3: Product: USB Audio CODEC
usb 1-1.3.3: Manufacturer: Burr-Brown from TI
input: Burr-Brown from TI USB Audio CODEC as /devices/platform/soc/20980000.usb/usb1/1-1/1-1.3/1-1.3.3/1-1.3.3:1.3/0003:08BB:2902.0001/input/input0[ 5.603317] hid-generic 0003:08BB:2902.0001: input,hidraw0: USB HID v1.00 Device [Burr-Brown from TI USB Audio CODEC ] on usb-20980000.usb-1.3.3/input3

System version: 0.836 Released: Tue Feb 23 22:29:19 CET 2016


UPDATE: My daughter just tried airplay from IpadAir2 and that works, including volume control.

Volume control isn’t fully implemented in the current release. This is a goal for the next 2 weeks.