Volumio 2 and brutefir

Hi,

Thank you, I have tried long filters and there is no error message, so that part is fine now.

I tried all the output formats in the list and a lot of input format as well modifying brutefir.conf.tmpl, several reinstall, more restarts, but no output music at all.

My DAC is rare (Okto Research Dac8 Stereo) but works well with Volumio without BruteFIR.

One attempt was to simplify config file removing VoBAF part and connect the only one filter setting to the output;

remove: filter “l_out” {from_filters: “lVoBAF”;to_outputs: “l_out”/${lattenuation};coeff: “l_out”;process: -1;};

added: filter “l_out” {from_inputs: “l_in”;to_outputs: “l_out”/${lattenuation};coeff: “l_out”;process: -1;};

but BruteFIR dropped an error message on UI at next plugin enable. It was possible to clean up unused settings about a year ago.

Please let me know, how can I continue, if no output sound at all ?

I just tried:

systemctl status brutefir -l
● brutefir.service - brutefir Daemon
Loaded: loaded (/etc/systemd/system/brutefir.service; disabled)
Active: active (running) since Sun 2020-12-06 17:04:05 UTC; 4s ago
Main PID: 8750 (brutefir)
CGroup: /system.slice/brutefir.service
├─8750 /bin/sh /usr/bin/brutefir /data/configuration/audio_interface/brutefir/volumio-brutefir-config
└─8751 /usr/lib/brutefir/brutefir.real /data/configuration/audio_interface/brutefir/volumio-brutefir-config

Dec 06 17:04:05 volumio systemd[1]: Started brutefir Daemon.
Dec 06 17:04:05 volumio volumio[8750]: BruteFIR v1.0m (November 2013) © Anders Torger
Dec 06 17:04:05 volumio volumio[8750]: Internal resolution is 64 bit floating point.
Dec 06 17:04:05 volumio volumio[8750]: Creating 4 FFTW plans of size 131072…finished.

What is strange the “/etc/systemd/system/brutefir.service; disabled” despite it looks Green on the UI.

Hi Balbuze,

I wish you Merry Christmas.

During last weeks I spent some time to figure out why no music at all with FIR filters from earlier Volumio and I found current version of Volumio BruteFIR implementation does not support usage of filter lengths over 262144. Old versions, last I installed a year ago supported longest filters and in general the BruteFIR supports very long filters, I don’t know about restrictions there. Could you check what can be a problem in Volumio implementation, please ? I tried to set up number of partitions to 16 but it did not help.

Hi @Dudu
Thank you and Merry Christmas!
The plugin supports filter length 2048, 4096, 8192, 16384, 32768, 65536, 131072, 262144, 524288
There is a check if it matches one of this length.
How are generated yours filters?
A very long filter introduces a long delay.

Hi Balbuze,

Please check the 524288. That is not supported. No warning or error message but no sound on output. My old filters from a one year old Volumio are 524288 taps, so 1.048.576 long filters. Currently BruteFIR plays only four times shortest filters.

Yes, long filters causes bigger delay, but it is important only at the start of the first track. I played lot with filters and it seems short filters has audible artifact especially at bad bass response, for example drums has no real drum instrument sound in the stereo space, so I use as long filters as I can use with RPI4.

I use RePhase and tested wav->pcm and float *.txt filters as well, both works well till 262144 only but not for 524288 or 1.048.576

First I thought the new DAC is the problem since there was no distorted sound on the output, but DAC works well.

Thank you for your help

Please, can you post one filter here so that I test? Thanks

@balbuze Hi, as I am running with my Hifi Berry Amp (China Copy “Inno HIFI AMP HAT”) in the same situation as wmoecke in 2018 maybe you have a glue.
I am using the latest volumio version 2.873 and your latest plugin. Hardware detection works perfectly. But when it comes to the first time playing, softvol says “NaN” but in reality, setting is at 100% and I have no hard ware volume. However which value I set (e.g. 5Vol%) → 100% real speaker vol.
I can make it work with a lot of playing that soft vol is adjustable in reality but when it comes to reboot all is gone and again softvol says “NaN” but with 100% speaker volume and my neighbours will knock when I do testing to often :slight_smile:
Maybe there is a solution?
Kind Regards Korniman

Hello
This a complicated problem with Volumio 2.xxx.
One thing, is to never change mixer after the plugin is enabled. If you did it, try to reset the plugin and disable it. Reboot. Set volume mixer properly. When ok enable the plugin…
But I suggest you to test Volumio buster with the updated version of the plugin using Camilladsp. : https://www.github.com/balbuze/volumio-plugins/tree/alsa_modular/plugins%2Faudio_interface%2FDsp4Volumio

@balbuze, thank you for your feedback. I carefully checked the procedure. Now I have no sound at all with brutefir plugin, maybe MPD OLED will have some impact on brutefir yet. How ever, I will wait until Volumio 3 is official released and will test it when plugins are ready vor volumio 3 too, as I am using some of them.

I guess you modified /etc/asound.conf?
But you’d better wait for Volumio3…