Volumio 1.5 + iOS10.1.1 = WebUI 'connecting'

Volumio 1.5 on Cubox-i4Pro, control via iPads running latest iOS10.

Since last iOS update the WebUI loses connection each few tens of seconds, showing
the ‘connecting’ spinner. Reloading the page or restarting the WebUI restores things to
normal. All was fine and stable for years with earlier iOS versions.

This is iOS-related: an old iPad2 with iOS9 does not show this behaviour.

For comparison, Moode Audio on an RPi2 acts similarly,
except that when the link is broken the WebUI immediately restores it
on its own. All you see is a quick blink of the screen, which is much less annoying
than Volumio’s reaction.

Have you tried running Volumio in the Firefox or Chrome browsers available in the app store?

I believe this is because newer browsers (Android users have been experiencing this behaviour for some time now) don’t agree with Volumio’s keep-alive function. You can disable it I guess… don’t think any of the volumio developers will support 1.5 anymore, since it’s EOL.

If I’m not mistaken you need to make sure this never happens:

GUI.state = 'disconnected';

Just checked the code a bit, it should be in volumio.api.js:

function backendRequest() { $.ajax({ type : 'GET', url : '_player_engine.php?state=' + GUI.MpdState['state'], async : true, cache : false, success : function(data) { GUI.MpdState = data; renderUI(); $('#loader').hide(); backendRequest(); }, error : function() { setTimeout(function() { GUI.state = 'disconnected'; $('#loader').show(); $('#countdown-display').countdown('pause'); window.clearInterval(GUI.currentKnob); backendRequest(); }, 2000); } }); }

The “$(’#loader’).show();” part is the result of losing the connection and showing the spinner.

I hope you will be able to fix your problem, otherwise you’d have to update (re-image) to volumio 2.0.


Volumio 2 is currently not an option because it has a killing bug on Cubox-i4:


I don’t have a Volumio 1.5 rig anymore, so I think you’re going to have to test it yourself :unamused:
Or maybe someone has a fix lying around somewhere…

This appears to be solved with iOS 10.2.1.

You could try this version from my repo
It is a dev version with latest functionality.
Perhaps it will be available from our website later this week.