Volume, library scan and other issues

Hi eveybody!
My system: RPI 4, 4GB, Volumio version: 2.882; library on external USB HDD; DAC S.M.S.L. M100 MKII.
My settings: mixer type NONE, I have a pre.
My habits: shuffle everything.

My issues:

-Volume normalization/replaygain: the first is costantly adjusting on the fly making the experience a farce, the latter is problably something out of my brain’s reach… I read all the topics about but still I can’t get it to work properly. As it’s not implemented in Volumio, I had to use competitor’s SW to analyze my complete library and set the tags. What happens is that in other players library is just fine, in Volumio is not. If normalization is OFF, MP3 files are soundless other formats are OK, if it’s ON replaygain settings are somehow bypassed… unenjoable (and not very audiophile).

-Library scan at startup, impossible to skip. I tried all the “[SOLVED]” solutions but no luck, so far it’s not huge but it’s growing.

-Sometimes, not always and completely randomic, after a while that there is no interaction between humans and Volumio, the system becomes unreacheable, from official app, from web app, not even possible to ping it; I’m positive my network is OK.
As much as I love my music collection, sometimes I’d like to skip and or repeat a track or search for a specific one without restarting.

-Autostart 1.1.2 plugin: not a big issue but works only when moon is high AND I wear grey socks… Unreliable.

There are actually some other minor issues but I’m confident they’ll eventually be corrected.
I really like Volumio for it’s sound presentation, especially on selected radios or good files.

I’d appreciate if someone could help me despite my lack of linux skills.


Ok, at this point it is pretty clear I won’t get an answer.
Perhaps y’all think I spoke crap about Volumio?
Or perhaps everybody is tired to reply the same things to the same issues and nobody’s getting a solution.
Or just free users issues won’t be fixed because biz is elsewhere.
I get it, no problem.

It’s a pity, because the Volumio has potential and is supposed to do marvelous things.

But it’s heavily bugged on some basic features and everybody seems to look elsewhere, I mean… can’t even control it the I should.

I guess Volumio is fine but not for everyone.


I think you’d get more replies if you set out your problems in a systematic manner, gave more specific information including how to reproduce them, and provided system logs. Your posts are a series of complaints without providing any way for people to follow them up, and investigate. You do appreciate, I presume, that this is a Community forum, with few mind-readers.

Hi chsims1, thanks for your kind answer and for pointing out my mistakes in asking for support.
Maybe it’s semantics or language barrier but i did not mean to post only complaints, sorry anyway.

You see, I am no Linux expert (not even a mind reader myself…), just an audio enthusiast, I don’t know how to extract a log from the machine, some behaviuor of Volumio are randomic, how can I provide anyone a way to reproduce it?
I tried some of the [SOLVED] solutions step by step and no luck on the library scanning issue and looks like I am not the only one frustrated by that.
I do complain because the product is not working as advertised, as simple as that maybe in the wrong Forum section (?).

If the main page stated that you need to be at least at this level of Linux to setup and enjoy Volumio, then I’d have spent money and time somewhere else.

It’s not my intention to demonize this Community, I just don’t fit in.

Thanks again


Gretz JT, fellow Volumio free user here :wink:

Can give you some pointers:

  1. To restrict crystal ball use - Share system logs for debugging.

Preferable from a fresh reboot, with minimal steps to reproduce the problem :slight_smile:

  1. When you need to get down and dirty - How to enable and use ssh.

For your specific problems, I’ve got vague memories of other with the replay gain issues, its an mpd setting, I’ll try and hunt through my old posts, and post back.

Hi ashthespy, thanks for your reply.
I will collect logs ASAP to share here.
As per ssh, I am using putty or powershell or iTerm on OSX, problem is that sometimes Volumio is not reachable, can’t even ping it or find it if I scan the network.