V3 touch screen not rotating 180deg on Waveshare 7"

Hi to all
I installed volumio V3 on raspberry pi 3 b+
i have 7’ Waveshare HDMI (H) 1024x600 screen
when i rotate screen by 180deg in touch screen plugin, picture rotate as required but my touch screen reman in 0deg
i try adding line in config.txt “lcd_rotate=2 or display_hdmi_rotate=2 or display_lcd_rotate=2”
in any combinations but nothing is working for touch screen.
please help.

Please uninstall the plugin and shutdown the rPi.
Locate your screen in the wiki of waveshare.
Follow the instructions given.
If you reboot your pi, check if the rotation and touch orientation are OK. If not follow the instructions from the wiki until it’s ok.
Next install the plugin. Everything should be fine.

Hi and thanks for yr instruction
I did as you suggested and I updated config.txt according to instructions on wiki.
when i again install screen plugin all is normal in 0 deg orientation but when I rotate screen by 180 deg only picture is properly rotated, touch is still in original 0 deg orientation.

you did rotated the screen in the /boot/userconfig.txt if possible? Not via the plugin!!

1 Like

Hi.
I did as you suggested but again there is same result picture is rotated touch remain in 0 position.
I try than adding same
display_lcd_rotate=2
display_hdmi_rotate=2
to config.txt instead to userconfig.txt but results are same.

Please post a link to the instructions for your display.

7inch HDMI LCD (H) (with case) - Waveshare Wiki

Did you go through all provided documents?

And the manual tells how to deal with the touch orientation.

And do this with the touch-plugin uninstalled, so the screen and touch rotation are in sync. Don’t install the plugin until the screen and touch rotation is fixed.

I i did all hat is possible to do in Volumio.
but it is not same as manual explained for since that explanation is for Raspbian
Volumio is missing many of Raspbian functions. see down bellow when i try to follow instructions and enter sudo apt-get install xserver-xorg-input-libinput
“”""""""""""""""""
login as: volumio
volumio@192.168.1.23’s password:
___
/_ \ __
__ __ //\ \ __ __ ___ ___ /_\ ___
/\ /\ \ / __\\ \ \ /\ \/\ \ /' __ __\/\ \ / __
\ \ _/ |/\ \L\ \
\ _\ \ _\ /\ /\ /\ \ \ /\ \L\
\ _
/ \ _//_\ _/\ _\ _\ _\ _\ _/
// // // // /////////___/

         Free Audiophile Linux Music Player - Version 3.0

      © 2015-2021 Michelangelo Guarise - Volumio Team - Volumio.org

Volumio Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Welcome to Volumio for Raspberry Pi (5.4.83-v7+ armv7l)
volumio@volumio:~$ sudo nano /boot/config.txt
[sudo] password for volumio:
volumio@volumio:~$ sudo apt-get install xserver-xorg-imput-libinput
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package xserver-xorg-imput-libinput
volumio@volumio:~$ sudo mkdir /etc/x11/xorg.conf.d
mkdir: cannot create directory ‘/etc/x11/xorg.conf.d’: No such file or directory
volumio@volumio:~$
“”""""""""""""""""""""
sorry i am just beginner.

Ok, different approch. Guess by removing the plugin, also the x11 part is missing.

  • To avoid cascading issues, re-flash your SD with a clean image
  • Run the primary setup for Volumio
  • when finished reboot the system
  • Enable SSH
  • add to the /boot/userconfig.txt
max_usb_current=1
hdmi_force_hotplug=1 
config_hdmi_boost=10
hdmi_group=2 
hdmi_mode=87 
hdmi_cvt 1024 600 60 6 0 0 0
  • reboot the system and observe screen rotation is okay. if you need to rotate add one of the following to the /boot/userconfig.txt.
display_rotate=1 #for 90 deg rotation
display_rotate=2 #for 180 deg rotation
display_rotate=3 #for 270 deg rotation
  • Install the touch-plugin, only enable the mouse pointer, so you have a visible aid on what the touch is doing, after completion reboot the rPi
  • Validate if the touch orientation is in line with the screen if not, proceed
sudo apt-get install xserver-xorg-input-libinput
sudo mkdir /etc/X11/xorg.conf.d
sudo cp /usr/share/X11/xorg.conf.d/40-libinput.conf /etc/X11/xorg.conf.d/
sudo nano /etc/X11/xorg.conf.d/40-libinput.conf

image

  • Depending on the display rotation you set previous, you set the same rotation for the screen
    90 degree: Option “CalibrationMatrix” “0 1 0 -1 0 1 0 0 1”
    180 degree: Option “CalibrationMatrix” “-1 0 1 0 -1 1 0 0 1”
    270 degree: Option “CalibrationMatrix” “0 -1 1 1 0 0 0 0 1”

  • reboot the rPi

Everything should be okay now

Ok I will let you know.

It could be there is race condition when the plugin starts that might be the cause for touch rotation settings made on the plugin’s config page not getting into effect. I am currently investigating it.

Does the plugin take care of the touch rotation, as I had the same issue with my Waveshare screen? Only with mine I could use a hardware function (push button) to rotate the rotation.

Yes.

Touch is working fine with Volumio version 2.917. I installed that on my second SD card and all is fine. but in Volumio V3 there is issue with rotating touch.
It will be ok if I could use normal orientation of screen in my project. unfortunately due to space available I had to rotate screen 180 deg :frowning: now all problems jump out from box.
Presently I am looking for another pc that I can run under Linux and have better control.
(this one is business only and I cant make any alternations)