User web interface not loading


When i restart volumio, the web user interface does not load. I am able to log in via SSH and restart MPD and then it’s all good again.

I’ve also noticed that this only occurs when music is playing and i restart the pi.

Is there a simple solution to this? you’ll have to forgive me i’m not to proficient in linux.


I can confirm this.


I thought I had fixed this behaviour… Maybe a regression of the code…
But to be safe, just stop before rebooting. This should give you no probs

I can also confirm this

I can also add that restarting mpd does not entirely fix the issue, the web interface comes back but a large part of it is not usable, I’m not able to browse the library for instance. I’ve been able to fix this by starting playback, then stopping playback, then rebooting. This is not ideal obviously.

Changing the address mpd binds to in mpd.conf to “” from “any” also seems to have helped.

Try to refresh the page with ctrl+f5 . This is due to apc chache …

I can confirm this as well. I am busy reloading the OS from scratch to see if I can duplicate it. If I can, I will post the results.


I also had this problem. Changing the user in the mpd config file (/etc/mpd) to root and restarting the mpd deamon (/etc/init.d/mpd restart) solved the problem for me. This is however probably not a safe solution…

Great Project btw! I love it!

Same problem. Seems to be very unstable. Runs well and sounds great until I restart, unplug, reboot or leave it unattended for an extended period of time. After which I must re flash the memory chip to get access to the GUI. Access via putty works but doesn’t do me much good. Any advice would be appreciated as I’ve just ordered quality speakers and DAC. Thanks in advance.

Before reboot you have to stop mpd and then reboot or shutdown. If you have problems loading web gui after reboot just ssh into volumio and do service mpd restart and after that all will work. Remember before shutting down or reboot from web gui press stop button and after that do reboot.

Sent from my TF300T using Tapatalk

as I read in one of the other posts a reinstall of mpd helps (apt-get --reinstall mpd). At least it did for me.

I just get “Invalid operation mpd” if I try to reinstall, does any one know a fix for this as I am trying to set it up and just changing a value can cause a loss of the web browser and I have to start from the image file, its really really frustrating. I hate to be so negative on the first post, its a great idea but this bug is a killer for wide adoption, there is no way an uncontrolled shutdown should cause such a complete loss of functionality.

OK should be install added after reinstall but interface still not working so I will reinstall the system for a fourth time.

Reinstalled complete system, tried to set buffer size to 2 as I have an MDAC and it has its own buffer and sqeels with a buffer size of 2048 on volumio, system hangs, reboot through SSH, no volumio, stopping and starting mpd no good either, reinstalled mpd sudo halt restart, one corpse of volumio. Any ideas?

When Mpd restart
Getting error msg. “Mpdfailed to open log file. Var/log/Mpd/Mpd.log. (Config line 11) :permission denied. Failed”
No connection to web ui . Airplay works . Mpd not accessible

Any ideas what happened. It was working fine till now :frowning:

It is not only the Web UI that does not load -all kinds of mpd clients are not able to connect the -in fact- running mpd service!

Strange but true a reinstall of mpd works!

Anyway, the command is: apt-get install --reinstall mpd

And does anyone know if the mpd.conf will be changed in the reinstall? -This may a affect the audio quality a lot :open_mouth: