USB SPDIF not working (Moode has a fix, how?)

I’d liek to run Volumio, but when playing through USB SPDIF mode on my CM6631A based converter I get loads of loud noise.

I had the same with Moode on a lot of streams, but when turning on Moode’s “USB (UAC2) fix” in the system config panel the problem is solved.
The info pane gave the following description: "Try this fix if experiencing audio glitches with USB High Speed (UAC2) audio devices. ".

I’ve love to know how to get Volumio to apply the same fix. It also would be great to know what the fix does exactly. Running Kodi on my raspberry gives exactly the same problem. In SPDIF mode I get loads of noise, in ‘analog’ mode it works, but it locks to 48kHz, so not bitperfect transfer of sound, which is a must have.

Thanks very much in advance to anyone who knows a bit about this!



This fix should “in theory” be obsolete, but I had the same issue with my SMLS DAC.
To fix this basically you need to add dwc_otg.fiq_fsm_mask=0x3 to /boot/cmdline.txt (better in the beginning of the file)

Let me know how it goes

Thank you. I’ve tried it, it does play now, but there are some pops and clicks present, even when overclocking and setting a static clockspeed that does not help. Tried 0x3, 0x7, 0xf.

Tried Moode again and noticed the sound is not perfect there either. On my Windows machine the sound is perfect, but I’ve unfortunately bricked my mainboard during an bios update. :unamused:

This relates to a well know issue of the Raspberry PI USB bus, there’s no solution to that other to resample hi res files to 44\16.
For this device I would suggest using a different platform than PI, preferably X86