USB DAC Error on play "Failed to open audio output"

Hi there,

I have set up Volumio on an Allo Sparky board for use with my USB DAC (a Schiit Audio Gungnir).

I haven’t been able to get Volumio working with the DAC yet. I’m new to Volumio and I was wondering if I might be able to get some pointers on debugging?

I’m able to see the DAC with lsusb:

$ lsusb
Bus 003 Device 003: ID 0d8c:0319 C-Media Electronics, Inc. 

It’s listed with aplay -l:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: atm7059link [atm7059_link], device 0: ATC2603C PCM atc2603c-dai-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: atm7059link [atm7059_link], device 1: HDMI PCM atm7059-hdmi-dai-1 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: atm7059link [atm7059_link], device 2: SPDIF PCM atm7059-spdif-dai-2 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Device [Schiit USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

And I can play wav files with aplay:

$ aplay --device=default:CARD=Device some_file.wav

But I haven’t found a combination of settings yet in the Volumio web ui that will enable me to play.

Any help greatly appreciated.

Thanks!

Simon

Playback options -> audio device :wink:

In Playback Options, I see 2 Output Devices:

  • Audio Out
  • Device

When I select “Audio Out”, I get no errors but also no audio.

When I select “Device” (which I’m thinking is my DAC based on the aplay -l output?), I get “Failed to open audio output” when I try to play a track.

I’ve tried both “Software” and “None” for Mixer Type.

I’ve renamed the topic to make it more specific. Was “USB DAC help”.

I’ve been doing a bit more experimenting and I’ve been able to get the DAC to play on a Raspberry Pi 3:

  • Volumio version: 2.118
  • DAC: Schiit Audio Gungnir via USB
  • SBC: Raspberry Pi 3
  • Output Device: Device
  • Mixer Type: Hardware
  • Mixer Control Name: PCM

However, I’m still having trouble on the Sparky with the same version of Volumio. I am now able to get sound but it’s too slow and only out of the right speaker. Here are those settings:

  • Output Device: Device
  • Mixer Type: Hardware
  • Mixer Control Name: Speaker (there is no “PCM” option as there is on the Pi 3 above)